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Activity: Divide a curve using multiple bounding objects 

Estimated time to complete: 3–6 minutes 

In this activity, you will divide a circle into segments so you can use a curve 

that starts and ends at intersecting curves for creation of a curve mesh surface. 

 

Launch the Divide a curve using multiple bounding objects activity. 
 

 

Open the part and start the curve dividing 

1. Open des18_divide_curve.  

 

2. On the Edit Curve toolbar, click Divide Curve .  

3. In the Divide Curve dialog box, from the Type list, select By Bounding Objects.  

4. Select the circle. 
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Select the bounding objects and then delete the unwanted portion 

1. In the Bounding Object group, with Select Object active, select the lower 

spline.  

 

 

 

2. Select the intersection point you want. 

 

 

3. With Select Object still active, select the upper spline.  
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4. Select the intersection point you want. 

 

 

5. Click OK.  

6. Right-click the arc outside the splines and choose Delete.  

 

 

 

Create a curve mesh surface (optional) 

1. On the Surface toolbar, click Through Curve Mesh .  

2. Select the five short strings of curves as Primary Curves. Make sure they are 

selected as 5 sets (use Add New Set ), and that the directions are all the 

same.  
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3. Select the two long curves as Cross Curves. Make sure they are selected as 2 

sets (use Add New Set ), and that the directions are the same.  

 

 

4. Click OK.  

 

 

You completed the activity. 
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Activity: Create a studio spline to be used as a 
centerline of a tube 

Estimated time to complete: 5–8 minutes 

In this activity, you will create a studio spline to be used as a centerline for a 

connecting hose. You will: 

 Create an associative Through Points studio spline normal to a face of a surface.  

 Edit the surface to see how the associated studio spline behaves. 

 Change the type of the studio spline from a Through Points to a By Poles spline.  

 Modify the degree of the spline and extend one end of the spline. 

 

Launch the Create a studio spline to be used as a centerline of a tube activity.  

 

Create a studio spline to be used as a centerline of a tube 

Open the part and create a Through Points studio spline 

1. Open des18_spline_normal_1.  

 

2. Choose Preferences→Visualization, Visual tab and select the Translucency 

check box.  
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3. On the Curve toolbar, click Studio Spline .  

4. Make sure Type is set to Through Points.  

5. In the Point Location group, expand Constraints.  

6. On the Snap Point toolbar, click Existing Point .  

7. Select the first point for the spline. 

 

The point is associative with the center of the surface 

 

8. Under Constraints, select the Constrain to Attachment Parent check box.  

9. From the Inferred Type list, select Normal.  

This creates a constraint that maintains its tangent to the surface’s natural 

normal. 

10. Continue selecting points to create the spline. 
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Because you selected existing points for the Through Points spline, each 

interior point has a position constraint (G0) and the end points have tangency 

constraints (G1). 

11. Select the G1 Magnitude check box.  

12. In the G1 Magnitude box, type 500 then press Enter.  

This creates a tangency magnitude constraint on the last point. 

 

13. Click Apply.  
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Create a tube using the Studio Spline 

1. Choose Insert → Sweep → Tube.  

2. Select the spline you just created as the path. 

3. In the Outer Diameter box, type 30 then press Enter.  

4. In the Inner Diameter box, type 28 then press Enter.  

5. Click OK 

 

6. Rotate the model around the connection to check for the normal constraint. 
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Modify the Through Curves surface and proportionately update the spline 

The bottom face of the pocket was created using a projected curve to define its 

orientation. You must change the direction of the projection to change the angle of 

the pocket sides. 

Because you want to proportionately update the spline, you will have to remove two 

position constraints to allow those spline points to move. 

1. In the Part Navigator, expand the Cameras node and double-click the start 

camera.  

2. In the Part Navigator, right-click Spline (62) node and choose Edit 

Parameters to edit it.  

3. Position the cursor over the spline point as shown, right-click and select 

Delete G0 from the list.  

 

4. Repeat to delete the position constraint on the next point to the right. 

5. Expand the Settings group and select the Proportional Update check box.  
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When Proportional Update is selected, when you modify the studio spline, all 

the points or poles between the updated point and the next fixed point are 

moved proportionally.  

6. Click OK.  

7. In the Part Navigator, under the Model History node, right-click Fixed Datum 

Axis (43) and select Show.  

8. Still in the Part Navigator, under the Model History node, right-click 

Projected Curve (44) and select Edit Parameters.  

9. In the Project Curve dialog box, in the Projection Direction group, from the 

Specify Vector list, select Inferred Vector .  

10. Select the Datum Axis as the new vector.  

 

11. Click OK.  

12. Once the model has updated, hide the Datum Axis.  

Rotate the model and notice that the tube, which is associated with the 

spline, stays normal at the start point of the spline, which is associative to the 

face of the surface. 

 

Before 
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After 

13. In the Part Navigator, expand the Cameras node and double-click the start 

camera.  

 

Change spline types 

1. On the View toolbar, click See Thru All .  

2. Double-click the spline to edit it. 
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This current condition is reflected in the List.  

 

Tip If you position the cursor over a constraint symbol in the list, constraint 

information is displayed. The balloon above states, Inferred Tangent Parent: 

Face of Through Curves (47) 

3. On the View toolbar, click See Thru All .  

4. Set the Type list to By Poles .  

An Alerts message displays  

The defining data of Through Points type cannot be retained. ‘Undo’ can be 

used at this time to revert the data.  

When you switch from Through Points to By Poles spline type, the through 

points and any internal constraints are deleted.  

Only the start and end constraints are retained. 

 

 

Convert the spline to single segment and change its degree 

It has been decided that the spline is to be a single segment By Poles spline with a 

degree of 3.  

1. In the Parameterization group, select the Single Segment check box.  

2. In the Degree box, type 3 then press Enter.  
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When you specify degree control for a single segment studio spline, the 

number of poles is automatically adjusted depending on the degree you 

specify. 

The apex point of the spline is displayed with the arclength percentage of its 

location on the spline. 

 

Extend the spline 

There is a design requirement to extend the tube beyond its limiting face.  

Since the tube is associated with the spline, you can extend the spline to meet this 

requirements. 

1. In the Extension group, from the Start list, select By Value.  

2. In the Value box, type 7 then press Enter.  

When you extend a studio spline, it creates a natural extension on top of the 

spline.  

 

3. Close the part. 

You completed the activity. 
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Activity: Create a feature pattern using sketch 
references 

Estimated time to complete: 5–8 minutes 

In this activity, you will create a pattern of features that reuses sketch geometry to 

control the length of slots as they traverse around a cylindrical tube. 

 

Launch the Create a feature pattern using sketch references activity.  

 

Open and examine the part 

1. Open des18_pattern_feature_reuse_reference.  

 

The part is made up three extrusions, two that define the main cylinder and 

one for the slot. There is also an edge blend which is suppressed – you will use 

that later in the activity. 
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2. In the Part Navigator, with the cursor over Extrude (15), right-click → Edit 

Sketch.  

3. Rotate the sketch, as shown, and examine the constraints of the slot sketch. 

 

The sketch is constrained dimensionally to the base of the large cylinder using 

a datum plane (1) and tangentially constrained to an angled datum plane (2) 

which also is used to define the elliptical intersection curve (3). 

4. Click Finish Sketch.  

 

Select features to pattern 

1. On the Feature toolbar, click Pattern Feature .  

2. On the rail of the Pattern Feature dialog box, click Reset to reset the 

default dialog box options.  

3. Select Extrude (15).  

The Reference Point is displayed (center of mass). 

 

4. In the Reference Point group, from the Specify Point list, select Intersection 

Point .  
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5. Locate the reference point at the intersection between the upper arc of the 

slot and the intersection curve on the cylinder. 

 

You want the reference point of the initial slot feature to reference the 

intersection curve so as the pattern of features is created, the reference point 

of each instance of the pattern will follow the intersection curve. 

Define directional and orientation parameters 

1. In the Pattern Feature dialog box, in the Pattern Definition group, set Layout 

to Along .  

2. Make sure Path Method is set to Offset.  

3. Select the intersection curve on the large cylinder. 

 

4. In the Direction 1 section, set the following parameters:  

o Spacing = Count and Span 

o Count = 20 

o Location = % Arc Length 

o % Span By = 100 

5. In the Orientation section, set the following parameters:  

o Orientation = Same as Input.  

o Select the Follow Face check box.  
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6. Select the outside face of the large cylinder. 

 

 

Identify reusable references 

1. In the Pattern Method group, make sure Method is set to Variational.  

2. In the Reusable References list, select the check boxes for the two external 

sketch references.  

Extrude  

Entity for csys for for Datum Coordinate System for Extrude  

Sketch External Reference for Extrude  

Sketch External Reference for Extrude  

3. The first sketch reference is to the tangency constraint between the top of the 

slot and the intersection curve. The second sketch reference is to the 

dimensional constraint that controls the height from the floor plane to the 

bottom of the slot. 

4. In the Preview group, click Show Result to check the pattern.  

 

5. Click Undo Result.  

6. Click OK to create the pattern of features.  
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Test associativity of slot geometry 

1. In the Part Navigator, double-click Datum Plane (13) to edit it.  

 

The angle of this datum plane controls the angle of the intersection curve on the 

cylinder. It is currently at a 30 degree angle. 

2. In the Angle type 20. and press Enter.  

 

3. Click OK in the Datum Plane dialog box.  

The pattern feature instances update based on the new angle of the datum 

plane, which controls the intersection curve to which the seed slot is associated. 
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Edit the pattern to add an edge blend to the feature pattern 

There is an edge blend on the initial slot which is suppressed. You want that blend on 

all the instances of the feature that were patterned. 

1. In the Part Navigator, select the Edge Blend check box to unsuppress the 

blend.  

2. In the Part Navigator, double-click the Pattern node.  

3. In the Pattern Feature dialog box, in the Feature to Pattern group, make 

sure Select Feature is highlighted.  

4. In the Part Navigator and using the Ctrl key, select the Edge Blend node so 

that both the extrude feature and the edge blend feature are selected.  

 

Note In the Pattern Feature dialog box, the Select Feature option now has a (2) 

after it, signalling that both the edge blend and extrude features are 

selected.  

5. In the Pattern Feature dialog box, click OK.  

 

The first edge blend is propagated to the other feature instances of the 

pattern. 

6. Close all parts. 

You completed the activity. 
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Activity: Explore object and feature relations with the 
Browser 

Estimated time to complete: 5–7 minutes 

In this activity, you will use the following part to explore some of the uses of the 

Browser.  

 

Launch the Explore object and feature relations with the Browser activity.  

 

Open the browser graph 

1. Open des18_browser.  

 

2. Choose Information→Browser.  

3. In the browser graph background, right-click and make sure the Show 

Expressions check box is selected.  

4. In the browser graph background, right-click and clear the All Relations View 

check box.  

5. In the graphics window, select Extrude (2).  
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6. Notice what is focused in the browser and what is highlighted in the graphics 

window. 

 

The parents are shown to the left, and the children to the right. 

 

Explore the object relationships 

1. In the browser, select Section.  

 

2. In the browser, with the mouse over Section, notice what highlights in the 

graphic window.  

 

3. In the browser, on Section, click the Input parent handle.  

 

4. Notice that Sketch (1) is related.  

 

 

5. In the browser graph, select Extrude (2).  
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Edit some features from the browser 

1. In the browser window, in the Settings group, on the Browse page, make sure 

all three check boxes are selected – Isolate on Select, Center on Select, and 

Animate.  

2. In the browser graph, select Extrude (4).  

3. In the browser graph, select Edge Blend (5), and notice the parent and child 

relationships.  

4. In turn, select Chamfer (6), Edge Blend (7), Edge Blend (8), and Simple Hole 

(9). As you select those features, notice how the display in the browser 

moves.  

5. In the browser window, with Simple Hole (9) highlighted, double-click the 

Diameter dimension expression.  

6. In the Diameter text entry box, type 8 and press Enter.  

 

 

Suppress a feature with the browser 

1. On the browser Settings group, select the Browse tab, and from the drop-

down list, select Icon.  

Notice the browser display. 

 

2. From the Node Style drop-down list, select Icon + Text.  

3. In the browser graph background, right-click and choose All Relations View.  
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4. In the browser graph, double-click Shell (11), and change its Thickness to 2.  

5. In the browser graph, on the Edge Blend (8) feature, clear the check box.  

 

The blend is suppressed. 

6. (Optional): Use the browser to explore the other object relationships in the 

part file. 

7. Close the part. 

You completed the activity. 
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Activity: Create circular and conic edge blends 

Estimated time to complete: 6–9 minutes 

In this activity, you will create circular edge blends and conic edge blends and then 

compare them. 

 

Launch the Create circular and conic edge blends activity.  

 

Open the part and prepare the view 

1. Open des18_blend_enhancements.  

 

2. On the View toolbar, click Clip Work Section .  

 

This will help you better see the blends you create. 

file:///D:/Siemens/NX%208.0/nxcast/html/etmd758/index.html
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Create the first circular edge blend 

1. On the Feature toolbar, click Edge Blend .  

2. From the Shape list, select Circular.  

3. In the Radius 1 box, type 0.18 and then press Enter.  

4. Select the 4 long edges of one of the spokes as shown. 

 

5. Click Apply.  

 

 

Create the second circular edge blend 

1. In the Radius 1 box, type .09 and then press Enter.  

2. On the Selection bar, from the Curve Rule list, select Tangent Curves.  

3. Select any of the edges at the far end of the same spoke, as shown. 

 

4. Click Apply.  
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Create a conic edge blend 

1. From the Shape list, select Conic.  

2. From the Conic Method list, select Boundary and Center.  

3. In the Boundary Radius 1 box, type 0.18 and then press Tab.  

4. In the Center Radius 1 box, type .06 and then press Enter.  

5. Select the 4 long edges of the unblended spoke as shown. 

 

6. Click Apply.  

 

 

Create another conic edge blend 

1. In the Boundary Radius 1 box, type .09 and then press Tab.  

2. In the Center Radius 1 box, type .04 and then press Enter.  

3. Select any of the edges at the small end of the spoke. 

 

4. Click OK.  
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Compare the blends 

1. Rotate the part and compare the conic edge blends with the circular edge 

blends. 

 

Notice the conic blends appear smoother at the edges of the blended faces. 

You completed the activity. 
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Activity: Replace a feature with one of its 
dependencies 

Estimated time to complete: 8–12 minutes 

In this activity, you will create a face blend and then sew the surfaces together. Next 

you will create a surface offset from one of the original surfaces. Finally you will 

replace the original surface with the offset surface. The previous dependent features 

will also be moved to the replacement feature. 

 

Launch the Replace Feature activity.  

 

Start the face blend 

1. Open des18_replace_feature.  

 

2. On the Features toolbar, click Face Blend .  

3. From the Type list, select Two Defining Face Chains.  

4. With Select Face Chain 1 active, select the upper surface.  
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31 
 

 By Design Through Manufacturing Co., Ltd.  
 

5. If the direction arrow is not pointing toward you and to the left, click Reverse 

Direction or double-click the arrow.  

 

Complete the face blend 

1. With Select face Chain 2 active, select the lower surface.  

 

2. If the direction arrow is not pointing up, double-click the arrow. 

3. In the Cross-Section group, from the Radius Method list, select Tangency 

Constraint.  

4. In the Constraining and Limiting Geometry group, with Select Tangent Curve 

active, select the curve on the upper surface.  

 

5. In the Trim and Sew Options group, clear the Sew All Faces check box.  

6. Click OK.  
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Sew the surfaces together and make the first enlarge surface the current 
feature 

1. On the Feature toolbar, from the Combine drop-down list, select Sew  

2. From the Type list select Sheet.  

3. Select any surface as the Target, select the other two as the Tool, and click 

OK.  

 

4. In the Part Navigator, right-click Enlarge Surface (16), and choose Make 

Current Feature.  

 

Create an offset surface 

1. On the Feature toolbar, click Offset Surface .  

2. With Select Face active, select the face of Enlarge Surface (16).  

 

3. If the direction arrow is not pointing away from you, reverse its direction by 

double-clicking it. 

4. In the Offset 1 box, type 250 .  

5. Click OK.  
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6. In the Part Navigator, right-click Sew (10), and choose Make Current Feature.  

 

Replace the original surface and its dependent features with the offset 
surface 

1. In the toolbar area, right click and activate the Edit Feature toolbar.  

2. On the Edit Feature toolbar, click Replace Feature .  

3. Select Enlarge Surface (5) as the feature to replace.  

 

4. Click the middle mouse button. 

5. Select the offset surface. 

 

Map the new parents to the original parents 

1. Click the middle mouse button. 

2. In the Original Parent list, make sure Face for Offset in Face (8) is selected.  

3. In the Replacement Feature window select the replacement face. 

4. In the Original Parent list, highlight Curve for Offset in Face (8).  
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5. in the Replacement Feature window select the bottom edge of the surface. 

Make sure the direction arrow is the same as the original. 

6. Click OK.  

 

You completed the activity. 
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Activity: Create an extruded feature by referencing 
other feature dimensions 

Estimated time to complete: 3–5 minutes 

In this activity, you will create an extruded feature by selecting other feature 

parameters references from the graphic window. You will then test the associativity. 

 

Launch the Extrude referencing feature dimension activity.  

 

Select the area to extrude 

1. Open des18_dimension_references.  

 

2. On the Features toolbar, click Extrude .  

3. In the Extrude dialog box rail, click Reset .  

4. On the Selection bar, from the Curve Rule list, select Region Boundary 

Curves.  

file:///D:/Siemens/NX%208.0/nxcast/html/etmd758/index.html
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5. In the Section group, with Select Curve active, select the portion of the face 

inside the curves.  

 

Select the dimensions from a different feature 

1. In the Limits group, from the End  

Distance parameter list, choose Reference.  

2. In the graphics window, select the extruded boss. 

 

3. Select the boss height dimension. 

 

4. Expand the Draft group, and from the Draft list, choose From Section.  

5. In the Draft group, from the Angle parameter list, choose Reference.  

6. In the graphics window, select the draft angle dimension. 
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7. Click OK, and then press F5 to refresh the screen.  

 

Edit the referenced feature 

1. In the graphics window, double-click the extruded boss feature. 

 

2. In the Edit Parameters dialog box, choose Feature Dialog.  

3. In the End Distance box, type 16 and press Enter.  

4. Click OK twice.  

 

Notice both the extrusions changed. 

You completed the activity. 
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Activity: Create a bridge surface with offsets 

Estimated time to complete: 3–5 minutes 

In this activity, you will create a bridge surface between offset edges and limits. You 

will create section curves for two of the limits. 

 

Launch the Create a bridge surface with offsets activity.  

 

Begin creating section curves 

1. Open des18_bridge_offsets.  

 

2. On the Curve toolbar, click Section Curve .  

3. In the Section Curve dialog box, from the Type list, select Selected Planes.  

4. In the Object to Section group, with Select Object active, select the large 

surface.  

 

 

file:///D:/Siemens/NX%208.0/nxcast/html/etmd758/index.html


39 
 

 By Design Through Manufacturing Co., Ltd.  
 

Complete the section curves 

1. In the Section Plane group, from the Specify Plane options list, select 

Through Object .  

2. Select the far edge of the small surface. 

 

3. Click Apply.  

 

4. With Select Object active, select the large surface.  

 

5. Click Specify Plane and select the near edge of the small surface.  
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6. Click OK.  

 

 

Create a bridge surface 

1. Choose Insert → Detail Feature → Bridge.  

2. With Select Edge 1 active, select the top edge of the large surface.  

 

3. Drag the % Offset handle to 50.  

 

4. With Select Edge 2 active, select the front edge of the small surface.  
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5. Drag the % Offset handle to 30.  

 

Adjust the bridge surface limits 

1. In the Selection bar, make only Intersection Point active.  

2. Drag the % Start handle to the right to the intersection point.  

 

3. Drag the % End handle to the left to the intersection point.  

 

4. In the Constraints group, under Continuity, set both Edge 1 and Edge 2 to G2 

(Curvature).  

5. In the Constraints group, under Flow Direction, from the Edge 1 and 2 list, 

select Isoparametric.  
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6. Click OK.  

 

You completed the activity. 
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Activity: Compare swept options 

Estimated time to complete: 5–8 minutes 

In this activity you will create swept surfaces and compare some of the options 

available. 

 

Launch the Compare swept options activity.  

 

Set the dialog box 

1. Open des18_swept.  

 

2. On the Surface toolbar, click Swept .  

3. In the Swept dialog box rail, click Reset to reset the dialog box to the 

default settings.  
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Create the swept surface 

1. In the Sections group, with Select Curve active, select the arc on the left.  

 

2. Click the middle mouse button or in the Sections group, click Add New Set 

.  

3. Select the large arc in the center. 

 

4. Click the middle mouse button or click Add New Set .  

5. Select the ellipse on the right. 

 

6. Make sure all the direction arrows are pointing in the same direction. 

7. Click Select Curve.  

8. Select the line. 
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Notice the linear interpolation between the section curves. 

 

Change the interpolation 

1. In the Section Options group, from the Interpolation list, select Cubic.  

 

Notice the start and end of the surface are normal to the section curves. 

2. From the Interpolation list, select Blend.  

 

Notice the change in shape. 

3. Click the middle mouse button twice or click OK.  
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Change the layer settings 

1. On the Utility toolbar, click Layer Settings .  

2. In the Work Layer box, type 82 and then press Enter.  

3. Clear the layer 42 and 81 check boxes.  

4. Select the layer 43 check box, and click Close.  

 

Create another swept surface 

1. In the graphics window, right click and choose Repeat Command→Swept, or 

on the Surface toolbar, click Swept .  

2. Select the arc on the left. 

 

3. Click the middle mouse button twice, or in the Guides (3 Maximum) group, 

select Select Curve.  

4. Select the curve as shown. 

 

5. Click the middle mouse button or click Add New Set .  
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6. Select the far large arc. 

 

7. Click the middle mouse button or, click Add New Set .  

8. Select the spline between the two guides. 

 

9. Make sure all the guide direction arrows are pointing in the same direction and 

click the middle mouse button or click OK.  

 

Notice the shape of the surface—it lies on all three guide curves. 

 

Use the different scaling methods 

1. In the graphics window, double-click the swept surface you just created. 

2. In the Guides (3 Maximum) group, expand the list, and select Guide 3.  
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3. Click Remove .  

 

Notice the shape of the surface. 

4. In the Scaling Method group, from the Scaling list, select Lateral.  

 

Notice the shape of the surface. 

 

Use another curve for scaling 

1. From the Scaling list, select Another Curve.  

2. Select the spline, and click the middle mouse button, or click OK.  
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3. On the View toolbar, click See-Thru All .  

 

4. Compare shape of the curve selected for scaling and the shape of the surface. 

5. Click See-Thru All to turn it off.  

You completed the activity. 
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Activity: Create and edit an extension surface 

Estimated time to complete: 3–4 minutes 

In this activity, you will create an extension surface, edit its shape, and then move 

one of the curves that drive the original Through Curve surface. 

 

Launch the Create and edit an extension surface activity.  

 

Create an extension surface 

1. Open des18_extension.  

 

2. On the Surface toolbar, from the Flange Surface drop-down list, click 

Extension Surface .  

3. Make sure Edge is selected from the Type list, and with Select Edge active, 

select the left edge of the surface.  
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4. In the Extension group, from the Method list, choose Circular.  

5. Drag the Length handle to 8.  

 

6. Click the middle mouse button, or click OK.  

 

Edit the extension 

1. Double-click the extension you just created. 

 

2. From the Method list, choose Tangential.  

3. Drag this Distance handle to 7, and click OK.  

 

Move one of the parent curves of the through curve surface 

1. On the menu bar, click Edit→Move Object.  

2. Select the two splines at the left end of the original Through Curves surface. 

 

3. From the Motion list, choose Distance.  

4. From the Specify Vector drop-down list, choose XC.  
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5. Type a Distance value of 10, and then press Enter.  

6. Click the middle mouse button, or click OK.  

 

You completed the activity. 
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Activity: Rebuild a law extension surface 

Estimated time to complete: 2–3 minutes 

In this activity, you will use Law Extension to create an extension from a base sheet 

and examine the updated Rebuild options for the law extension surface.  

 

Launch the Rebuild a law extension surface activity.  

 

Open the part and show the poles of the surface 

1. Open des18_keep_parameterization_3.  
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2. With the cursor in a blank area of the graphics window, right-click and hold 

until the radial menu appears, then hover over Shaded with Edges and 

release.  

 

 

3. If the Analyze Shape toolbar is not available, position the cursor in an empty 

area of a toolbar and right-click and select Analyze Shape to display the 

toolbar.  

4. Select the curved surface as shown. 

 

5. On the Analyze Shape toolbar, click Show Poles .  
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6. Shift-select the surface to deselect it. 

 

 

Create an law extension surface 

1. On the Surface toolbar, choose Law Extension .  

2. Select the base profile curve. 
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3. Click the middle mouse button. 

4. Select the reference face. 

 

5. In the Length Law group:  

o Make sure Law Type is set to Constant.  

o In the Value box, key in 50 then press Enter.  

6. In the Angle Law group:  

o Make sure Law Type is set to Constant.  

o In the Value box, key in 180 then press Enter.  
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7. On the Analyze Shape toolbar, click Show Poles .  

8. In the Law Extension dialog box, expand the Preview group and click Show 

Result .  

Notice that the poles of extension surface do not match with the poles of the 

parent surface. This is because there are no rebuild settings in effect. 

 

9. Click Undo Result .  

 

Check Rebuild settings  

1. Expand the Settings group.  

Notice that the Merge Faces if Possible check box is selected and that 

Rebuild is set to None.  

2. From the Rebuild list, select Degree and Tolerance.  
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3. Click Show Result .  

 

Degree and Tolerance lets you specify the maximum degree and the 

tolerance to control the parameterization of the output surfaces.  

4. Click Undo Result .  

5. From the Rebuild list, select Auto Fit.  

6. Notice the Alerts message.  

7. Click Show Result .  

 

Auto Fit creates the smoothest possible surface within the specified 

tolerances.  

You can specify Maximum Degree and Maximum Segments to rebuild the 

surface without adding segments up to the maximum degree.  

8. Click Undo Result .  

9. Clear the Merge Faces if Possible check box.  

The Rebuild option of Keep Parameterization is not available unless the Merge 

Faces if Possible check box is selected. 
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10. From the Rebuild list, select Keep Parameterization.  

11. Click Show Result .  

 

Keep Parameterization inherits the degree, segments, pole structure and 

knot structure from the input surfaces and applies it to the extension surface.  

Keeping the parameterization between input curves and derived surface 

allows working in both mesh and sweep based workflows and a pole editing 

based workflow. 

12. Click OK to create the law extension.  

13. (Optional) On the Analyze Shape toolbar, use Show Poles to turn off the 

pole display and Face Analysis - Reflection to add the law extension 

surface to the reflection display.  

 

14. Close the part. 

You completed the activity. 
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Activity: Compare Delete Edge with Untrim 

Estimated time to complete: 2–3 minutes 

In this activity, you will use both the Untrim and the Delete Edge commands to 

remove edges of a surface. You wilt then compare the results.  

 

 Untrimmed  

 Edges deleted  

Launch the Compare Delete Edge with Untrim activity.  

 

Untrim the surface 

The objective is to remove some of the edges of a surface. You will use both Untrim 

and Delete Edge and compare the results.  

1. Open des18_delete_edge.  

 

2. Choose Insert→Trim→Untrim.  

3. Select the face. 

 

4. In the Settings group, clear the Hide Original check box.  
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5. Click the middle mouse button, or click OK 

 

Notice most of the edges changed. 

 

Delete some edges of the original surface 

1. Choose Insert→Trim→Delete Edge.  

2. From the Curve Rule list, choose Tangent Curves.  

3. Select any curve in the notch area. 

 

 

4. Select any curve at the edge of the hole. 

 

 

5. Click the middle mouse button, or click OK.  
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6. Compare the untrimmed surface with surface with the removed edges. 

 

Notice that only the selected edges were untrimmed. 

You completed the activity. 
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Activity: Create a variable offset surface 

Estimated time to complete: 4–8 minutes 

In this activity, you will create a variable offset surface with different offset locations 

and values. 

 

Launch the Create a variable offset surface activity.  

 

Open and set the object preferences 

1. Open des18_variable_offset.  

 

This is a curve mesh surface. All the generating sketches, curves, planes and 

axes are hidden. 

2. Choose Preferences→Object.  

3. In the Object Preferences dialog box, on the General page, set the 

Translucency slider to approximately 50 percent.  

This will make it easier to compare the offset surface that you create with the 

original. 

4. Click the middle mouse button, or click OK.  

 

Select the base surface and set some the offset parameters 

1. Choose Insert→Offset/Scale→Variable Offset .  
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2. In the Variable Offset dialog box rail, click Reset to reset the dialog box to 

its default settings..  

3. In the Offset group, select the Apply to All check box.  

4. In the Offset at A entry box, type 4, and then press Enter.  

5. Select the face of the surface. 

 

6. Rotate the view so you can better see the surfaces. 

 

Specify the offset locations and values 

1. Drag the offset handle shown below to 7.  

 

Notice the 0.024 value in black at one corner. This is the location and value of 

the maximum deviation of the fitted surface from the true offset surface. If 

the value exceeds the Modeling Distance tolerance, it is displayed in red.  

2. Clear the Apply to All check box.  
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3. Drag the offset handle shown below to 12.  

 

4. On the Selection bar, make sure only Point on Curve is active.  

5. Drag the origin handle along the edge, approximately as shown below. 

 

6. Drag the offset handle shown below to 5.  

 

Change a parameter and complete the offset 

1. In the Settings group, from the Method list, select Cubic.  
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Notice the shape of the edges of the previewed surface. 

2. Click the middle mouse button, or click OK.  

3. Rotate and examine the two surfaces. 

 

You completed the activity. 
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Activity: Delete faces 

Estimated time to complete: 3–5 minutes 

In this activity, you will delete a face without trimming the surrounding faces so that a 

new face can be sewn in its place. 

 

Launch the Delete faces activity.  

 

Delete faces 

You need to create a bump in the roof of this race car. 

1. Open syn2_delete_faces.  

2. On the Synchronous Modeling toolbar, click Delete Face .  

3. In the Delete Face dialog box, in the Settings group, select the Heal check 

box.  

4. Select the three faces as shown, and click OK.  

 

file:///D:/Siemens/NX%208.0/nxcast/html/etmd758/index.html


68 
 

 By Design Through Manufacturing Co., Ltd.  
 

With Heal selected NX attempts to close the hole by extending the surrounding 

faces. In this example NX is unable to extend these faces. For this activity you 

need to delete the faces without healing the surrounding faces because you 

want to use a new face in its place.  

5. In the Delete Face message box, click OK.  

6. In the Delete Face dialog box, in the Settings group, clear the Heal check 

box, and click OK.  

The three faces have been deleted and the surrounding faces have not 

changed. A new face can be created and sewn into the existing body. 

 

Sew in new faces 

1. In the Part Navigator, right-click Through Curves (63) and select Show.  

2. On the Feature toolbar, from the Combine Drop-down list, select Sew .  

3. Select the face as shown. 

 

4. Select the face as shown, and click OK.  
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The bump is now part of the race car roof. 

 

Blends and other changes can be made to the new body. 

 

5. Close the part. 

You completed the activity. 
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Activity: Edit Cross Section 

Estimated time to complete: 8–12 minutes 

In this activity, you will modify an extruded aluminum part that has no feature history. 

You will create a cross section through the part and modify the cross section in a 

sketch. 

 

Launch the Edit Cross Section activity.  

 

Define a section 

First you will edit the part’s cross section in History-Free Mode. Later you will edit the 

part’s cross section in History Mode. 

1. Open syn2_edit_cross_section.  

 

2. On the Synchronous Modeling toolbar, make sure History-Free Mode is 

selected.  

3. On the Synchronous Modeling toolbar, click Edit Section .  
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4. In the Cross Section Edit dialog box, from the Type list, select On Plane.  

5. In the Sketch Plane group, from the Plane Method list, select Create Plane.  

6. Select the X-Y Datum Plane as shown.  

 

7. To advance to defining the horizontal reference of the sketch, click the 

middle mouse button. 

Notice that Select Reference is now highlighted in the dialog box.  

8. Select the X Datum Axis as shown.  

 

9. To accept the sketch plane and enter the Sketch task environment, click the 

middle mouse button. 
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Edit the sketch 

1. On the Sketch Tools toolbar, click Auto Constrain .  

2. In the Auto Constrain dialog box, in the Constraints to Apply group, select 

the following check boxes:  

o Horizontal 

o Vertical 

o Collinear 

o Coincident 

3. To select all the curves in the sketch, press Ctrl+A. 

 

4. To create the constraints, click the middle mouse button. 

On the Sketch Tools toolbar, if Show All Constraints is turned on, you 

will see the geometric constraints that have been created.  

 

5. On the Sketch Tools toolbar, click Inferred Dimensions .  
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6. Select the horizontal line as shown. 

 

7. Click a screen position to locate the dimension origin. 

 

8. In the on-screen input box, type 20 and press Enter.  

 

9. Right-click in the background of the graphics window and choose Finish 

Sketch .  

 



74 
 

 By Design Through Manufacturing Co., Ltd.  
 

Because the solid body has been modified in History-Free Mode, the sketch used to 

cross section the part is deleted. If you want NX to maintain the sketch and the 

constraints, use the Edit Cross Section command in History Mode.  

 

Edit the part in History Mode 

1. On the Synchronous Modeling toolbar, click History Mode .  

2. In the Modeling Mode message box, click Yes.  

3. On the Synchronous Modeling toolbar, click Edit Cross Section .  

4. To select all the faces, press Ctrl+A . 

 

5. To advance to defining the cross section plane, click the middle mouse button. 

Notice that Select Plane is now highlighted in the dialog box.  

6. Select the X-Y Datum Plane as shown.  

 

7. In the Edit Cross Section dialog box, in the Preview group, clear the Preview 

check box.  
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8. In the Section Curve group, click Section to enter the Sketch task 

environment.  

 

9. To make the sketch easier to visualize, in the Part Navigator, right-click Body 

(1)and choose Hide.  

 

Edit the sketch 

1. On the Sketch Tools toolbar, click Auto Constrain .  

2. In the Auto Constrain dialog box, in the Constraints to Apply group, select 

the following check boxes:  

o Horizontal 

o Vertical 

o Collinear 

o Coincident 

3. To select all the lines us the sketch, press Ctrl+A. 
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4. To create the constraints, click the middle mouse button. 

On the Sketch Tools toolbar, If Show All Constrains is turned on, you will 

see the geometric constraints that have been created.  

 

5. On the Sketch Tools toolbar, click Constraints .  

6. Select the vertical line as shown. 

 

7. Select the vertical line as shown. 
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8. Right-click one of the selected lines and choose Collinear .  

 

9. Make the two vertical lines as shown collinear. 

 

 

10. You can continue to constrain the sketch or go to the next step. 
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11. When you finish adding constraints, right-click in the background of the 

graphics window and choose Finish Sketch .  

 

12. In the Edit Cross Section dialog box, click OK to complete the edits.  

13. In the Part Navigator, right-click Body (1) and choose Show.  

 

Edit the existing cross section sketch 

1. To edit the cross section, double-click the face as shown. 

 



79 
 

 By Design Through Manufacturing Co., Ltd.  
 

2. In the Edit Cross Section dialog box, in the Preview group, select the Preview 

check box.  

 

3. To enter the Sketch task environment, in the Section Curve group, click 

Section .  

 

4. Edit one of the sketch dimensions or constraints you created, or create a 

dimension or constraint. 
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5. When you finish editing the sketch, right-click in the background of the 

graphics window and choose Finish Sketch .  

 

6. To complete the edits, in the Edit Cross Section dialog box, click OK.  

 

You can use the Edit Cross Section command in History Mode to add design 

intent to models with or without feature history.  

7. Close the part now or close all parts when you exit the session. 

You completed the activity. 
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Activity: Reorder Blends 

Estimated time to complete: 3–5 minutes 

In this activity, you will change the order of blends in a molded part without feature 

history. Using the Reorder Blends command lets you change the order of two 

intersecting blends of opposite convexity without deleting and recreating blends.  

 

Launch the Reorder Blends activity.  

 

Reorder Blends 

1. Open syn2_reorder_blends.  
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2. On the Synchronous Modeling toolbar, from the Detail Feature Drop-down 

list, click Reorder Blends .  

3. Select the blend face as shown. 

 

NX selects the Blend Face 2 and displays the preview of the change.  

 

4. In the Reorder Blends dialog box, click Apply.  
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5. Select the blend face as shown. 

 

6. In the graphics window, click the middle mouse button to click Apply.  

 

7. Reorder the two blends in the underside for the part. 
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8. Close the part now or close all parts when you exit the session. 

You completed the activity. 
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Activity: Project curves to a sketch 

Estimated time to complete: 3–5 minutes 

In this activity, you will: 

 Add a sketch feature to an unparameterized part. 

 Associatively project curves from the unparameterized part into the sketch and 

use them to create a feature. 

 Modify the part in such a way that the sketch-based feature updates. 

 

Launch the Project curves to a sketch activity.  

 

Project the groove edges to a sketch 

1. Open skt13_project_curves.  

2. On the Direct Sketch toolbar, click Sketch .  

3. In the Create Sketch dialog box, from the Type list, select On Plane.  

4. Select the datum plane shown and click OK.  

 

5. On the Direct Sketch toolbar, from the Curve from Curves Drop-down list, 

select Project Curve .  
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6. In the Project Curve dialog box title bar, click Reset to return the dialog 

box and the Selection Bar to the default settings.  

7. In the Settings group, make sure the Associative check box is selected.  

8. Select any curve on the edge of the inner groove. 

 

9. From the on-screen Curve Rule Drop-down list , select Tangent Curves 

.  

 

The tangent edges are selected. You get this same result had you selected 

Tangent Curves from the Curve Rule list on the Selection bar before you 

selected the edge.  

 

10. Click OK 

NX projects the curves to the sketch plane. 
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Extrude the sketch and modify the part 

1. On the Direct Sketch toolbar, click Arc .  

2. Create an arc that closes the projected profile. 

As you create the arc, be sure to infer a tangent constraint with the top edge 

of the solid body as shown. 

 

 

 

3. On the Feature toolbar, click Extrude .  

4. In the Limits group, for both Start and End, select Until Selected and select 

the datum planes as shown.  
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5. On the Synchronous Modeling toolbar, click Move Face .  

6. Select the face shown. 

 

7. In the Transformation group, from the Motion list, select Distance.  

8. Drag the handle into the part as shown. Click OK to complete the move face 

command.  
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Because the sketch appears before the Move feature in Timestamp order, the 

sketch and extrude do not update.  

 

9. In the Part Navigator, drag Move Face (8) before Sketch (6).  

 

NX updates the sketch curves and the extrude feature. 

10. Close the part now or close all parts when you exit the session. 

You completed the activity. 
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Activity: Zero length lines in a sketch 

Estimated time to complete: 3–5 minutes 

This extruded aluminum heat sink needs to be configured for three different 

assemblies. The three different cutout configurations shown below can be made with 

the same sketch. In this activity, you will: 

 Add a dimension to a sketch. 

 Edit the dimension value to equal zero. 

 See that a Perpendicular dimension maintains its direction when the expression 

value is set to zero.  

 See that you can have zero length lines in a sketch. 

 

Launch the Zero length lines in a sketch activity.  

Add sketch dimension 

1. Open skt10_sketch_dimensions.  
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2. Double-click the sketch as shown to open it for edit. 

 

3. On the Direct Sketch toolbar, click Inferred Dimensions .  

4. Select the horizontal line as shown. 

 

5. Select the short horizontal line as shown. 
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6. Click to place the dimension. 

 

7. In the on-screen input box, type 5 and press Enter.  

 

8. Right-click in the background of the graphics window and choose Finish 

Sketch .  

 

Edit sketch dimension 
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1. In the Part Navigator, click Sketch (10).  

 

2. In the Part Navigator, expand Details.  

3. In the Expression column double-click p55=5, type 0 and press Enter.  

The notch has moved to the bottom of the sketch and the lower short vertical 

line is removed. 

 

4. In the Expression column double-click p55=0, type 9 and press Enter.  

The notch has moved to the top of the sketch and the lower short vertical line 

appears. 



94 
 

 By Design Through Manufacturing Co., Ltd.  
 

 

5. Close the part now or close all parts when you exit the session. 

You completed the activity. 
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Activity: Create a general pattern in a sketch 

Estimated time to complete: 5–8 minutes 

In this activity, you will pattern the existing sketch to add bolt clearance pockets on a 

brake caliper. 

 

Launch the Create a general pattern in a sketch activity.  

 

Pattern sketch curves 

Edit the existing sketch. 

1. Open skt13_general_pattern.  

2. Double-click any curve in the sketch to open it for edit. 

 

3. On the Direct Sketch toolbar, from the Curve from Curves Drop-down list, 

select Pattern Curve .  
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4. From the Curve Rule list, select Connected Curves.  

5. Select the sketch curves to pattern as shown. 

 

6. In the Pattern Curve dialog box, in the Pattern Definition group, from the 

Layout list, choose General.  

7. In the From section, click Specify Point.  

8. On the opposite side of the part, select the arc center of the edge shown. 

 

 

9. Select the arc center of the edge as shown for To location.  
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10. Select the remaining two arc centers of the edges as shown for additional To 

locations.  

 

11. In the Pattern Curve dialog box, in the Pattern Definition group, clear the 

Lock Orientation check box.  

Because the patterns were created with the lock orientation check box 

cleared, you can set the rotation angle for each pattern. 

 

Constrain patterns 

Constrain the rotation angle for each pattern. 

1. On the Direct Sketch toolbar, click Inferred Dimensions .  

2. Select the Y-Z datum plane as shown. 

 

 

 

 

 

 



98 
 

 By Design Through Manufacturing Co., Ltd.  
 

3. Select the sketch curve as shown between the end points, and click to indicate 

the dimension origin. 

 

4. In the on-screen input box, type -15, and press Enter.  

 

Note You can enter a negative value for angle dimensions to get the alternate 

angle. 

5. On the Direct Sketch toolbar, click Constraints .  

6. Select the sketch curve as shown. 
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7. Select the second sketch curve as shown. 

 

8. Right-click one of the selected curves and choose Parallel .  

 

9. Select the sketch curve as shown. 

 

10. Select the second sketch curve as shown. 
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11. Right-click one of the selected curves and choose Parallel .  

 

12. In the background of the graphics window, right-click and choose Finish 

Sketch .  

 

In the Part Navigator, the Extrude (6) node has an information alert icon .  

13. Move your cursor over the Extrude (6) feature to display the Information 

window.  
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When the original extrude feature was created, the selection curve rule was 

set to Feature Curves. Curves that were added to the sketch were also be 

added to the extrude feature.  

14. To close the Information window, right-click the Extrude (6) node and choose 

Clear Feature Info Alerts.  

 

Edit hole locations 

The through holes, and therefore the sketch patterns, are not located correctly. You 

need to change the hole locations. The patterns are associative to the hole locations 

and will be updated when the holes move. 

1. In the Part Navigator, right-click the Simple Hole and choose Edit Sketch.  

 

2. On the Sketch Tools toolbar, click Make Symmetric to create a symmetric 

constraint between the inner and outer two holes.  

3. Select the point as shown for Primary Object.  

 

4. Select the point as shown for Secondary Object.  
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5. Select the datum axis as shown for Symmetry Centerline.  

 

 

6. Create another symmetric constraint between the outer two points. 
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Note The automatic dimensions on the two left points are removed because the 

symmetric constraint now applies. 

7. Right-click in the background of the graphics window and choose Finish 

Sketch .  

The sketch patterns are associative to the hole centers and are now located 

correctly. 

 

8. Close the part now or close all parts when you exit the session. 
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Edit patterns 

The sketch patterns are associative to the original curves. You need to edit one of the 

sketch dimensions to allow for a larger bolt head clearance. 

1. In the Part Navigator, select the Sketch node.  

2. In the Part Navigator, expand the Details panel.  

3. In the Details panel, slowly double-click the p13=4 expression, type 5 and 

press Enter.  

 

All four patterns and extrusions now have larger radii to accommodate a larger bolt 

head clearance. 

You completed the activity. 
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Assembly 
 

 
 
 

 
 

1. Open the part 
Open asm3_ws_assembly_1 loading all components with Use Partial Loading.  

1.1 On the Standard toolbar, click Open .  
1.2 In the Open dialog box, click Options. The Assembly Load Options dialog box appears.  

1.3 In the Part Versions group, expand the Load list and select From Folder.  

1.4 In the Scope group, expand the Load list and select All Components.  

1.5 Ensure that the Use Partial Loading check box is selected.  

1.6 Click OK.  

1.7 Open asm3_ws_assembly_1.  

 
 

 

Constraint Navigator  
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2. Review the assembly 
2.1 Open the Assembly Navigator. 
2.2 Notice there are 2 subassemblies and a component. 

 
 

2.3 In the Assembly Navigator, expand the sub-assemblies.  
2.4 Observe that the top level assembly and both sub-assemblies have Constraints nodes. 

 

 

3. Review top level assembly constraints 
3.1 In the Resource Bar, click the Constraint Navigator and pin it open. 
3.2 Below the last constraint listed, right-click and choose Group by Constraints. 

This setting lists the constraints by pairs of components. Also notice that the constraints are 
only listed for the Work Part. 

 
 

 

4. Group constraint status 
4.1 In the Constraint Navigator below the last constraint listed, right-click and select Group by 

Constraint Status. 
4.2 Observe that the navigator lists by status. 
4.3 Expand Status = OK (7). 

Now you see the same constraints as before. 
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5. Group by inherited 

5.1 In the Assembly Navigator, double-click asm3_ws_sub_assm_2 to make it the work part. 

5.2 Return to the Constraint Navigator. 

5.3 In the Constraint Navigator below the last constraint listed, right-click and select Group by 

Inherited. 

 
 

5.4 Observe that there are no inherited constraints. 

5.5 Expand Created in Work Part (14). 

Listed are all of the constraints of the sub-assembly. 
 

 
 

 

 

6. Group by components 

6.1 In the Constraint Navigator below the last constraint listed, right-click and select Group by 

Components. 

 
 

6.2 Observe the Status column. Notice that one of the angle components is fixed and the other is 
fully constrained. The rest of the components are partially constrained. 
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6.3 Expand asm3_cn_pulley_1. 

 
 

6.4 Click Align (ASM3_CN_PULLEY_1, ASM3_WS_ANGLE_1). 

6.5 Observe in the graphic window that the constraint is highlighted. 

 
 

6.6 Review the other 2 constraints of the pulley. 

With a little interrogation you can see that the pulley rotation is not constrained, thus the pulley 
is partially constrained. 

 

 

7. Group by component status 

7.1 In the Constraint Navigator below the last constraint listed, right-click and select Group by 

Component Status.  

 
 

 

 

 

8. Group by component level 

8.1 In the Assembly Navigator, double-click asm3_ws_assembly_1 to make it the work part. 

8.2 In the Constraint Navigator below the last constraint listed, right-click and select Group by 

Component Level. 
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8.3 Expand Child Components of Work Part (3). 

This grouping allows the investigation of constraints at the component level. 

 
 

8.4 Expand asm3_ws_sub_assm_1. 

 
 

8.5 Click Touch (ASM3_WS_SUB_ASSM_1, ASM3_WS_PLATE_1). 

8.6 Observe in the graphic window that the top of the plate becomes highlighted. 

Since this is a Touch constraint, you could assume that it is constrained to the bottom of one 
of the angle components. 

8.7 Click of the Align (ASM3_WS_SUB_ASSM_1, ASM3_WS_PLATE_1) constraints. 

8.8 Observe in the graphic window that 2 holes are highlighted, 1 in the plate and 1 in the angle. 

8.9 Click the other Align (ASM3_WS_SUB_ASSM_1, ASM3_WS_PLATE_1) constraint. 

8.10 Observe in the graphic window that 2 holes are highlighted, 1 in the plate and 1 in the angle. 

Now it’s easy to see how the ASM3_WS_SUB_ASSM_1 is fully constrained. 

 
 

8.11 Close all parts; do not save. 
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1. Open the part 
Open asm3_ws_assembly_1 loading all components with Use Partial Loading. 

1.1 On the Standard toolbar, click Open . 
1.2 In the Open dialog box, click Options. 

The Assembly Load Options box is displayed. 
1.3 In the Part Versions group, from the Load list, select From Folder. 
1.4 In the Scope group, from the Load list, select All Components. 
1.5 Ensure that the Use Partial Loading check box is selected. 
1.6 Click OK. 
1.7 Open asm3_ws_assembly_1. 

 
 

2. Review the assembly 
2.1 Verify that the Assemblies application is running. 
2.2 In the Assembly Navigator, notice that there are 2 subassemblies and a component. 

 
 

2.3 Expand the node for the subassemblies. 
2.4 Click the Descriptive Part Name column heading. 

 
 

2.5 Observe that the components of the two subassemblies are identical. 

Unique part files from existing components 
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3. Make a pulley unique 
The design requirement is that the pulley on the right side needs to be increased 4” in 

diameter. You will use the Make Unique command to achieve this. 
3.1 Right-click the right side pulley and choose Make Unique. 

 
 

3.2 In the Make Unique dialog box, click Name Unique Parts. 
3.3 If necessary, from the Project Assignment message box, click OK until the message is 

dismissed. 
3.4 In the Name and Location group, in the Name box, type xxx_pulley_1, where xxx represent 

your initials, and press Enter. 
3.5 In the Folder box, enter and address to a directory to which you have write access. 
3.6 In the Name Unique Parts dialog box, click OK. 
3.7 In the Make Unique dialog box, click OK. 
3.8 Click OK if you get a Read-only Part message. 

 
4. Edit the pulley 

4.1 Right-click the right side pulley and choose Make Work Part. 

 
4.2 Choose Tools→Expression. 
4.3 In the Expressions dialog box, from the Listed Expressions list, select All. 
4.4 Select the p8 expression and change the Formula value to 4. 
4.5 Click OK. 
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5. Make the angle unique 
5.1 Right-click the right angle, as shown, and choose Make Unique. 

 
 

5.2 In the Make Unique dialog box, click Name Unique Parts. 
5.3 If necessary, from the Project Assignment message box, click OK until the message is 

dismissed. 
5.4 In the Name and Location group, in the Name box, type xxx_angle_1, where xxx represent 

your initials, and press Enter. 
5.5 In the Folder box, enter an address to a directory to which you have write access. 
5.6 In the Name Unique Parts dialog box, click OK. 
5.7 In the Make Unique dialog box, click OK. 
5.8 In the Make Unique warning box, click No - Discard Changes. 

 
6. Edit the angle 

6.1 Right-click the angle and choose Make Work Part. 

 
6.2 Choose Tools→Expression. 
6.3 Select the p0 expression and change the Formula value to 5. 
6.4 Click OK. 
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7. Replace the angle 
7.1 In the Assembly Navigator, double-click asm3_ws_assembly_1 to make it the work part. 

 
7.2 Rotate the view to the orientation shown below. 

 
 
7.3 Right-click the angle, as shown, and click Replace Component. 

 
 
7.4 In the Replace Component dialog box in the Replacement Part group, select xxx_angle_1. 
7.5 In the Settings group, verify that the Maintain Relationships check box is selected. 
7.6 Click OK. 
7.7 In the Replace Component warning box, click Yes. 
7.8 Choose View→Operation→Regenerate Work. 

 
 

7.9 Close all parts without saving them. 
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1. Verify current load options 
1.1 Choose File→Options→Assembly Load Options. 
1.2 In the Part Versions group, from the Load list, select From Folder. 
1.3 In the Scope group, from the Load list, select All Components. 
1.4 Ensure that the Use Partial Loading check box is selected. 
1.5 Ensure that the Load Interpart Data check box is not selected. 
1.6 Click OK. 

 
2. Save the plate component 

2.1 Open asm3_interpart_assembly_1. 

 
 

2.2 In the Assembly Navigator, double-click asm3_ipu_plate_1 to make it the work part. 
2.3 In the Read-only Part message box, click OK. 
2.4 Choose File→Save As.  
2.5 From the Save in list, select a directory in which you have write access.  
2.6 In the File name box, type ***_plate_1 where *** represents your initials.  
2.7 Click OK.  
2.8 In the File name box, type ***_interpart_assembly_1 where *** represents your initials.  
2.9 Click OK.  
2.10 In the Save As message box, click Yes.  
2.11  In the Save Warning message box, click OK.  
2.12  Close the Information window.  

 
 
 

Load Interpart data enhancements 
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3. Save the angle component 
3.1 Right-click asm3_ipu_angle_1 component as shown, and choose Make Work Part. 
 

 
 

3.2 Choose File→Save As. 
3.3 From the Save in list, select a directory in which you have write access. 
3.4 In the File name box, type ***_angle_1 where *** represents your initials. 
3.5 Click OK. 
3.6 In the Save as dialog box, click Cancel. 
3.7 In the Save As message box, click Yes. 
3.8 In the Save As Report message box, click OK. 
3.9 Close the Information window. 
3.10 In the Assembly Navigator, double-click ***_interpart_assembly_1 to make it the work part. 
3.11 Choose File→Save. 
3.12 Choose File→Close→All Parts. 

 
4. Change a hole size in the plate component 

4.1 Open ***_plate_1. 

 
 

4.2 Choose Tools→Expression. 
4.3 Select the p11 expression and change the Formula value to 0.375. 
4.4 Click OK. 
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4.5 Observe that the holes on the right side of the plate are now larger. 

 
 

4.6 Choose File→Close→Save and Close. 
 

5. Open the assembly 
5.1 Choose File→Options→Assembly Load Options. 
5.2 In the Part Versions group, in the Load list, select As Saved.  
5.3 Click OK.  
5.4 Open ***_interpart_assembly_1.  

 
 

5.5 Observe the size of the holes in the angle and plate components under the large pulley. 

Notice that the holes are of two different sizes. An interpart expression links the holes from 
the plate to the angle so that they will be the same size. However, because of the Partial 

Loading and Load Interpart Data settings used from the Assembly Load Options dialog 
box, the expressions are not updated.  

 
 

5.6 Close all parts without saving. 
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6. Open the assembly 
6.1 Choose File→Options→Assembly Load Options. 
6.2 In the Part Versions group, in the Load list, select As Saved.  
6.3 In the Scope group, ensure that the Load Interpart Data checkbox is selected.  
6.4 From the Load Parents list, select All Levels.  
6.5 Click OK.  
6.6 Open ***_interpart_assembly_1.  
6.7 Observe the size of the holes in the angle and plate components under the large pulley. 

The holes in the plate and angle are now the same size. 

 
  

6.8 From the Assembly Navigator, right-click ***_angle_1 and choose Properties.  
6.9 From the Assembly page, review the Load Status.  

Even though you used the Partial Loading option, the Load Interpart Data option 
automatically fully loaded the ***_angle_1 component part.  

 
 

6.10 Click OK.  
6.11 Close all parts without saving. 

 
7. Open the assembly by group 

7.1 Choose File→Options→Assembly Load Options. 
7.2 In the Scope group, from the Load list, select Specify Component Group.  
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7.3 Ensure that the Load Interpart Data check box is selected.  
7.4 Click OK.  
7.5 Open ***_interpart_assembly_1.  
7.6 In the Open Components dialog box, select By Name Pulley_2 and click OK.  

The assembly opens with only the selected component group and this time the holes in 
the angle components have been updated as defined in the plate component. 

 
 

7.7 Observe the size of the holes in the angle components under the large pulley.  

The holes have been updated to reflect the size in the plate component. 

7.8 Close all parts without saving. 
7.9 Open the Assembly Load Options and clear the Load Interpart Data check box. 
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4.1 Open the part 
Open asm3_ra_assembly_1 loading all components with Use Partial Loading. 

1.1 On the Standard toolbar, click Open . 
1.2 In the Open dialog box, click Options.  

The Assembly Load Options dialog box appears.  

1.3 In the Part Versions group, expand the Load list and select From Folder.  
1.4 In the Scope group, expand the Load list and select All Components.  
1.5 Ensure that the Use Partial Loading check box is selected.  
1.6 Click OK.  
1.7 Open asm3_ra_assembly_1.  

 

 

 

2. Review close options 

2.1 Open the Assembly Navigator. 
2.2 Right-click asm3_ra_sub_assm_1 and select Close.  

 
 

2.3 Observe that the only selections for Close are Part and Assembly.  
2.4 Right-click asm3_ra_plate_1 and select Close.  

Again, the only selections for Close are Part and Assembly.  
 

 

Reopening modified parts 
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3. Edit the pulley 
3.1  In the Assembly Navigator expand the first asm3_ra_sub_assm_1. 

3.2 Double-click asm3_ra_pulley_1 to make it the work part.  
3.3 Click OK if you get a Read-only Part message.  
3.4 Choose Tools→Expression.  
3.5 From the Listed Expressions list, select All.  
3.6 Select the p8 expression.  
3.7 In the Formula box, type 3.  
3.8 Click OK.  

The pulleys are now larger and intersect the plate. 

 
 

3.9 Click OK if you get a Read-only Part message. 

 
4. Edit the angle 

4.1 In the Assembly Navigator double-click one of the asm3_ra_angle_3 components to make it 
the work part. 

4.2 Choose Tools→Expression.  
4.3 Select the p0 expression.  
4.4 In the Formula box, type 2.5.  
4.5 Click OK.  
4.6 Click OK if you get a Read-only Part message.  
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5. Edit the plate 
5.1  In the Assembly Navigator double-click asm3_ra_plate_1 to make it the work part. 

5.2 Choose Tools→Expression.  
5.3 Select the p23 expression.  
5.4 In the Formula box, type 1.  
5.5 Click OK.  
5.6 Click OK if you get a Read-only Part message.  
5.7 Observe that there are now slots in the plate. 

 

 
6. Change the work part 

6.1  In the Assembly Navigator double-click asm3_ra_assembly_1. 
6.2 Right-click asm3_ra_plate_1 and select Close.  

 
6.3 Observe that there are now two new selections for Close, Reopen Part and Reopen 

Assembly.  
6.4 In the Assembly Navigator right-click asm3_ra_plate_1 and select Close→Reopen Part. 

An information window pops up informing you that the asm3_ra_plate_1 has been 
successfully reopened. 

6.5 Close the information window. 
6.6 In the Assembly Navigator right-click asm3_ra_sub_assm_1 and select Close→Reopen 

Assembly. 

An information window pops up informing you that the asm3_ra_angle_3, 
asm3_ra_pulley_1, and asm3_ra_sub_assm_1 have been successfully reopened. 

6.7 Close the information window. And Close all parts; do not save. 
 



122 
 

 By Design Through Manufacturing Co., Ltd.  
 

 
 

1. Open the part 
Open asm3_suppress_assembly_1 loading all components with Use Partial Loading. 

1.1 On the Standard toolbar, click Open . 
1.2 In the Open dialog box, click Options.  

The Assembly Load Options dialog box appears.  

1.3 In the Part Versions group, expand the Load list and select From Folder.  
1.4 In the Scope group, expand the Load list and select All Components.  
1.5 Ensure that the Use Partial Loading check box is selected.  
1.6 Click OK.  
1.7 Open asm3_suppress_assembly_1.  

 

 

 

2. View the arrangements 
2.1  Select Assemblies→Arrangements. 
2.2 Observe that there are 3 additional arrangements.  

However, at this time they are only copies of Arrangement 1 that have been renamed. 

 
2.3 Click Close.  

 
 
 
 

Edit Suppression State enhancement 
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3. Edit the left pulley arrangement 
3.1 Open the Assembly Navigator and pin it open. 
3.2 Expand asm3_sup_sub_assm_2.  
3.3 Select all of the components of asm3_sup_sub_assm_2.  

 
3.4 On one of the selected components, right-click and select Suppression.  
3.5 In the Suppression dialog in the Controlling Parent group, select 

asm3_suppress_assembly_1.  
3.6 Observe that the Arrangements group is now populated with arrangements that you had 

reviewed earlier.  

 
3.7 In the Arrangements group, select Left_Pulley.  
3.8 In the State group, click Always Suppressed.  
3.9 Click OK.  

 
4. Edit the right pulley arrangement 

4.1 In the Assembly Navigator expand asm3_sup_sub_assm_1. 
4.2 Select all of the components of asm3_sup_sub_assm_1.  

 
4.3 On one of the selected components, right-click and select Suppression.  
4.4 In the Suppression dialog in the Controlling Parent group, select 

asm3_suppress_assembly_1.  
4.5 In the Arrangements group, select Right_Pulley.  
4.6 In the State group, click Always Suppressed.  
4.7 Click OK.  
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5. Edit the Suppress Front Angles arrangement 
5.1  In the graphics window, select the 2 angle components as indicated below. 

 
 

5.2 In the graphics window, right-click one of the highlighted components and select 
Suppression.  

5.3 In the Suppression dialog box in the Arrangements group, select Suppress_Front_Angles.  
5.4 In the State group, click Always Suppressed.  
5.5 Click OK.  

 
6. Test the arrangements 

6.1 Select Assemblies→Arrangements. 
6.2 Double-click Left_Pulley. 

 
6.3 Double-click Right_Pulley.  
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6.4 Double-click Suppress_Front_Angles.  

 
6.5 Click Close.  

6.6 Close all parts; do not save. 
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1. Open the part 
1.1 Choose Tools→Update→Interpart Update. 
1.2 Verify that Delay Geometry, Expressions, and PMI is selected.  

 
 

1.3 Choose File→Options→Assembly Load Options.  
1.4 In the Part Versions group, expand the Load list and select From Folder.  
1.5 In the Scope group, expand the Load list and select All Components.  

1.6 Ensure that the Use Partial Loading check box is selected.  

1.7 Click OK.  

1.8 Open asm2_epr_assm.  

 

 

2. Add a column to the Assembly Navigator 

2.1 Open the Assembly Navigator. 
2.2 Below the last component node, right-click and choose Columns→Out of Date.  

 
 

2.3 Below the last component node, right-click and choose Columns→Configure.  

 

Synchronize Links 
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2.4 In the Assembly Navigator Properties dialog box on the Columns tab, select Out of Date.  
2.5 Click the Move Up button until Out of Date is second from the top.  

 
2.6 Click OK.  

 

3. Edit the guide curve 

3.1 In the Assembly Navigator, double-click asm2_pipe_route to make it the work part. 

3.2 In the Part Navigator, double-click Intersection Curves (7).  

3.3 In the Selection bar, insure that the Face Rule is set to Tangent Faces.  

3.4 Hold the Shift key and select one of the highlighted faces as indicated below.  

 
3.5 Select the lower sheet solid as indicated below. 

 
3.6 Click OK.  

 
 

4. Return to the assembly 

4.1 In the Assembly Navigator, double-click asm2_epr_assm. 

4.2 In the Assembly Navigator, right click assm2_pipe and select Open→Component Fully.  
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4.3 Observe in the Assembly Navigator that there is an Out of Date icon present for the 
asm2_pipe component.  

 
4.4 Observe in the graphic window that the asm2_pipe_route and asm2_pipe components are 

no longer coaxial.  

 
 

5. Update the pipe component 

5.1 In the Assembly Navigator, double-click asm2_pipe to make it the work part. 

5.2 Choose Assemblies→WAVE→Synchronize Links.  
5.3 In the Synchronize Links dialog box, select Linked Composite Curve(1).  

5.4 Click Synchronize Linked Feature .  
5.5 In the WAVE Geometry Linker dialog box, click OK; the feature is updated.  

 
5.6 In the Synchronize Links dialog box, click Close.  

5.7 In the Part Navigator, right-click Tube (2) and select Make Current Feature.  

 
5.8 Close all parts; do not save. 
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NX 8 Drafting Transition 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



130 
 

 By Design Through Manufacturing Co., Ltd.  
 

 
 
 
 

1. Open the part and set the work layer 
1.1 Open drf7_borders_and_zones_dwg. 

 
 

1.2 On the Utility toolbar, click Layer Settings .  

1.3 In the Work Layer box, type 256 and then press Enter.  

1.4 Click Close.  

 

2. Apply standard zones to the drawing sheet 

2.1 On the Drawing Format toolbar, click Borders and Zones . 
2.2 In the Borders group, in the Width box, type 15.  
2.3 In the Zones group, make sure the Method is set to Standard.  
2.4 In the Zone Labels and Markings group, in the Label Height box, type 10.  
2.5 Click OK.  

 
Sheet “Sheet 1” Work 

The Standard method places equally spaced zones along the horizontal and vertical borders 
of the drawing sheet.  

Borders & Zones 
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3. Turn the sheet zone grid on 

3.1 Choose Preferences→Drafting. 
3.2 At the bottom of the General tab, from the Grid Settings group, click Use Sheet Zone Grid.  
3.3 Click OK.  

3.4 In the Part Navigator , right-click the Drawing node and select Grid.  

 
Sheet “Sheet 1” Work 

Associative grid lines appear on the drawing sheet. The major grid spacing coincides with the 
zone markings on the border. 

 
4. Convert the section view label to a sheet and zone callout 

4.1 Double-click the View and Section Label, or right-click it and choose Edit View Label. 

 
 
4.2 In the View Label group, from the Letter Format list, select 1–A1.  

 
 

4.3 From the Reference to Show list, select Sheet and Zone.  
4.4 Click OK.  



132 
 

 By Design Through Manufacturing Co., Ltd.  
 

 
 

The zone information appears in the label of the section view, and on the section line symbol in 
the parent view. The label’s alignment position determines its zone location. 

 
5. Edit the border and zone layout 

5.1 Click Borders and Zones . 
5.2 In the Zones group, from the Method list, select Custom. 

The Custom method lets you configure your own border and zone layout. 

5.3 In the Horizontal Size box, type 100.  
5.4 From the Origin list, select Bottom Right.  
5.5 Click OK.  

Zone ‘A1’ is placed at the bottom right of the drawing border. 

 
The section view label updates to reflect the new zone configuration on the drawing sheet. 
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5.6 Drag the section view to a new location on the drawing sheet. 

 
The label updates as you move the view from one zone to another. 

 
6. Open Sheet 2 and add borders and zones to it 

6.1 In the Part Navigator , double-click the Sheet “Sheet 2” node to open it. 

 
Sheet “Sheet 2” Work 

 

6.2 Click Borders and Zones  

6.3 Accept the current border and zone settings by clicking OK.  

 
Sheet “Sheet 2” Work 
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7. Move the section view to Sheet 2 
 

In the Part Navigator , use your mouse to drag the ‘Section “SX@2” A node down to the ‘Sheet 

“Sheet 2”(Work-Active) node. 

 
Sheet “Sheet 2” Work 

 

The section view moves to the same relative location on Sheet 2, and the section view label updates. 
If you look at Sheet 1, the section line symbol on the parent view also reflects the corresponding update. 
 

 

 
 

8. Add a note with a zone callout in it 

8.1 On the Annotation toolbar, click Note . 
8.2 In the Text Input box, type:  

Zone 

8.3 In the Symbols group, from the Category list, select Relationships.  

8.4 Click Insert Sheet Zone .  
8.5 In the Sheet Zone Reference dialog box, from the Attributes list, select both:  

Sheet Number 
Zone Reference 
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8.6 From the View Reference group, select the Show All Views in Drawing check box.  

8.7 From the Views List, select:  

Top@1 

8.8 Click OK.  

The character sequence for the sheet and zone callouts appears in the Text Input box.  

8.9 Drag the note over the view so that an associative helper line extends from it to the center of 
the view. 

 
 

8.10   Click to place the note next to the view label. 

 
8.11   Close all parts. 
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1. Open the drawing and add borders and zones to it 
1.1 Open drf7_define_title_block. 

 
Sheet “Sheet 1” Work 

1.2 On the Utility toolbar, click Layer Settings .  
1.3 In the Work Layer box, type 256, and then press Enter.  
1.4 Click Close.  

1.5 On the Drawing Format toolbar, click Borders and Zones .  

1.6 On the dialog rail, click Reset .  
1.7 Click OK.  

 
Sheet “Sheet 1” Work 

A set of associative borders and zones is placed on Layer 256. 
 

 

Create and edit a title block 
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2. Move the tabular notes 

2.1 Move your cursor over the origin of the revision block. 

 
 

2.2  Drag the revision block to the upper right corner of the main title block note. 

 

 
2.3 Drag the signature (1) and tolerance block (2) to the positions shown. 
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3. Create the title block 

3.1 On the Drawing Format toolbar, click Title Block . 

3.2 Rectangle select all of the tabular notes. 

 
Their contents appear in the Cell Properties list.  

 
Observe that some of the cells of title block are automatically locked. For instance, LABEL2 

and LABEL3 are automatic text attributes and cannot be edited, thus they are locked.  An alert also 
appears in the graphics window: 

 
It informs you that only Auto Size Text can be applied to the cells of the custom title block. 

All other fit methods are ignored. 
3.3 Scroll down to the bottom of the list. 

 
3.4 The text in Label33 is currently unlocked and can be edited.  
3.5 Click OK to create the custom title block. 
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4. Drag the title block to its position on the drawing sheet 

4.1 Right-click the title block and choose Style. 

4.2 From the Alignment Position list, make sure Bottom Right is selected.  

 
4.3 Click OK.  
4.4 Drag the title block to the lower right corner of the drawing sheet. 

 

 

 

5. Edit the title block 

5.1 Right-click the title block and choose Populate. 

5.2 Scroll down to the bottom of the list. 

 
5.3 Select the Label33 row.  

5.4 Click .  
5.5 In the Text editor, scroll to the end of the character string and replace –2004 with –2009.  

5.6 Click OK.  
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The note updates. 

5.7 In the Populate Title Block dialog box, click Close. 
 

6. Lock the contents of the edited cell 

6.1 Right-click the title block and choose Edit Definition. 

6.2 Select the Label33 row.  

6.3 Select the Lock check box.  

The lock symbol appears in the cell row. 

 
6.4 Click OK.  
6.5 Right-click the title block and choose Populate.  

Label33 no longer appears in the list and cannot be edited.  

 
6.6 Click Close.  
6.7 Close all parts. 
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The Mark as Template command creates a sheet or drawing template based on the 

configuration of the currently open drawing sheet. The template can include associative borders and 
zones, views, notes, template regions, symbols, and custom title blocks.  

Marking a drawing as a template gives you access to the template regions and rules 
functions as well as allows you to choose to add the template to your collection of sheet and drawing 
templates.  

 
If you elect to save the template in your template directory, you must specify a presentation 

name, description, template type, and the .pax file location. 
Three different template types are available: 

Sheet 
Creates a sheet template from the current drafting part. A sheet template is used to add a 

new sheet to an existing drawing. 
 

Reference Existing Part 
Creates a master model drawing template from the current drafting part. A master model 

drawing template is used to create a separate drafting part that includes the current model as a 
component. 

 
Standalone 

Creates a 2D drawing template. A 2D template is used to create a standalone drawing that 
does not reference a master model part. 

When you save the template part, the specified .pax file is created or updated and the 
template is displayed by its presentation name on the Resource bar palette. 

 
Note :  You must have write permission to the .pax file and file directory to add a new template or update an 
existing template. 

Mark as Template 
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Template region is a rectangular area on a drawing template designated to accept only 
certain types of drafting objects. The Template Region command defines the origin and the 
rectangular dimensions of the area on the drawing template and the specific types of drafting objects 
that can be contained therein. 

  
You can designate a template region as a note, symbol, table, or view type region. This 

designation determines the type of drafting object that can be added to the template region. You can 
apply Knowledge Fusion rules to template regions to govern the behavior of objects in them when 
the drawing template is incorporated into another part. 

 
Note :  Although this command is only available for drawing templates, it is not necessary to create template 

regions in order to add drafting objects to the drawing template. You can add views, custom 
symbols, title blocks, and notes to your drawing template without template regions. 

 

 

Phantom lines denoting the boundary of a template region 
 

When the contents of a template region grow beyond its borders, the region behaves in one of two 
ways: 

 
As a growing region 

Contents that extend beyond the template region’s boundary continue into other template 
regions of the same object type. Depending on how you set the Continuation for the template region, 
the overflow extends to other template regions of the same type on the same sheet, or to template 
regions of the same type on another sheet. 
 

 

Template Region  
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As a fixed region 
Contents that extend beyond the template region are displayed outside the boundary of the 

region and do not continue to any other region. 
 

Note :  View regions are always fixed regions. 
 

After you create a template region, you can re-size it, move it, or delete it in the drawing 
template. 

However, after you import a region as part of a drawing template, you cannot edit it, move it, 
or delete it. 

 
Priority and Content Control 

If content from two growing regions grow into each other, the region with the larger priority 
number will move to the continuation area. You may also control whether the entire contents of the 
lower priority region move to another region, or if only the overlapping portion moves. 

Customer Defaults 

Customer defaults govern the display of template regions. The defaults are contained in the 
Customer Defaults dialog box, on the Drafting→Drawing Automation →General tab:  

 Display Region in Non-Template Part — Displays the template region’s border when a drawing 
template is imported into another part.  

 Display Region Label — Displays the template region’s name, type, and the rule file name at the 
center of each region.  

 

You can also set color, font, and width settings for region borders here. 
 
These options also control the default setting for the template region options on the General tab of 

the Drafting Automation Preferences dialog box.  
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Standard font types available in the FreeType Font library are supported in the PMI and Drafting 
environments.  
Note :   Although the FreeType Font library supports non scalable and other font types, only scalable 

TrueType, OpenType, and PostScript fonts are supported. 
 

When setting your character font, it is important to remember the following points: 
 

 Existing NX font types are still available and are located in a directory set by the 
UGII_CHARACTER_FONT_DIR environment variable.  

 Standard Fonts files are found in your normal font directories, usually in the 
C:\Windows\Fonts on Windows or in a configuration file on Unix.  

 You can use custom fonts by placing the font files in a directory referenced by the 
UGII_STANDARD_FONT_DIR environment variable.  

 NX will search for the character font in the following order: 
1. Standard font location (that is, C:/Window/Fonts).  
2. The directory specified by UGII_STANDARD_FONT_DIR.  
3. The directory specified by UGII_CHARACTER_FONT_DIR.  

 A default font is used when a font cannot be found. The default font can be changed, but is 
initially set to Arial Unicode MS. If Arial Unicode MS is not found, the default font is set to Tahoma. If 
Tahoma is not found, then the default font is set to Arial.  

 
Why should I use it? 

Use Standard Fonts to replace, enhance, or supplement your current set of drafting and PMI 
character fonts. 
Where do I find it? 

All fonts found in standard directories and in the custom directory are automatically available in 
customer defaults, preference dialog boxes, style dialog boxes, and any other dialog box that lets you specify 
a character font. 

 
 
 
 
 

Support for Standard Fonts 
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1. Open the part and review the drawing 
1.1 Open drf7_out_of_date_folder. 

 
 

1.2 Zoom in on the tabular note at the upper right corner of the part. 

 
The note contains: 

1.2.1  A custom symbol. 
1.2.2 The part attribute DB_PART_REV. 

 
 

2. Review the Out-of-Date folder 

2.1 On the Resource bar, click the Part Navigator tab. 

 
2.2 Right-click the Out-of-Date folder and choose Refresh. 

 

Out of Date Folder 
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2.3  Folders for the custom symbol and tabular note are added under the Out-of-Date folder.  

 
2.4 Right-click the Out-of-Date folder and choose Refresh All.  
2.5 NX performs an out of date check on the contents of the selected folders and verifies that 

the objects in them are up to date. It then marks each folder with the green check mark 
symbol. 

 
3. Edit the custom symbol definition 

3.1 On the Resource bar, click the Reuse Library  tab. 
3.2 Expand the Custom Symbol Library node and select the Part Symbols folder underneath it.  
3.3 On the Member Select panel, right-click Hex and choose Edit.  

You are placed in the symbol editor mode. 

 
Sheet “Symbol Editor” Work 

3.4 On the Sketch Tools toolbar, click Line .  

3.5 Use Mid Point to construct a line diagonally from one side of the hexagon to the other.  

 
Sheet “Symbol Editor” Work 

3.6 On the Symbol toolbar, click Finish Custom Symbol Edit .  

3.7 In the Finish Custom Symbol Edit dialog box, click OK. 
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4. Update the symbol from the Out-of-Date folder 
 

4.1 In the Part Navigator, right-click the Out-of-Date folder and choose Refresh All. 

 
The custom symbol is marked out of date. 
 

4.2 Right-click the Out-of-Date folder and choose Update All. 
The Out-of-Date and Custom Symbols folder underneath it are marked up to date, and the 

object is removed from the Custom Symbols folder. 

 
 
The custom symbol is likewise updated in the tabular note. 

 
 
 

5. Edit the part attribute 
5.1 Right-click the tabular note and choose Style. 

 
5.2 Click the Tabular Note tab.  
5.3 Clear the Automatic Update check box.  

This prevents the tabular note from automatically updating as you edit the part attribute. 

5.4 Click OK.  
5.5 Choose File→Properties.  
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5.6 On the Attributes tab, select the DB_PART_REV row.  

5.7 In the Value box, overstrike A, and then type B.  

5.8 Click OK 

 
6. Update the attribute value from the Out-of-Date folder 

6.1 Right-click the Out-of-Date folder and choose Refresh All. 

 
The tabular note is marked out of date. 

 
6.2 Right-click the Out-of-Date folder and choose Update All. 

 
NX updates the attribute value in the tabular note, and then marks all folders up to date. 

 
 
6.3 Close all parts. 
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1. Review your drafting preferences 
1.1 Choose Preferences→Drafting. 
1.2 On the General tab, from the Model-based Drawing Workflow group, make sure the following 

options are selected: 
 Automatically Start View Creation 

 View Creation Wizard 
 Base View Command 

Do not be concerned about selecting any other options as you do not need them for this activity. 
1.3 Click OK. 

 
2. Open an assembly and create a drawing part 

2.1 Open drf7_armrest_assm. 

 
 

2.2 On the Standard toolbar, click New . 
2.3 Click the Drawing tab. 
2.4 In the Filters group, make sure 

Relationship = Reference Existing Part 
Units = Millimeters 

2.5 From the Templates list, select A0 – Drawing. 
2.6 Under New File Name, make sure: 

Name  = xxx_armrest_assm_dwg 
2.7 Under Part to create a drawing of, make sure: 

Name = drf7_armrest_assm 
2.8 Click OK. 
2.9 Click Close in the Populate Title Block dialog box. 

 

View Creation Wizard 
 



150 
 

 By Design Through Manufacturing Co., Ltd.  
 

 
3. ect the model and view options 

3.1 On the Part page, from the Loaded Parts list, make sure drf7_armrest_assm.prt is selected. 
3.2 Click Next to advance to the Options page.  
3.3 From the View Boundary list, make sure Automatic is selected.  
3.4 Clear the Show Centerlines check box.  
3.5 From the Preview Style list, select Border. 

 
Sheet “Sheet 1” Work 

3.6 Click Next to open the Arrangement page. 
 

4. Select the arrangement and orientation for the parent view 
The assembly was saved with the closed arrangement displayed. You can accept this arrangement 
for your assembly views by leaving it selected in the Arrangement list. 
4.1 Click Next to advance to the Orientation page. 
4.2 From the Model Views list, select Front. 

The parent view serves as the base view for the other orthographic views in the layout. 
4.3 Click Next to advance to the Layout page. 

 
5. Construct the view layout 

On the Layout page, the middle button denotes the parent view you selected from the Orientation 
page. 
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Select the view layout indicated below. 

 
The preview on the drawing sheet updates as you select view buttons. 

 

TIP : If you need to turn a view button off, click it a second time. You can turn off all but the parent view. 
 

6. Place the view layout on the drawing sheet 
Notice that the Automatic placement option centers the view layout on the drawing sheet. 

 

If you accept the current view placement now, your views would be placed on the drawing sheet at 
1:1 scale. 
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Click Finish. 

 
eet “Sheet 1” Work 

 
7. Create a view layout showing an assembly arrangement 

7.1 On the Drawing toolbar, click New Sheet . 
7.2 In the Sheet dialog box, in the Size group, make sure Use Template is selected and A0 – Size 

is highlighted in the sheet list. 
7.3 Click OK to create a new sheet. 
7.4 Click Close to close the Populate Title Block dialog box. 

 
Sheet “Sheet 2” Work 

7.5 On the Drawing toolbar, from the Add View Drop-down list, select View Creation Wizard 

.On the dialog rail, click Reset . 
7.6 On the Part page, from the Loaded Parts list, make sure drf7_armrest_assm.prt is selected. 
7.7 Click Next to advance to the Options page. 
7.8 From the View Boundary list, select Manual. 
7.9 Make sure the Auto-Scale to Fit check box is selected. 

The Auto-Scale to Fit applies the maximum scale to the views that still shows the geometry in 
its entirety within the specified area of the drawing sheet. 

7.10 Click Next to open the Arrangement page. 
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8. Select an assembly arrangement 
8.1 From the Arrangement list, select fully_opened. 
8.2 Click Next to advance to the Orientation page. 
8.3 From the Model Views list, select Front. 
8.4 Click Next to advance to the Layout page. 
8.5 Select the view layout depicted below. 

 
The preview on the drawing sheet updates as you select a different array of views. 

 

8.6  In the Placement group, from the Option list, select Manual. 
8.7 Move your cursor into zone F8. 

 
 

8.8 Select the position. 

 
Sheet “Sheet 2” Work 

The views are placed on the drawing sheet showing the fully_opened arrangement and auto scaled to 1:2. 
8.9 Close all parts. 
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1. Open the part and review the current view break preferences 
1.1 Open drf7_view_break_dwg. 

 
Sheet “Sheet 1” Work 

1.2 Choose Preferences→Drafting. 
1.3 Click the View Break tab. 
1.4 In the Workflow group, make sure the Propagate View Break check box is selected. 

This ensures that any projected or section view contains the same view break as the parent view. 
1.5 Make sure the Show Break Lines check box is selected. 

This ensures that break lines are visible in all break views. 
1.6 Click OK. 

 

2. Start the view break 
2.1 Right-click the border of the left view and choose Add View Break. 

 
 

2.2 In the Type list, make sure Regular is selected. The regular view break produces two break lines 
that foreshortens the view area in between them. The default direction vector points upward. 

 

View Break 
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2.3 For Break Line 1, select the anchor point shown. 

 
 

2.4 For Break Line 2, select the anchor point shown. 

 
 

2.5 Click OK. 

 
 
 
3. Edit the style of the break 

3.1 Right-click the break line in the view and choose Edit. 
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3.2 In the Settings group, set the following parameters: 

Gap = 26 

Style = 
 

Amplitude = 16 

 
3.3 Click OK. 
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Use Import AutoCAD Block to create custom symbols by importing block definitions from AutoCAD 
DXF and DWG files. There are two methods for selecting AutoCAD files with blocks: 

 Select an AutoCAD file and its list of blocks will be extracted. 
 Select a folder and any AutoCAD files open and any list of blocks is extracted. 
Users can mix any selection of files and folders, the blocks tree list will accumulate all selections. 

By default the block name will be used to define the symbol name, and the symbol part file name will be the 
symbol name with a .sym.prt extension (not applicable to part symbols).  

The Import Summary will show the number of blocks processed, number of symbols created and 
their status.  

To remove a new symbol, you can delete it after import like any other custom symbol. 
You can recreate symbols for simple blocks as you migrate AutoCAD data to NX Drafting. However, in the 
case of more complex blocks or large block libraries, it is easier to use this functionality to create the NX 
symbol from the existing AutoCAD blocks. In the event of symbol name clashes, a number will be appended 
to the name. 

Where do I find it? 

Application Drafting 

Prerequisite The DXF / DWG Translator (dxfdwg kit) must be installed. 

Menu File→Import→AutoCAD Block 

Resource 
bar 

Reuse Library  tab → Custom Symbol Library → right-click a folder → Import 
AutoCAD Block  

 

 
 
 
 

Import AutoCAD Block 
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Activity: Create cutting tools 

Estimated time to complete: 3–5 minutes 

In this activity, you will create several milling tools and their tool holders. 

 

Launch the Create cutting tools activity.  

 

Create the Manufacturing setup 

1. Open mnf3_MFG_asmb_slotted_adjuster.  

 

2. On the Standard toolbar, click New or choose File→New.  

3. Click the Manufacturing tab.  

4. From the Units list, select Inches.  

5. From the Templates list, select General Setup.  

6. Click OK.  

The manufacturing assembly is created. 

7. In the Operation Navigator, right-click in the background and choose Machine Tool View.  

8. Right - click in the background again and choose Expand All.  

The machine tool view contains a carrier and pockets. 

9. In the graphics window, right - click in the background and choose Orient View→Front.  

file:///D:/Siemens/NX%208.0/nxcast/html/etmf758/index.html
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Create a 1.0 diameter end mill with a tool holder 

Since a mill is a good general purpose tool, it will be placed as tool number one. The diameter of 

the mill will be 1.000. 

1. In the Create toolbar, click Create Tool or choose Insert→Tool.  

The Type is set to mill_planar.  

2. In the Create Tool dialog box, in the Tool Subtype group, click MILL .  

3. In the Location group, from the Tool list, select POCKET_01.  

4. In the Name box, type EM-1.00.  

5. Click OK.  

You will accept the tool parameter defaults and set some additional settings. 

6. In the Milling Tool-5 Parameters dialog box, in the Description group, click Edit .  

7. In the Search Result dialog box, in the Matching Items group, select TMC0_00002 from 

the list.  

8. Click OK.  

9. In the Milling Tool-5 Parameters dialog box, click the Holder tab.  

Holders are built sequentially from the tool up to the gauge line. You will start at the 

connection point to the face mill. 

10. In the Holder Steps group, set the parameters as shown.  

a. (LD) Lower Diameter = 1.50.  

b. (L) Length = 3.00.  

c. (UD) Upper Diameter = 1.50.  

11. Click OK.  

You have created a 1.00” diameter mill, defined a tool holder and placed it into pocket 1 of your 

machine tool. Next you will create end mills of various sizes. 
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Create a 1.25 diameter end mill with a two step tool holder 

1. On the Insert toolbar, click Create Tool .  

2. In the Create Tool dialog box, in the Tool Subtype group, click MILL .  

3. In the Location group, from the Tool list, select POCKET_02.  

4. In the Name box, type EM-1.25-0.  

5. Click OK.  

6. In the Milling Tool-5 Parameters dialog box, in the (D) Diameter box, type 1.25.  

7. In the (L) Length box, type 5.5.  

8. In the Flutes box, type 3.  

Caution Do not set the tool number. It is inherited from the POCKET_ID. 

9. In the Description group, click Edit .  

10. In the Search Result dialog box, in the Matching Items group, select TMC0_00006 from 

the list.  

11. Click OK.  
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Define step 1 of the tool holder 

1. In the Milling Tool 5-Parameters dialog box, click the Holder tab.  

2. In the Holders Steps group, set the parameters as shown.  

a. (LD) Lower Diameter = 2.25.  

b. (L) Length = 1.25.  

c. (B) Taper Angle = 10.  

d. (R1) Corner Radius = .125. 

 

Define step 2 of the tool holder 

1. Click Add New Set .  

2. In the Holders Steps group, set the parameters as shown.  

a. (LD) Lower Diameter = 3.50.  

b. (L) Length = .75.  

c. (UD) Upper Diameter = 3.50.  

d. (B) Taper Angle = 0.  

e. (R1) Corner Radius = .125.  

3. Click OK.  

 

You have created a 1.250 end mill, defined a tool holder and placed it into pocket 2 of your 

machine tool. Next you will create a 1.000 diameter, 3 - fluted carbide end mill, with a .125 corner 

radius. 
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Create a 1.0 diameter end mill with a tool holder 

1. Click Create Tool .  

2. In the Create Tool dialog box, in the Tool Subtype group, ensure MILL is active.  

3. In the Location group, from the Tool list, select POCKET_03.  

4. In the Name box, type EM-1.00-.125C.  

5. Click OK.  

6. In the Mill Tool-5 Parameters dialog box, on the Tool tab, in the Dimensions group, set 

the parameters as shown.  

a. (D) Diameter = 1.00 

b. (R1) Lower Radius = .125.  

c. (B) Taper Angle = 10.  

Caution Do not set the tool number. It is inherited from the POCKET_ID. 

7. In the Description group, click Edit .  

8. In the Search Result dialog box, in the Matching Items group, select TMC0_00002 from 

the list.  

9. Click OK.  

 

Define the tool holder 

1. In the Milling Tool-5 Parameters dialog box, click the Holder tab.  

2. In the Holder Steps group, set the parameters as shown.  

a. (LD) Lower Diameter = 3.5.  

b. (L) Length = .75.  

c. (UD)) Upper Diameter = 3.5.  

d. (B) Taper Angle = 0.  

e. (R1) Corner Radius = .125.  

3. Click OK.  

You have created a 1.000 diameter end mill with a .125 corner radius and a 10 degree taper, 

defined a tool holder, and assigned it to POCKET_03.  

Copy and edit an existing tool 

1. In the Machine Tool view of the Operation Navigator, under the POCKET_01 node, right-
click EM-1.00 and choose Copy.  
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2. Right-click the POCKET_04 node and choose Paste Inside.  

 

3. Rename the new tool to EM-1.0-.25C.  

4. Double-click the new tool to edit its parameters. 

5. In the Milling Tool 5-Parameters dialog box, on the Tool tab, in the Dimensions group, in 

the (R1) Lower Radius box, type .250.  

 

6. Click OK.  

 

Retrieve a tool from the tool library 

1. Click Create Tool .  

2. In the Create Tool dialog box, in the Library group, click Retrieve Tool from Library 

.  

3. In the Library Class Selection dialog box, expand Milling and select End Mill (non 

indexable).  

4. Click OK.  

5. In the Search Criteria dialog box, in the Search Parameters group, in the (D) Diameter 

box, type 1.25 and click OK.  

6. In the Search Result dialog box, in the Matching Items group, select End Mill 1 1/4” from 

the list, and click OK.  
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The tool is retrieved and placed in the next available pocket. 

 

7. Click Cancel to close the Create Tool dialog box.  

8. Close the part. 

 

Define the shank, tool holder, and clearances 

You normally define the tool, the shank, and the tool holder. In this activity, the tool was 

previously defined. 

1. Open mnf17_tool_clearance.  

 

2. In the Operation Navigator, right-click in the background and choose Geometry View.  

3. Right-click WORKPIECE and choose Edit.  

4. In the Mill Geom dialog box, click Specify Part and select the part.  
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The cut region for this operation was previously defined. 

 

5. Click OK twice.  

6. In the Operation Navigator, right-click FACE_MILLING and choose Generate.  

 

The tool path is generated. Next you will verify the tool path to visually inspect for 

collisions. 

7. Right - click FACE_MILLING and choose Tool Path→Verify.  

8. In the Tool Path Visualization dialog box, on the Replay tab, move the Animation Speed 

slider to 1.  

This value slows the animation speed so that you can view the tool path more easily. 

9. Click Play .  

The tool cuts and rubs against the highest wall of the pocket. 
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10. Click OK to accept the tool path.  

You can specify additional parameters to more accurately define your cutting tool. 

11. In the Operation Navigator, right - click in the background and choose Machine Tool 

View.  

12. Right - click MILL and choose Edit.  

13. In the Milling Tool-5 Parameters dialog box, click the Shank tab.  

The tool diameter, length, and flute length were previously defined. You will now define 

the shape of tool shank. 

14. Define the tool shank and preview the tool. 

a. In the Shank group, select the Define Shank check box . In the Dimensions 

group, set the parameters as shown.  

b. (SD) Shank Diameter = 2.  

c. (SL) Shank Length = 3.  

d. (STL) Shank Taper Length=.750.  

e. In the Preview group, click Display .  

 

f. Click OK.  
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You must update the tool path for it to inherit the new tooling parameters. 

15. Verify the tool path. 

a. In the Operation Navigator, right-click FACE_MILLING and choose Generate.  

b. In the graphics window, right-click in the background and choose Orient 

View→RIGHT.  

c. In the Operation Navigator, right-click FACE_MILLING and choose Tool 

Path→Verify.  

d. In the Tool Path Visualization dialog box, on the Replay tab, move the 

Animation Speed slider to 1.  

e. Click Play .  

The shank of the tool interferes with the part. You need to check for tool and 

holder collisions. 

 

f. Click OK.  

16. In the Operation Navigator, right-click FACE_MILLING and choose Edit.  

17. In the Face Milling dialog box, in the Path Settings group, click Cutting Parameters .  

18. Edit the tool path and check for tool and holder collisions. 

In the Cutting Parameters dialog box, click the Containment tab.  

a. Select the Check Tool and Holder check box .  

b. Click the More tab.  

You can specify individual clearance distances for each segment of the tool. You 

are going to specify clearance distances for the tool holder and the shank. 

c. In the Clearance group, set the parameters as shown.  

A. Tool Holder = .100 
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B. Tool Shank = .100.  

d. Click OK.  

19. In the Face Milling dialog box, in the Actions group, click Generate .  

20. If you see the Tool Path generate message, click OK.  

21. Click  to close the Information window.  

22. Verify the tool path. 

In the Face Milling dialog box, in the Actions group, click Verify .  

a. In the Tool Path Visualization dialog box, on the Replay tab, move the 

Animation Speed slider to 1.  

b. Click Play .  

The tool and shank now clear the wall of the part. 

 

c. Click OK twice to close the open dialog boxes.  

23. In the Operation Navigator, if necessary switch to the Machine Tool View.  

24. Right - click MILL and choose Edit.  

The tool diameter and length, the flute length, and the shape of the tool shank are 

defined. You will now specify the shape of the tool holder. 

25. In the Milling Tool-5 Parameters dialog box, click the Holder tab and, enter the 

parameters as shown.  

Holder Steps group:  

a. (LD) Lower Diameter = 3.5.  

b. (L) Length = 2.0.  

c. (UD) Upper Diameter = 4.0.  
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The Taper Angle will be automatically calculated based on the (LD) Lower 

Diameter and (UD) Upper Diameter values.  

d. (R1) Corner Radius = .25.  

e. Tool Insertion group:  

(OS) Offset = 1.5.  

 

f. In the Preview group, click Display .  

g. Click OK.  

26. In the Operation Navigator, right-click FACE_MILLING and choose Generate to 

update the tool path.  

27. If you see the Tool Path generate message, click Yes.  

28. Click to close the Information window.  

29. In the Operation Navigator, right-click FACE_MILLING and choose Tool Path→Verify.  

30. Play the animation. 

The tool holder stays away from the wall because NX adjusts the tool path depending on 

the Tool Holder clearance value.  

 

31. Click OK.  

32. Close the part. 

You completed the activity. 
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Activity: Mill with a chamfer tool 

Estimated time to complete: 5–8 minutes 

In this activity, you will create a chamfered end mill used to machine an edge break on two ports. 

Launch the Milling with a chamfer tool activity.  

 

Create an end mill with a chamfer 

1. Open mnf3_mount7.  

 

2. On the Insert tool bar, click Create Tool .  

3. In the Create Tool dialog box, in the Type group, from the list, select mill_planar.  

4. In the Tool Subtype group, click CHAMFER_MILL .  

5. Click OK.  

6. In the Chamfer Mill dialog box, set the parameters as shown.  

a. (D) Diameter = 10.00 

b. (B) Chamfer Angle = 45 

c. (C) Chamfer Length = 1.5 

d. (FL) Flute Length = 1.5 

7. Click OK.  

 

Create an operation to machine the chamfer 

1. On the Insert tool bar, click Create Operation .  

2. In the Create Operation dialog box, in the Type group, from the list, select mill_contour.  

file:///D:/Siemens/NX%208.0/nxcast/html/etmf758/index.html


171 
 

 By Design Through Manufacturing Co., Ltd.  
 

3. In the Operation Subtype group, click CAVITY_MILL .  

4. In the Location group, set the options as shown.  

Program NC_PROGRAM 

Tool CHAMFER_MILL 

Geometry WORKPIECE 

Method METHOD 

5. Click OK.  

 

Select the curves surrounding the two ports to contain the tool path 

1. In the Cavity Mill dialog box, in the Geometry group, click Specify Trim Boundaries .  

2. In the Trim Boundaries dialog box, under Filter Type, click Curve Boundary .  

3. On the Selection bar, from the Curve Rule list, select Tangent Curves.  

4. Under Trim Side, select Outside.  

5. Select the first edge as shown. 

 

6. In the Trim Boundaries dialog box, click Create Next Boundary.  

7. Select the second edge as shown. 
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8. Click OK.  

 

Set the depth of cut and specify the cut range 

1. In the Cavity Mill dialog box, in the Path Settings group, from the Cut Pattern list, select 

Profile.  

2. In the Maximum Distance box, type 1.  

The Maximum Distance value determines how far below the specified trim boundary plane 

the tool will cut.  

3. Click Cut Levels .  

4. In the Cut Levels dialog box, in the Ranges group, from the Range Type list, select 

Single.  

There is one range, with a 1 mm depth of cut increment through the entire thickness of 

the part. 

 

5. From the Cut Levels list, select Only at Range Bottom.  

6. In the Range Definition group, in the Range Depth box, type 1.  

7. Click OK.  

The Cavity Mill dialog box is displayed.  
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View the tool path 

1. In the Actions group, click Generate .  

 

2. Click Verify .  

3. In the Tool Path Visualization dialog box, move the Animation Speed 

slider to 1.  

4. Click Play .  

 

5. Click OK twice.  

6. Close the part. 

You completed the activity. 
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Activity: Output shop documentation 

Estimated time to complete: 3–5 minutes 

In this activity, you will create shop documentation, an operation list, and a tool list. 

 

Launch the Output shop documentation activity.  

 

Output shop documentation for the operations and tools in a text format 

Continue to use mnf3_bearing_case_mfg_3.  

1. In the Operation Navigator, select the PROGRAM folder.  

2. On the Operations toolbar, click Shop Documentation .  

You must specify a name and location for the documentation data file that you are about 

to create. The default location is the current directory, which should be your home 

directory. 

Note that you will accept the default name in the Output File Name field or change it to 

your home directory path if your current directory is not your home directory.  

3. In the Shop Documentation dialog box, in the Report Format group, from the list, select 

Operation List Select (TEXT).  

4. Click OK.  

The Operation List is displayed in the Information window.  

 

5. Examine the information in the operation description and tool name columns. 

6. Close the Information window.  
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Output shop documentation for the tools in a text format 

1. On the Operations toolbar, click Shop Documentation .  

2. In the Report Format group, from the list, select Tool List Select (TEXT).  

3. Click OK.  

The Tool List is displayed in the Information window.  

 

4. Examine the milling and drilling tool information. 

5. Close the Information window.  

 

Output shop documentation for the tools in an HTML or Excel format 

1. Click Shop Documentation .  

2. In the Shop Documentation dialog box, in the Report Format group, from the list, select 

Tool List Select (HTML/Excel).  

3. Click OK.  

The HTML and Excel both open. 

4. Examine the tool information output and file name extensions. 

 

5. Return to NX. 

Output shop documentation for the operations in an HTML or Excel format 

1. Click Shop Documentation .  

2. In the Shop Documentation dialog box, in the Report Format group, from the list, select 

Operation List Select (HTML/Excel).  

3. Click OK.  
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4. In the Output File message box, click OK.  

5. Examine the operation information output and file name extensions. 

 

6. Close the part without saving it. 

You completed the activity. 
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Activity: Transfer an IPW between two workpieces 

Estimated time to complete: 4–8 minutes 

In this activity, you will transfer an IPW between two workpieces in the same setup assembly. 

 

Launch the Transfer an IPW between two workpieces activity. 

 

Open the part 

This setup assembly for this activity has a main MCS with two workpieces. There is an MCS for each 

workpiece. 

1. Choose File→Options→Assembly Load Options.  

2. In the Assembly Load Options dialog box, in the Scope group, clear the Use Partial 

Loading check box.  

3. Click OK.  

4. Open mnf15_IPW_Workpart_flow_mfg_1.  

 

5. Review the Geometry view of the Operation Navigator.  

The WORKPIECE1 geometry parent for the first setup will become the IPW source for the 

WORKPIECE2 geometry parent in the next setup.  
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MCS_MAIN 

MCS_1 

WORKPIECE1 

CAVITY_MILL 

PLANAR_MILL1 

FACE_MILLING 

PLANAR_PROFILE 

HOLE_MILLING 

HOLE_MILL_SM 

MILL_BND 

PLANAR_MILL_1 

MCS_2 

 WORKPIECE2 

  

6. Click MCS_1 to display the MCS for the first setup.  

 

7. Click WORKPIECE1 to display the part and blank geometry for the first setup.  

 
1. Part in first setup 

2 .Blank in first setup 
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8. Click MCS_2 to display the MCS for the second setup.  

 

9. Click WORKPIECE2 to display the part geometry for the second setup.  

 

Generate and verify the operations 

1. Right-click WORKPIECE1 and choose Generate.  

NX generates the first tool path. 

2. In the Path Generation dialog box, click OK as necessary to continue generating the tool 

paths for WORKPIECE1.  

3. Click Yes in the Tool Path generate message box.  

The CAVITY_MILL roughing operation uses a larger diameter tool that does not fit in all 

areas. You can ignore this message.  

4. Close the Information window.  

5. Right-click WORKPIECE1 and choose Tool Path→Verify.  

The Tool Path Visualization dialog box is displayed.  

6. Click the 2D Dynamic tab.  

7. Click Play.  
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8. Click OK.  

 

Define the blank for the second setup 

The part geometry in WORKPIECE2 is already defined for you, and uses the WAVE linked body.  

A WAVE linked body is not a prerequisite, but the part geometry in both setups must be from the 

same source. You can choose: 

 The same WAVE linked body for both setups. 

 The same assembly occurrence of the part geometry for both setups. 

1. In the Operation Navigator, double-click WORKPIECE2.  

The Mill Geom dialog box is displayed.  

2. In the Geometry group, click Specify Blank .  

The Blank Geometry dialog box is displayed.  

3. In the Type group, from the list, select IPW — In Process Workpiece.  

4. In the IPW Source group, click Select Source for IPW .  

The IPW Source dialog box is displayed. The Copy IPW from option is Work Part, which is 

the default.  

5. In the hierarchy list, expand the collapsed nodes. 

MCS_MAIN 

MCS_1 

WORKPIECE1 

CAVITY_MILL 

PLANAR_MILL_1 

FACE_MILLING 
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PLANAR_PROFILE 

HOLE_MILLING 

HOLE_MILL_SM 

MILL_BND 

PLANAR_MILL 

MCS_2 

WORKPIECE2 

6. The operations are included in the hierarchy for reference to help you select the correct 

workpiece. You can only select a workpiece for the IPW source.  

7. Select WORKPIECE1 and click OK.  

The Blank Geometry dialog box is displayed.  

8. In the Local IPW group, click Update Local IPW from Source .  

The output IPW of the last operation in the Program Order View for WORKPIECE1 

becomes the input IPW for your second setup. NX transforms the position and orientation 

of the IPW to match the position and orientation of the part geometry in the current 

setup.  

 

9. Click OK.  

The Mill Geom dialog box is displayed.  

10. Click OK.  

11. Close the part without saving it. 

12. Choose File→Options→Assembly Load Options.  

13. In the Assembly Load Options dialog box, in the Scope group, select the Use Partial 

Loading check box.  

14. Click OK.  

You completed the activity. 
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Activity: Transfer an IPW between two setup assemblies 

Estimated time to complete: 6–10 minutes 

In this activity, you will transfer an IPW between two setup assemblies. 

 

 

Launch the Transfer an IPW between two setup assemblies activity.  

 

Open the first setup assembly 

1. Open mnf15_ipw_setup_1.  

 

2. Notice the orientation of the part in the fixture. 
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Specify the blank for the first workpiece 

1. Right-click in the background of the Operation Navigator and choose Geometry View.  

2. Double-click WORKPIECE.  

The Mill Geom dialog box is displayed.  

3. In the Geometry group, click Specify Part .  

The Part Geometry dialog box is displayed.  

4. Pause the cursor over the part geometry until the QuickPick cursor is displayed, and 

then click.  

 

The QuickPick dialog box is displayed.  

This step helps you to identify if there is more than one occurrence of the part geometry 

in the assembly. 

5. Select Solid Body in MNF15_IPW_TRANSFER.  

6. In the Part Geometry dialog box, click OK.  

The Mill Geom dialog box is displayed.  

7. In the Geometry group, click Specify Blank .  

The Blank Geometry dialog box is displayed.  

8. Select the blank as shown. 

 

9. Click OK.  

The Mill Geom dialog box is displayed.  

10. Click OK.  
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Generate the operations for the first setup assembly 

1. Right-click in the background of the Operation Navigator and choose Program Order 

View.  

2. Right-click PROGRAM and choose Generate.  

NX generates the first tool path. 

3. In the Path Generation dialog box, click OK as necessary to continue generating the tool 

paths for the program.  

 

The output IPW for the last operation in the PROGRAM hierarchy defines the input IPW for 

the workpiece in the second setup assembly.  

 
4. Click Yes in the Tool Path generate message box.  

The CAVITY_MILL roughing operation uses a larger diameter tool that does not fit in all 
areas. You can ignore this message.  

5. Close the Information window.  

6. Right-click PROGRAM and choose Tool Path→Verify.  

The Tool Path Visualization dialog box is displayed.  

7. Click the 2D Dynamic tab.  

8. Click Play.  

 

9. Click OK.  

10. Save the part as xxx_ipw_setup_1.  

Replace xxx with your initials.  

11. Close the part. 
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Define the workpiece for the second setup assembly 

1. Open mnf15_ipw_setup_2.  

 

2. Notice the orientation of the part in the fixture. 

3. Right-click in the background of the Operation Navigator and choose Geometry View.  

4. Double-click WORKPIECE.  

The Workpiece dialog box is displayed.  

5. In the Geometry group, click Specify Part .  

The Part Geometry dialog box is displayed.  

You must select the same part geometry for the second setup that you selected for the 

first setup. 

6. Pause the cursor over the part geometry until the QuickPick cursor is displayed, and 

then click.  

 

The QuickPick dialog box is displayed  

7. Select Solid Body in MNF15_IPW_TRANSFER.  

This step helps to ensure you select the same part geometry as you did for the first setup 

assembly. 

8. In the Part Geometry dialog box, click OK.  

The Workpiece dialog box is displayed.  

9. In the Geometry group, click Specify Blank .  
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The Blank Geometry dialog box is displayed.  

10. In the Type group, from the list, select IPW — In Process Workpiece.  

The WORKPIECE geometry parent from the first setup assembly is the IPW source for your 

blank geometry.  

11. In the IPW Source group, click Select Source for IPW .  

When you select an IPW source part, NX maintains the path to locate the part. If you copy 

the work part or source part to a different folder, you must modify the blank to specify 

the source part in its new location. 

You can also modify the blank to specify a different IPW source. 

The IPW Source dialog box is displayed.  

12. From the Copy IPW from list, select xxx_ipw_setup_1.  

If necessary, select Browse and navigate to your part file.  

13. In the IPW Source dialog box, expand the WORKPIECE geometry object.  

MCS_MILL 

WORKPIECE 

CAVITY_MILL 

CAVITY_MILL_2 

SPOT_DRILLING 

DRILLING 

14. The operations are included in the hierarchy for reference to help you select the correct 

workpiece. You can select only a workpiece for the IPW source. 

15. Select WORKPIECE and click OK.  

The Blank Geometry dialog box is displayed.  

16. Review the status information in the Blank Geometry dialog box. Notice that the IPW 

Source group displays the name of the source part and geometry group you are using for 

the input IPW.  

17. In the Local IPW group, click Update Local IPW from Source .  

 

Notice that in the Local IPW group, the Status line displays Up to Date.  
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18. Click OK.  

The Workpiece dialog box is displayed.  

19. Click OK.  

 

Generate the operations in the second setup assembly 

1. In the Operation Navigator, right-click WORKPIECE and choose Generate.  

NX generates the first tool path. 

2. In the Path Generation dialog box, click OK as necessary to continue generating the tool 

paths for WORKPIECE.  

 

3. Click Yes in the Tool Path generate message box.  

The CAVITY_MILL roughing operation uses a larger diameter tool that does not fit in all 

areas. You can ignore this message.  

4. Close the Information window.  

5. Right-click WORKPIECE and choose Tool Path→Verify.  

The Tool Path Visualization dialog box is displayed.  

6. Click the 2D Dynamic tab.  

7. Click Play.  

 

8. Click OK.  

9. Close the part. 

You completed the activity. 
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Activity: Customize a Probing operation 

Estimated time to complete: 15–25 minutes 

In this activity, you will do the following to customize a probing operation: 

 Add a new custom sub-operation type. 

 Add new parameters to an existing sub-operation type. 

You must customize probing operations before you add suboperations. You cannot modify a 

suboperation once it is used in the current Probing or Generic Motion operation. However, you can 

modify a suboperation that is used in another operation because each operation is independent.  

Launch the Customize a Probing operation activity.  

 

Create the probing operation 

1. Open mnf16_mill_probe_mfg.  

 

2. On the Create toolbar, click Create Operation or choose Insert→Operation.  

3. In the Type group, select probing.  

4. In the Operation Subtype group, click PROBING.  

5. In the Location group, set the options as shown.  

Program T2345A 

Tool UGTI_0402_001 

Geometry WORKPIECE 

Method MILL_FINISH 

6. In the Name group, type CUSTOM_PROBING.  

7. Click OK to create the operation.  
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Customize a standard suboperation type 

1. In the Probing dialog box, in the Options group, click Customize Dialog .  

2. In the Customize Dialog dialog box, in the Items Used group, under Sub-Operation 

Manager, select Linear Move to Point.  

3. Click Customize Sub-Dialog .  

4. In the Customize Sub Dialog dialog box, from the Dialog Item Type list, select Double.  

The Double item adds an input box for a double-precision number parameter.  

5. In the Label box, enter my_double.  

6. In the Default Value box, enter 5.3.  

7. Click Add to Dialog .  

8. Click OK to complete the parameters.  

 

Add a custom suboperation type 

1. In the Customize Dialog dialog box, in the Items Used group, select Sub-Operation 

Manager.  

2. In the Items to Add group, from the Dialog Item Type list, choose User Defined 

Move Type .  

3. In the Label box, enter my_subop.  

4. Click Add to Dialog .  

NX adds my_subop to the Sub-Operation Manager list and selects it.  

5. Click Customize Sub-Dialog .  

 

Add parameters to the custom suboperation type 

1. In the Customize Sub Dialog from the Dialog Item Type list, select Group.  

2. In the Label box, enter my_parameters.  

3. Click Add to Dialog .  

NX adds my_parameters to the Items Used list and selects it.  

4. From the Dialog Item Type list, select Double.  

5. In the Label box, enter my_double.  
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6. In the Default Value box, enter 5.3.  

7. Click Add to Dialog .  

NX adds my_double to the my_parameters group.  

8. From the Dialog Item Type list, select Enumeration.  

9. In the Label box, enter my_list.  

10. In the Enumeration Items box, enter your list options.  

o Option_1 

o Option_2 

o Option_3 

11. Click Add to Dialog .  

NX adds my_list to the my_parameters group.  

12. Click OK to complete the parameters.  

 

Modify the list of available suboperation types 

1. In the Customize Dialog dialog box, in the Sub-Operation Manager list, clear the check 

boxes for all suboperations except my_subop and Linear Move to Point.  

You clear the check box to remove a suboperation from the Type list of the Create Move 

Subop dialog box. You can select the check box later to add the suboperation type if your 

requirements change.  

2. Select my_subop and click until my_subop is below Linear Move To Point.  

3. Click OK to complete your customized suboperation list.  

 

View your customizations 

1. In the Probing dialog box, in the suboperations group, click Add New suboperation.  

2. In the Create Move Subop dialog box, in the Type group, from the list, review the 

available suboperation types.  

Notice there are only two suboperation types: Linear Move To Point and my_subop.  

3. From the Type list, select Linear Move to Point.  

4. Notice the my_double parameter appended to the Linear Move To Point suboperation.  

5. From the Type list, select my_subop.  

6. Review the my_subop parameters.  
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7. Click Cancel to close the dialog box without creating a suboperation.  

8. In the Probing dialog box, click OK to save the customized Probing operation.  

You can use the custom_probing operation as a template for your probing operations.  

9. Close the part. 

You completed the activity. 
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Activity: Use the IPW to reduce non cutting motions 

Estimated time to complete: 4–6 minutes 

In this activity, you will modify a Contour Area operation to use the in-process workpiece (IPW) to 

remove tool path segments that do not remove material  

Launch the Use the IPW to reduce non cutting motions activity.  

 

Open the part and generate the operation 

1. Open mnf16_surface_contour_ipw.  

2. Right-click the background of the Operation Navigator and choose Configure.  

You will configure the Program Order View of the Operation Navigator to ensure the 

Time and Length columns are visible.  

3. In the Operation Navigator Properties dialog box, under View, click Program Order  

4. Set the options as shown. 

Name 

Toolchange 

Path 

Time 

Length 

5. Click OK.  

6. Review the Time and Length values for the CONTOUR_AREA operation.  

Time = 01:37:36  

Length = 1019.7  

7. Double-click CONTOUR_AREA.  

8. In the Contour Area dialog box, in the Actions group, click Replay .  

9. Review the tool path. 
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Notice the cutting motions that do not remove material. Also notice the engage and 

retract motions. 

 

Change the Cutting Parameters options and generate the operation 

1. In the Path Settings group, click Cutting Parameters .  

2. In the Cutting Parameters dialog box, click the Containment tab.  

3. In the Blank group, from the In Process Workpiece list, select Use 3D.  

The Minimize Non Cutting Moves check box is selected by default.  

4. Click OK.  

5. In the Contour Area dialog box, in the Actions group, click Generate .  

6. Review the tool path. 

 

 

Notice how non cutting portions of the tool path were removed to create a more efficient 

tool path. The tool is no longer cutting air. 

7. In the Operation Navigator, review the Time and Length values for the CONTOUR_AREA 

operation.  
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Time and Length values using the IPW:  

o Time = 01:02:55  

o Length = 717.7  

Time and Length values without the IPW:  

o Time = 01:37:36  

o Length = 1019.7  

8. Click OK.  

9. Close the part. 

You completed the activity. 
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Activity: Align the tool to wall UV rulings 

Estimated time to complete: 1–4 minutes 

In this activity, you will modify a Contour Profile operation to align the tool with the UV rulings of 

the part wall.  

Launch the Align the tool to wall UV rulings activity.  

 

Open the part and generate the operation 

1. Open mnf16_contour_profile_swarf.  

 

2. Right-click the background of the Operation Navigator and choose Geometry View.  

3. Double-click VARIABLE_CONTOUR.  

4. In the Variable Contour dialog box, in the Actions group, click Generate.  

5. In the warning dialog box, click OK.  

6. Review the information message and close the information window. 

7. Review the tool path. 

 

 

Change the tool axis option and generate the operation 

1. In the Tool Axis group, from the Axis list, select Swarf Base UV.  

2. In the Actions group, click Generate.  
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3. Review the tool path. 

 

4. Click Verify .  

5. In the Tool Path Visualization dialog box, on the Replay tab, move the Animation slider 

to 1.  

6. Click Play .  

Notice how the tool aligns with the blade contour. 

7. Click OK.  

8. Close the part without saving it. 

You completed the activity. 
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Activity: Create a multi blade blend finish operation 

Estimated time to complete: 5–7 minutes 

In this activity, you will create a mill multi blade blend finish operation. 

 

Launch the Create a multi blade blend finish operation activity.  

 

Open the part and create the operation 

The blend finish operation removes material that remains from the blade finish and hub finish 

operations. 

1. Open mnf16_multi_blade_blend_finish.  

 

2. Choose Analysis→Geometric Properties 

The Geometric Properties dialog box is displayed.  

Analyzing the fillet geometry helps you to determine the correct tool size. 

3. In the graphics window, pause the cursor over the blade blend fillet. 

 

The Minimum Radius value in the Results group of the Geometric Properties dialog box is 

-2.250.  
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You will use a 4 mm ball mill to finish the blade blend fillet. 

4. Click Close.  

5. On the Create toolbar, click Create Operation or choose Insert→Operation.  

6. In the Type group, from the list, select mill_multi_blade.  

7. In the Operation Subtype group, click BLEND_FINISH  

8. In the Location group, set the options as shown.  

Program 1234 

Tool BALL_4 

Geometry MULTI_BLADE_GEOM 

Method MILL_FINISH 

9. The geometry for the operation is inherited from the MULTI_BLADE_GEOM geometry 

parent.  

10. Click OK.  

The Blend Finish dialog box is displayed.  

 

Specify the drive settings 

1. In the Drive Method group, click Blend Finish .  

The Blend Finish Drive Method dialog box is displayed.  

2. In the Cut Periphery group, from the Geometry to Finish list, select Blade Blend.  

3. From the Sides to Cut list, select Left, Right, Leading Edge.  

4. In the Drive Settings group, from the Drive Mode list, select Reference Tool.  

The Reference Tool option provides more control of the cut area and ensures full 

coverage of the area that was not finished in the previous blade and hub operations. The 

smaller tool in the blend finishing operation removes material in the regions where the 

larger reference tool could not fit due to the ball tool diameter.  

5. In the Reference Tool Diameter box, type 5.  

The blade and hub finish operations both use a 5 mm diameter ball mill. 

6. Use the default values for the remaining options. 

Overlap on Hub = 0.0000  

Overlap on Blade = 0.0000  

Cut Band = Stepovers.  



199 
 

 By Design Through Manufacturing Co., Ltd.  
 

Number on Hub = 3  

Number on Blade = 3  

Cut Pattern = Zig 

Sequencing = Steep First 

Cut Direction = Climb 

Start Point = Trailing Edge 

7. In the Preview group, click Display .  

 

8. Evaluate the preview display. 

The tool path is not trimmed, so the tool fits into all regions. 

9. Click OK.  

The Blend Finish dialog box is displayed.  

 

Adjust the cutting parameters 

1. In the Path Settings group, click Cutting Parameters .  

The Cutting Parameters dialog box is displayed.  

2. On the Tool Axis Control tab, move the Axis Smoothing % slider to 100.  

With greater smoothing, the software may not find a gouge-free tool orientation, and will 

trim the cutting motions. 

You will check the tool path for any trimmed cutting motions. 

3. Click OK.  

The Blend Finish dialog box is displayed.  

4. In the Drive Method group, click Blend Finish .  



200 
 

 By Design Through Manufacturing Co., Ltd.  
 

The Blend Finish Drive Method dialog box is displayed.  

5. In the Preview group, click Display .  

 

The tool path preview does not show any trimmed cutting motions. 

6. Click OK.  

The Blend Finish dialog box is displayed.  

7. In the Actions group, click Generate .  

 

8. Click OK.  

9. Close the part. 

You completed the activity. 
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Activity: Create an instance of the multi blade blend finish operation 

Estimated time to complete: 3–5 minutes 

In this activity, you will create a multiple instances of the multi blade hub finish operation. 

 

Launch the Create an instance of the multi blade blend finish operation activity.  

 

Open the part and open the Transformations dialog box 

1. Open mnf16_multi_blade_blend_finish_instance.  

 

2. In the Operation Navigator right-click BLEND_FINISH and choose Object→Transform.  

The Transformations dialog box opens.  

 

Select the transformation parameters 

1. From the Type list, select Rotate About a Point.  

2. On the Selection bar, from the Selection scope list, select Entire Assembly.  

3. In the Transformations Parameters group, click Specify Pivot Point.  

4. In the graphics window, select the hub center arc. 

file:///D:/Siemens/NX%208.0/nxcast/html/etmf758/index.html
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5. In the Angle box, type 360.  

6. In the Result group, select Instance.  

7. In the Distance/Angle Divisions box, type 6.  

8. In the Number of Instances box, type 5.  

9. Click OK 

The instances are displayed in the graphics window and added to the operation navigator. 

You completed the activity. 
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Activity: Create a Hole Milling operation 

Estimated time to complete: 15–25 minutes 

In this activity, you will create a Hole Milling operation with a helical cut pattern.  

 

Launch the Create a Hole Milling operation activity.  

 

Specify the Workpiece geometry 

1. Open mnf15_hole_milling.  

 

2. Right-click in the background of the Operation Navigator and choose Geometry View.  

3. Double-click WORKPIECE.  

4. In the Workpiece dialog box, in the Geometry group, click Specify Part .  

5. Select the part geometry as shown. 

file:///D:/Siemens/NX%208.0/nxcast/html/etmf758/index.html
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6. In the Part Geometry dialog box, click OK.  

7. In the Workpiece dialog box, click OK.  

 

Define the hole geometry 

1. On the Insert toolbar, click Create Geometry .  

2. In the Create Geometry dialog box, in the Type group, from the list, select mill_planar.  

3. In the Geometry Subtype group, click HOLE_BOSS_GEOM .  

4. In the Location group, from the Geometry list, select WORKPIECE.  

5. Click OK.  

6. In the Hole or Boss Geometry dialog box, in the Type group, from the list, select Hole.  

7. Select the first hole diameter as shown. 

 

8. From the Depth Limit list, select Blind.  

9. Select the second hole diameter as shown. 
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10. Click OK.  

 

Create the Hole Milling operation 

1. On the Create toolbar, click Create Operation or choose Insert→Operation.  

2. In the Type group, from the list, select mill_planar.  

3. In the Operation Subtype group, click HOLE_MILLING .  

4. In the Location group, set the options as shown.  

Program PROGRAM 

Tool END_MILL_2 

Geometry HOLE_BOSS_GEOM 

Method METHOD 

5. Click OK to create the operation.  

 

Specify the operation parameters 

1. In the Hole Milling dialog box, in the Path Settings group, from the Cut Pattern list, 

select Helical.  

2. From the Blank Diameter list, select Diameter.  

3. In the Start Diameter input box, type 0.500.  

4. From the Start Diameter units list, select in.  

5. Use the default values for the remaining options. 

Under Axial:  

o Depth per Revolution = Distance.  

o Pitch = 25.0 %Tool 

Under Radial:  
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o Radial Stepover = Constant 

o Maximum Distance = 50.0 %Tool 

 

Turn on the cleanup passes 

1. Click Cutting Parameters .  

2. In the Cutting Parameters dialog box, click the Strategy tab.  

3. In the Cleanup Passes group, select the Add Cleanup Passes check box.  

4. Click OK.  

 

Generate the operation 

1. In the Hole Milling dialog box, in the Actions group, click Generate .  

 

2. Click OK to save the operation.  

3. Close the part. 

You completed the activity. 
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Activity: Tilt Tool Axis 

Estimated time to complete: 10–12 minutes 

In this activity, you will use the Tilt Tool Axis option to avoid tool holder collisions with the part 

and reach greater depths using the shortest tools possible . NX replaces the colliding 3-axis motions 

with 5-axis motions to avoid the collision.  

Launch the Tilt Tool Axis activity.  

 

Verify the existing tool path 

1. Open mnf15_electrode.  

2. In the Operation Navigator, right-click in the background and choose→Geometry View.  

3. Right-click FIXED_CONTOUR and choose Tool Path→Verify.  

4. In the Tool Path Visualization dialog box, click the 2D Dynamic tab.  

Make sure that the Check for IPW Collisions and Check Tool and Holder check boxes 

are selected.  

5. Move the Animation Speed slider to 3.  

6. Click Play .  

7. In the No blank message box, click OK.  

8. In the Blank Geometry dialog box, in the Type group, from the list, select Offset from 

Part.  

9. In the Offset group, in the Offset input box, type .030.  

10. Click OK.  

Notice the tool holder and part collision along the high ridge of the part. You made need 

to orient the view similar to the illustration shown to see the interference. 

 

11. In the Tool Path Visualization dialog box, click List.  

In the Information window, NX lists the location of every collision in the tool path. Review 

some of the coordinates.  

file:///D:/Siemens/NX%208.0/nxcast/html/etmf758/index.html
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12. Close the Information window.  

13. In the Tool Path Visualization dialog box, click OK.  

 

Tilt the tool axis to avoid collisions 

1. In the Operation Navigator, right click FIXED_CONTOUR and choose Tool Path→Tilt Tool 

Axis.  

NX replaces the colliding 3-axis motions with 5-axis motions to avoid the collision. 

2. In the Tool Path Tilt dialog box, review some of the parameters settings and accept the 

defaults.  

3. Click OK.  

The tool axis tilt calculation can take a few minutes to complete. 

Visually inspect the tool path  

1. In the Operation Navigator, right-click FIXED_CONTOUR and choose Tool Path→Verify.  

2. In the Tool Path Visualization dialog box, click the 2D Dynamic tab.  

Make sure the Check for IPW Collisions and Check Tool and Holder check boxes are 

selected.  

3. Move the Animation Speed slider to 3.  

4. Click Play .  

5. In the No blank message, click OK.  

6. In the Blank Geometry dialog box, from the Type list, select Offset from Part.  

7. In the Offset group, in the Offset box, type .030.  

8. Click OK.  

Notice how the tool axis tilts away from the part to avoid collisions.  
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After the verification is complete, notice that the List option is no longer available in the 

Tool Path Visualization dialog box. The option is not available because no collisions were 

detected.  

9. Click OK.  

If you regenerate the operation in which NX tilted the tool path, the tilted tool path is not 

maintained, and the tool path reverts to being a 3-axis tool path.  

10. Close the part. 

You completed the activity. 
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Activity: Post process tool paths 

Estimated time to complete: 3–5 minutes 

In this activity, you will post process tool paths using the NX POST post processor. 

 

Launch the Post process tool paths activity.  

 

Post process the tool path 

1. Open mnf3_bearing_case_mfg_3.  

 

2. In the Operation Navigator, right-click in the background and choose Program Order 

View.  

3. Right-click in the background again and choose Expand All.  

4. Click the PROGRAM folder.  

5. On the Operations toolbar, click Post Process .  

6. In the Postprocess dialog box, in the Postprocessor group, from the list, select 

MILL_3_AXIS.  

7. In the Output File group, accept the default name in the File Name input box.  

You need to specify a name and location for the posted output file that you are about to 

create. The default location is your current directory. 

 

file:///D:/Siemens/NX%208.0/nxcast/html/etmf758/index.html
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8. Click OK.  

The Information window is displayed containing the post processed output for the three 

tool paths CAVITY_MILL, FINISH_WALLS, and SPOT_DRILLING operations. View the output 

of the program.  

 

9. Close the Information window.  

10. Do not save or close the part. You will use the same part in the next activity. 

You completed the activity. 

 

 

 

 

 

 

 

 

 

 

 

 

 


