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เพ่ิมความสามารถการท างานในค าสัง่ Command Finder โดยเพ่ิมออบชัน่ให้สามารถท าการคน้หา

ค าสัง่ท่ีตอ้งการหาเฉพาะในหมวดค าสัง่ท่ีท างานอยู่เท่านั้น 

 

 

 
เม่ือพบค าสัง่ท่ีตอ้งการจากการคน้หา ผูใ้ชง้าน
สามารถเลือกค าสัง่ท่ีต้องการ จากนั้นท าการคลิก
เมาส์และท าการออบชัน่ Show on Menu หรือ Show 
on Toolbar เพ่ืองแสดงแสดงต าแหน่งหรือเปิด
ไอคอนของค าสัง่ในหนา้ต่างของซอฟแวร์ 

 

Toolbar and menu consistency and Roles 
มีการจดักลุ่มของค าสัง่ใน Toolbar และ Menu bar ใหม่ เพ่ือให้เหมาะสมกบัการใชง้าน  และการ

เพ่ิมรูป Role ให้ผูใ้ชง้านสามารถเลือก Role ตรงกบัรูปแบบและลกัษณะท่ีใชง้านซอฟแวร์ 
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Add or Remove Buttons on toolbar drop-down lists 

ผูใ้ชง้านสามารเพ่ิมหรือลบปุ่มค าสัง่ใน drop-down lists ไดง่้ายข้ึน โดยคลิกเมาส์ปุ่มขวาบน Toolbar 

จากนั้นเลือก Customize จากนั้นท าการ เพ่ิมหรือลบปุ่มค าสัง่ใน drop-down lists ไดต้ามตอ้งการ 

 

 

Correction toolbars 

ในหมวดการท างานแบบ Full Screen Mode มีการเพ่ิม Correction toolbars เพ่ือรวมค าสั่งในหมวด

การท างานท่ีใชง้านอยูไ่วด้ว้ยกนั  เพ่ือลดเวลาในการจดัเรียกค าสัง่ในแต่ละหมวดการท างาน  มีเฉพาะใน

หมวดการท างานแบบ Modeling ,Shape Studio ,Drafting เท่านั้น 
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Save a user role with the current layout 
มีออบชัน่ใหม่เพ่ิมในส่วนของ Role คือ Update with Current Session เพ่ือปรับปรุงรูปของ Role 

ของผูใ้ชง้านให้ตรงกบัรูปแบบของการจดัเรียงไอคอน และ รูปแบบการท างานของซอฟแวร์  ในขณะนั้น   
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Last  applied role  

ค่าของ Role งานอยู่ในปัจจุบนัจะแสดงในแถบของ Role ในหนา้ต่าง Toolbar Customize 

 

 

 

Point Constructor enhancement 
มีการเพ่ิมออบชัน่ในส่วนของระบบอา้งอิง( Reference) ในการก  าหนดต าแหน่ง ของ Point 

Constructor โดยแบ่งออกเป็น 4 แบบ 

- Absolute-Work Part (อา้งอิงต าแหน่ง Absolute ของช้ินงานท่ีถูกก  าหนดเป็น Work part ) 

- Absolute-Displayed Part  (อา้งอิงต าแหน่ง Absolute ของช้ินงานท่ีแสดงอยูใ่น Graphics Area ) 
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- WCS (อา้งอิงกบัระบบแกน WCS ท่ีใชง้านอยู่ในขณะนั้น) 

- Drawing อา้งอิงกบัต าแหน่งของกระดาษเขียนแบบ  
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Point on Bound Grid  

เพ่ิมออบชัน่ Point on Bound Grid ในส่วนของเคร่ืองมือช่วยในการเลือก Selection bar เพ่ือช่วย 

snap จุดตดัของ grid ในการก  าหนดต าแหน่ง 
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Auto accept of command input  
ใน NX 7.5 เม่ือท าการก  าหนดค่าต่างๆให้ค าสัง่ตามท่ีซอฟแวร์ตอ้งการจนครบแลว้ เราสามารถเรียก

ค าสัง่อ่ืนใชง้านต่อไดเ้ลยโดยไม่ต้องคลิกปุ่ม OK หรือ Apply โดยซอฟแวร์จบค าสัง่เดิมให้โดยอตัโนมติั 

 
 

 

 

 

Handle and visual indicators enhancements 
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มีการปรับเปล่ียนรูปแบบและฟังชัน่การท างานของ Handle และลูกศร ท่ีใชก้  าหนดค่าต่างๆ   เพ่ือให้

ผูซ้อฟแวร์สามารถ สร้าง ,แกไ้ขไดโ้ดยง่าย 

 

เราสามารถเปล่ียนสีของ Handle และลูกศร ไดโ้ดยคลิกท่ี Preferences ->Visualization Preferences-
> Handles ->Part Settings ->Handles -> Color Setting และนอกจากนั้นสามารถเปล่ียนสีของ Pole และ 
Poly line ไดโ้ดยคลิกท่ี Preferences->Modeling->Analysis->Pole and Poly line Display 

 
 
 
 
 
 

File New enhancement  
ในส่วนของหนา้ต่างของค าสัง่ File-> New ไดท้ าการเพ่ิม Tab ของ Inspection ส าหรับในการท างาน

ในส่วนของ Inspection Programming 

 



10 
www.dtm-thailand.com 

 
 

 
 
 
 
Inspection Navigator 

ในส่วนของ NX 7.5 มีการเพ่ิม Inspection Navigator ใน Resource bar เพ่ือช่วยในท างานในส่วน
ของ Inspection Programming 
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Generate accurate section curves with lightweight loading  
เม่ือท าการเปิดไฟลช้ิ์นงานขนาดใหญ่และท าการก  าหนดค่า Load option เป็นแบบ Lightweight เพ่ือ

ลดการใช้ หน่วยความจ า (RAM) และ หน่วยประมวลผล CPU เพ่ือให้การแสดงผลและการหมุนช้ินงานใน
ซอฟแวร์เร็วช้ิน  แต่เม่ือท าการ View section และ สร้างเสน้ Section จะพบว่ามีจะคลาดเคล่ือน  ซ่ึงแตกต่าง
จากเสน้Section ท่ีไดจ้ากการ Load แบบ Fully load   

 
สามารถแกปั้ญหาน้ีไดโ้ดยการก  าหนดค่าใน  File-> Utilities -> Customer Defaults -> Gateway -

>View Operations -> View Section 

 
 
 

New customer defaults for collapsed groups and on-screen input boxes 
เม่ือก  าหนดค่า Keep Group Closed if Selection on Block in Group gets Focus ใน Customer 

Default   แมว้่าออบชัน่ท่ีท างานอยูถู่กย่อส่วนในหนา้ต่างของค าสัง่ ซอฟแวร์จะแสดงแถบสีของออบชัน่ท่ี
ท างานอยูใ่นขณะนั้น 
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เม่ือก  าหนดค่า Show All Out-of-Focus Handle Input Fields ใน Customer Default  ซอฟแวร์จะ
แสดง Input box แมว้่าค่าดงักล่าวจะไม่ถูกเลือก  

 

      
                         เปิดออบชัน่                                                               ปิดออบชั่น 

Direct Sketching 
ในเวอร์ชนั NX7.5 ได้มีการเพ่ิม Sketching รูปแบบใหม่ท่ีช่ือว่า Direct Sketching  ดว้ยค าสัง่ใน 

Toolbar  ของ Direct Sketch ผูใ้ชง้านสามารถสร้างเสน้ต่างของ Sketch ไดง่้ายและรวดเร็ว โดยไม่ต้องเขา้
หมวดท างานของ Sketch โดยจุดแรกท่ีผูใ้ชง้านก  าหนดในการสร้าง จะเป็นตวัก  าหนด Sketch Plan , 
Orientation ,Origin ของ Sketch   
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ตัวอย่างการสร้าง Direct Sketch 
 
ขั้นตอนท่ี1 

คลิกค าสัง่   Rectangular ใน Toolbar  ของ Direct Sketch 
 
ขั้นตอนท่ี2 

คลิกบนผิวของช้ินงานเอก  าหนดจุดแรกของส่ีเหล่ียม  

 

 
 
ขั้นตอนท่ี3 

คลิกบนผิวของช้ินงานเอก  าหนดจุดท่ีสองของส่ีเหล่ียม  
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ซอฟแวร์จะก  าหนด Dimension และ Constraint ให้เป็นแบบ fully โดยอตัโนมติั 

 
ขั้นตอนท่ี4 

   คลิกค าสัง่   Rectangular ใน Toolbar  ของ Direct Sketchและคลิกบนผิวของช้ินงานเอก  าหนด
จุดแรกของส่ีเหล่ียม  

 
 
ขั้นตอนท่ี5 

คลิกบนผิวของช้ินงานเอก  าหนดจุดท่ีสองของส่ีเหล่ียม ซอฟแวร์จะก  าหนด Dimension และ 
Constraint ให้เป็นแบบ fully โดยอตัโนมติั 
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ขั้นตอนท่ี6 

คลิกค าสัง่   Quick Trim ใน Toolbar  ของ Direct Sketch เพ่ือตดัเส้น และท าการตดัเสน้ตาม
รูปดา้นล่าง 

 
ขั้นตอนท่ี7 

คลิกค าสัง่   Extrude  ใน Toolbar  จากนั้นท าเลือกเสน้ Sketch จะไดช้ิ้นงานตามรูปดา้นล่าง 
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Edit Direct Sketch 

เราสามารถแกไ้ข Direct Sketch ไดโ้ดย ท าการดบัเบ้ิลคลิกบนหนา้จอหรือเลือก Sketch ใน Part 
Navigator แลว้คลิกขวาแลว้เลือก Edit หรือ ดบัเบ้ิลช่ือของ Sketch ใน Part Navigator 
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เม่ือท าการแกไ้ข Sketch ช้ินงานทันที ถา้ค่าของ Sketch มีความสัมพนัธ์กบัหลาย Feature แนะน าให้

ผูใ้ชง้านท างานท าการแกไ้ขในหมวดท างานของ Sketch   โดยคลิก   Open Sketch in task 
environment ใน Toolbar  ของ Direct Sketch 

 
 
 
 
 
 

Intermediate Datum CSYS 
ซอฟแวร์จะท าการสร้าง Intermediate Datum CSYS  โดยอตัโนมตัเม่ือเราท าการสร้าง หรือ reattach 

ของ Sketch โดยจะถูกสร้างระหว่างการเลือก Geometry ในการสร้าง Sketch  โดยค่า Default ของ Software 
ในส่วน Datum CSYS  จะถูกเกบ็ไวภ้ายใน Sketch โดยไม่สามารถมองเห็นใน Part Navigator  ถา้ตอ้งการ
ให้แสดง Datum CSYS  ของ Sketch แสดงใน Part Navigator สามารถท าไดโ้ดย เลือก Sketch ใน Part 
Navigator ท าการคลิกขวาและเลือก Make Datums  External  
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DATUM CSYS: Plane ,X-Axis, Point 
เพ่ิมออบชัน่ Plane ,X-Axis, Point ในการสร้าง DATUM CSYS โดยท าการเลือก Plan ส าหรับ Z-

Axis ,เลือกแกน X และเลือกจุดท่ีจะถูกProjectลงบนเป็น Plane  โดยออบชัน่น้ีถูกใชใ้นการวางระนาบของ 
Sketch  เม่ือท าการแกไ้ข Sketch ,Geometry ต่างยงัคง Update แมว้่าผิวSurface ท่ีใชอ้า้งอิงของ DATUM 
CSYS จะถูกลบ หรือ Suppress  
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 Auto Dimension  
ดว้ยค าสัง่ Auto Dimension เราสามารถก  าหนด Dimension ให้กบัเส้นหรือจุด โดยอตัโนมติั ซ่ึงจะ

สมัพนัธ์กบัขอ้ก  าหนด(Rule)ท่ีตั้งไว ้
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ขอ้ก  าหนด(Rule)ในการก  าหนด Dimensionโดยอตัโนมติัประกอบดว้ย 

- Create Horizontal and Vertical Dimensions on Lines 
- Create Dimensions to Reference Axes 
- Create Symmetric Dimensions 
- Create Length Dimensions 
- Create Adjacent Angles 

 
 
เราสามารท าการเลือกชนิดของ Dimension ท่ีจะท าการสร้างได ้2 ชนิด 

1. Driving (แบบเดิม ในเวอร์ชั่น NX7.0 และกอ่นหนา้) 
การสร้าง Dimension จะอา้งอิงกบั Expression เราสามารถเปล่ียนค่า Driving Dimension มาเป็น 

Reference  Dimension 
2. Automatic 
เป็น Dimension แบบใหม่ท่ีสามารถสร้างดว้ย Auto Dimension เท่านั้น  โดย Auto Dimension จะ

ท าการค่า Dimension constrainให้กบัเส้น Curve ท่ีถูกจนสมบูรณ์เป็น Fully Constraint  ขนาดของ
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Dimension จะท าการปรับปรุง เม่ือท าการลากยา้ยเส้น Curve ของ Sketch  ค่าของ Auto Dimension ไม่ได้ถูก
ก  าหนดไวแ้บบถาวร เม่ือท าการเพ่ิม Constraint ซ่ึงขดัแยง้กบั Auto Dimension ท่ีมีอยูแ่ลว้ , Auto Dimension 
ท่ีขดัแยง้จะถูกลบออกโดยอตัโนมติั  

 

 
 
  นอกจากนั้นเราย ั้งสามารถเปล่ียน Auto Dimension เป็น Driving Dimension 
 
 
 
 
 

 Continuous Auto Dimensioning 
เม่ือเปิดใช้ออบชั่น Continuous Auto Dimensioning  เม่ือท าการสร้างเสน้Curve ของ Sketch ค่า 

Dimension จะถูกก  าหนดให้อตัโนมติั  ซ่ึงจะช่วยลดเวลาในการก  าหนด Dimension ให้กบั Sketch โดย 
Dimension ท่ีถูกสร้าง  เป็น Dimension แบบใหม่ท่ีสามารถสร้างดว้ย Auto Dimension เท่านั้น เม่ือท าการ
เพ่ิม Constraint ซ่ึงขดัแยง้กบั Auto Dimension ท่ีมีอยูแ่ลว้ ,Auto Dimension ท่ีขดัแยง้จะถูกลบออกโดย
อตัโนมติั 

 

 Replace with Independent Sketch 
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ใชอ้อบชัน่น้ีในการแทนท่ี Wave linked sketch หรือ Linked curve  ดว้ย Sketch ท่ีเป็นอิสระไม่
สมัพนัธ์กบั linked sketch หรือ Linked curve ตน้แบบ  ตวัอยา่งเม่ือท าการออกแบบและพฒันาผลิตภณัฑ ์เรา
มีผงัการจดัวางหลกัเพ่ือควบคุมการออกแบบช้ินส่วนยอ่ยต่างๆ  เม่ือท าการพฒันาออกมาเป็นผลิตภณัฑแ์ลว้  
ในส่วนของหน่วยงานดา้นการผลิต  เราไม่ต้องการให้ช้ินส่วนยอ่ยต่างๆ  เปล่ียนเม่ือผงัการจดัวางหลกั
เปล่ียน เราสามารถตดัความสมัพนัธ์ของ linked sketchและแทนท่ี Sketch ท่ีเป็นอิสระไม่สมัพนัธ์กบั linked 
sketch เดิม ข้อดีคือเราสารถเปล่ียน dimension และ constrain ของ Sketch ท่ีเป็นอิสระเพ่ือท าการแกไ้ข 

 
 Makes Symmetric 

เราสามารถใชค้ าสัง่ Makes Symmetric เพ่ือก  าหนดเง่ือนไข Constrain ให้กบั จุดสองจุด หรือเส้น
สองเส้นให้สมมารถรอบเสน้ Centerline ใน Sketch 

 
 
 

 Pattern Curve   
เราสามารถใชค้ าสัง่ Pattern Curve ในการคดัลอกซ ้ า เสน้ edge ,curve , จุด ใน Sketch  ,การคดัลอก

จะอยู ่แนวระนาบของ Sketch Plane โดยเราสามารถ คดัลอกไดท้ั้งแบบ Linear Pattern หรือ Circular Pattern  
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 Polygon  
เราสามารถใชค้ าสัง่ Polygon ในการสร้างรูปหลายเหล่ียมใน Sketch โดยการก  าหนด 
- Center point 
- Number of sides 
- Radius 
- Rotation angle 

 
 
นอกจากนั้นยงัสามารถก  าหนดวิธีการสร้างรูปหลายเหล่ียมตามดา้นล่าง  
- Inscribed Radius 
- Circumscribed Radius 
- Side of Polygon 
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 Chamfer 
เราสามารถใชค้ าสัง่ Chamfer ในการสร้าง Chamfer บริเวณมุมระหว่างเส้นตรงสองเสน้ในSketch 

เราสามาถก  าหนดชนิดของ Chamfer ไดส้ามแบบ  
- Symmetric 
- Asymmetric 
- Offset and Angle 

 

 
 
 
 
 
 
Exit Sketch 
 เราใช ้Exit Sketch ในการออกจากหมวดการท างานของ Sketch โดยไม่ท าการบนัทึกส่ิงท่ีแกไ้ข, 
เปล่ียนแปลง หรือ แกไ้ขช้ินงาน ค าสัง่ Exit Sketch เป็นการกลบัเขา้สู่ค่าเดิมของSketch กอ่นท่ีจะเขา้สู่การ
ท างานใน Sketch เพ่ือป้องกนัการเปล่ียนแปลงของ Sketch โดยไม่ไดต้ั้งใจ 
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Copy or move sketch geometry in a vertical or horizontal direction 
 เราสามารถยา้ย Sketch ในแนวนอน หรือ ในแนวตั้งฉาก, Move หรือ Copy   พร้อมทั้งการ Snap 
หรือไม่Snap โดยใช้ Keyboard Shortcuts    

 
To do this task Perform this action 

Move vertically or horizontally with snapping. Hold Shift and drag 

Move vertically or horizontally without snapping. Hold Shift+Alt and drag 

Copy vertically or horizontally with snapping. Hold Shift+Ctrl and drag 
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Copy vertically or horizontally without snapping. Hold Shift+Ctrl+Alt and drag 

 
Cut / Copy / Paste enhancements 
 เราสามารถท าการ Cut / Copy / Paste วตัถุใน Sketch ท่ีใชง้านอยู ่หรือ ไปยงั Sketch ใหม่ 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Modeling 
 

 Projection Curve enhancements 
 ใน NX7.5 ไดมี้การเพ่ิมความสามารถของ ค าสัง่ Projection Curve ดงัต่อไปน้ี 
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1. เพ่ิมออบชัน่ Project to Nearest Point along Vector   เม่ือเปิดใช้ออบชัน่ ซอฟแวร์จะท าการ 
project ไปยงั Surface ท่ีใกลเ้ส้น Curve ท่ีก  าหนดมากท่ีสุด ในกรณีท่ีมีผิว  Surface ท่ีเป็นตวัเลือกมากกว่า
หน่ึงผิว 
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เราสามารถใชง้าน  เม่ือ  Nearest Point along Vector    
- เม่ือก  าหนดค่า Direction เป็นแบบ Along Vector 
- เม่ือก  าหนดค่า Projection Option เป็นแบบ None หรือ Project Both Sides 

 
2. เพ่ิมออบชัน่ Create Curve to Bridge Gaps เม่ือท าการ Project เสน้ CurveไปยงัSurfaceท่ีมี

ช่องว่าง (Gap ) ซอฟแวร์จะสร้างเสน้เช่ือมบริเวณช่องว่างและท าการรวมเสน้ทั้งหมดเป็นเส้นเดียวกนั   
ซอฟแวร์จะสร้างเส้นเช่ือมบริเวณช่องว่าง  

- ระยะช่องว่าง (Gap )นอ้ยกว่าค่า Maximum Bridged Gap Size 
- ระยะช่องว่าง (Gap )มากกว่าค่า Default ของ Modeling Tolerance 

 

 
3. เพ่ิมออบชัน่ Gap list เพ่ือแสดงขอ้มูลต่างๆของ สร้างเส้นเช่ือมบริเวณช่องว่าง Surface 
4. เพ่ิมออบชัน่ Preview เพ่ือแสดงตวัอยา่งของ Projection Curve กอ่นการสร้างจริง 

 
 Composite Curve enhancements 

 ใน NX7.5 ไดมี้การเพ่ิมความสามารถของ ค าสัง่ Composite Curve ดงัต่อไปน้ี 
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1. เพ่ิมออบชัน่ Join Curves เพ่ือเช่ือมเส้น Composite Curve เขา้ดว้ยกนั  และ สามารถก  าหนด 
Degree ของเส้น Composite Curve เขา้ดว้ยกนัโดยมีออบชั้นดงัต่อไปน้ี 

- No ไม่เช่ือมเสน้เขา้ดว้ยกนั 
- Cubic Degree ของเสน้ Composite Curve เป็นดีกรี 3 
- General จ านวน Degree ของเสน้ Composite Curve จะเท่ากบัเส้น Composite Curve เดิม 
- Quintic Degree ของเสน้ Composite Curve เป็นดีกรี 5 

 
2. เพ่ิมออบชัน่ Tolerance เพ่ือก  าหนดค่า Tolerance ของการเช่ือมเส้น ซ่ึงจะเหมือนกบัการ

ก  าหนดค่าใน Modeling Preferance 

 
Selection Intent for Composite Curve 
 NX7.5 ไดมี้การเพ่ิมความสามารถในส่วนของออบชั่นการช่วยในการเลือก Selection Intent  ของ
ค าสัง่ Composite Curve ดงัต่อไปน้ี 
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1. Body Edge ช่วยในการเลือดเส้นขอบทั้งหมดของช้ินงาน และถา้ในกรณีช้ินงานประกอบดว้ย
ผิวของ Surface จ านวนมาก ผูใ้ชซ้อฟแวร์จะตอ้งเปิดออบชั่น Allow Self-intersection ใน หนา้ต่างของค าสัง่ 
Composite Curve เพ่ือเลือกเส้นทั้งหมด 

2. Boundary Edge Only จะท าการเลือดเฉพาะเส้นขอบดา้นของของผิวช้ินงานเท่านั้น 

 
 
 
 
 

 Extract Virtual Curve 
 เป็นค าสัง่ใช้ในสร้างเสน้เสมือน ของ แกนหมุนของ Surface , เสน้ Center line ของผิว Blend ,
เสน้แนวตดัเสมือนของของผิว Blend 
 

- แกนหมุนของ Surface - เส้น Center line ของผิว Blend 
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- เส้นแนวตดัเสมือนของของผิว Blend 

 

 
 

 
 

Maple Mathematical Package Integration 
 NX7.5 ไดมี้การรองรับการท างานของ Maple Worksheet Integration  ของบริษทั Maple ,Inc. 
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Selection Intent enhancement 
 NX7.5 ไดมี้การเพ่ิมออบชั่นการเลือกใน Selection Intent ไดแ้ก ่Single Body , Feature Bodies, 
Body in Group ส าหรับเลือกช้ินงาน ,และเพ่ิมออบชัน่ Curves in Group ในส่วนของ Curve Rule เพ่ือเลือก
กลุ่มย่อยของเสน้ Curve  
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 Extrude – Inferred Boolean 
 NX7.5 ไดมี้การเพ่ิมความสามารถให้กบัค าสัง่ Extrude โดยจะท าการเลือกค่า Default ส าหรับ 
Boolean Operation ท่ีเหมาะสมโดยอตัโนมติั โดยข้ึนอยู่กบัทิศทางของการ Extrude และ Section Normal , 
โดย Tool Body จะตอ้งสมัผสัหรือมีส่วนทบัซอ้นกบั Target Body 

 

 
 

Offset Curve in Face –Enhancements 
 ไดมี้การเพ่ิมความสามารถในส่วนของ  Offset Curve in Face ไดแ้ก ่

 
1. ในส่วนของ Type ไดเ้พ่ิมออบชัน่ Variable Offset ผูใ้ชง้านสามารถก  าหนดระยะค่า offset ได้

หลายค่า   
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2. ในส่วนของ Direction and Method Group ไดเ้พ่ิมออบชัน่ Offset Direction ผูใ้ชง้านสามารถ

ก  าหนดทิศทางในการ offset โดยสามารถก  าหนดได ้2 วิธี 
2.1 Normal to Curve  ทิศทางในการ offset จะตั้งฉากกบัเสน้ Curve 

 

 
 
 
 

2.2 Normal to Vector ผูใ้ชง้านสามารก  าหนดทิศทางในการ offset 
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3. Projected Distance เป็นออบชัน่ใหม่ในส่วนของ Offset Method เพ่ือก  าหนดค่าระยะ offset บน 

virtual plane  

 
4. สามารถท าการ Offset บน Datum plane เหมือนกบั Offset บนผิว Surface 

 
5. เม่ือก  าหนดค่า Offset เป็นแบบ Variable Offset ผูใ้ชง้านสามารถก  าหนด Law-Defined 
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6. Fillet Sharp Corner ผูใ้ชง้านสามารถลบมุมแหลมและแทนท่ีดว้ยเสน้โคง้  
 

 
 

7. ในส่วนของ Setting มีการเพ่ิมออบชัน่ประกอบดว้ย 
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7.1 Curve Fit ผูใ้ชง้านสามารถเพ่ิม Degree ,Segments ของเส้น Offset เพ่ือปรับความ 
smooth 

7.2 Join Curves  ใชใ้นการก  าหนดออบชั่นส าหรับการเช่ือมเสน้เขา้ดว้ยกนั 
 

 
 

 Offset Surface – Enhancements 
NX7.5 ไดมี้การเพ่ิมความสามารถให้กบัค าสัง่ Offset Surface ไดแ้ก ่

1. Approximate Offset Faces ถูกก  าหนดเป็นค่า Default ของซอฟแวร์โดยผูใ้ชก้ารงานไม่ต้อง
ก  าหนด ซ่ึงออบชั่นขา้งตนจะช่วยแกปั้ญหา self-intersection เม่ือท าการ Offset surface และ ออบชัน่ 
Approximate Offset Faces ไดถู้กลบออกจากหนา้ต่างค าสัง่ Offset Surface 
 

  
 NX6                                                                      NX7 

 
2. Partial Result เม่ือผูใ้ชง้านเปิดใชง้านออบชัน่ Partial Result ในการ Offset surface ในการ 

Offset surface ซอฟแวร์จะคงผิวท่ีสามารถท าการ Offsetไดไ้ว ้และ ซอฟแวร์จะลบผิวSurface ท่ีปัญหาจาก
การ Offset  จาก surfaceท่ีก  าหนดโดยอตัโนมติั  โดยผูใ้ชง้านสามารถสร้างผิว surface อุดช่องดว้ยค าสัง่ 
surface ไดภ้ายหลงั 
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Partial Result 

 
 
 
 
 
 

 Datum Plane- enhancement 
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 NX7.5 ไดมี้การเพ่ิมความสามารถให้กบัค าสัง่ Datum Plane โดยผูใ้ชง้านสามารถสร้าง Datum Plan 
ท่ี Offset จาก Datum Plan อ่ืนในขั้นตอนเดียว  ตวัอยา่งเช่น การ Offset ของ Datum Plan จาก 2 Datum Plan 
โดยไม่ตอ้งสร้าง Datum Plan ท่ีอยูร่ะหว่างทั้ง 2 Datum Plan เพ่ือการ Offset 

 

 
 

 Layer Setting- Enhancements 
NX7.5 ไดมี้การเพ่ิมความสามารถเก ีย่วกบั Layer ดงัต่อไปน้ี 

1. ผูใ้ชงานสามารถเลือก Layer ในหนา้ต่างของ Layer Setting เพ่ือท าการ Delete ,Rename  
category หรือแกไ้ข category  description  ซ่ึงง่ายต่อการใชง้าน 

 

 
2. ใน Customer Default ผูใ้ชง้านสามารถก  าหนดออบชัน่ Restrict One Layer to One Category  

เพ่ือจ ากดัให้หน่ึงCategoryมีหน่ึงLayerเท่านั้น 
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 Extrude enhancement – intersecting section curves  
 ผูใ้ชง้านสามารถใชค้ าสัง่ Extrude เพียง Feature เดียวในการ Extrude เสน้ Curve ท่ี การตัดกนั 
(Intersection) กนั ซ่ึงต่างจากเวอร์ชัน่ตอ้งใช ้Extrude หลาย Feature 

 

 
 

 โดยตอ้งท าการเปิดออบชัน่ใน Customer Default : File→ Utilitiies→ Customer Defaults→ 
Modeling→ General→ Miscellaneous tab→ Allow Self-intersecting Section in Extrude Feature 
 

 
 
 
 
 
 

Edit sketch section dimensions outside Sketch  
 เม่ือกลุ่มออบชั่น Section ในหนา้ต่างของค าสัง่ถูกเลือก ผูใ้ชง้านสามารถแกไ้ขขนาดของ Sketch ได้
โดยตรงจากในบริเวณ Graphic Area โดยไม่ตอ้งแกไ้ขในหมวดการท างานของ Sketch   สามารถใช้
ความสามารถน้ีกบัค าสัง่ท่ีตอ้งก  าหนด section ตวัอยา่งเช่น Extrude ,Revolve ,Louver ( ไม่สามารถใชง่าน
ร่วมกบั Auto-Dimension )  
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Region Boundary Curves 
 เพ่ิมออบชัน่ Region Boundary Curves เพ่ือช่วยเลือกเสน้ Sketch Curve ในค าสัง่ท่ีมีการเลือก 
Sketch Curve ตวัอยา่งเช่น Extrude ,Revolve 

 
Reuse 2D section objects 
 สามารถก  าหนด Sketch ,จุด ,เสน้ Curve เป็นReuse Library เราสามารถใช ้2D ซ ้ าไดห้ลายคร้ัง  เพ่ือ
ลดเวลาของการท างานซ ้ า 
 

Feature Dimensions for sketch driving dimensions 
 ผูใ้ชง้านสามารถใชค้ าสัง่ Feature Dimensions ในการแสดงและแกไ้ขค่า dimension ของ Sketch 
โดยไม่ตอ้งเขา้สู่หมวดท างานของ Sketch 
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Group enhancements 
 ผูใ้ชง้านสามารถจดักลุ่มวตัถุต่างและแกไ้ข ไดด้ว้ย ค าสัง่ Group ซ่ึงจะช่วยในง่ายการท างาน 
Format -> Group 
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Feature Group 
ผูใ้ชง้านสามารถจดักลุ่มของ Feature ไดด้ว้ย ค าสัง่ Group ซ่ึงจะช่วยง่ายในการมอง ,การเลือก และการการ
ท างานอ่ืน 
Format -> Feature Group 

 
 
 
 

 
 
 
 
 
 

 Edit curve parameters enhancement 
 ผูใ้ชง้านสามารถใชค้ าสัง่  Edit curve parameters ในการแกไ้ข Non-Associative line หรือ Curve 
ตวัอยา่ง เส้นท่ีสร้างจากค าสัง่ Basic Curve  (Edit -> Curve -> Parameters) 
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 Make Offset 
 ผูใ้ชง้านสามารถใชค้ าสัง่  Make Offset ในการปรับระยะ offset ระหว่างสองผิวมีค่าเท่ากนัตลอด  
เป็นค าสัง่ในกลุ่มของ Synchronous Modeling (Insert→ Synchronous Modeling→ Relate→ Make 
Offset) 

 

 
 
 

Error during update enhancements 
 เม่ือมีการ update หรือ แกไ้ขช้ินงาน เม่ือพบวามีการผิดพลาดเกดิข้ึน ซอฟแวร์จะก  าหนดให้ Feature 
ดงักล่าวเป็น Current Feature เพ่ือให้ผูใ้ชง้านแกไ้ขขอ้ผิดพลาดให้ถูกตอ้ง  
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 Face Blend – three-face blend enhancements 
 NX7.5 ไดมี้การเพ่ิมความสามารถให้กบัค าสัง่ Face Blend โดยผูใ้ชง้านสามารถก  าหนด ผิว Surface 
3 ผิวส าหรับสร้าง Face Blend  

 

        
 
 

 Inferred Curve Selection  
 NX7.5 ไดมี้การเพ่ิม Inferred Curve Selection ในส่วนของSelection Intent เพ่ือ ช่วยในการเลือก
เสน้ Curve แบบต่อเน่ืองในกลุ่มของเส้น Curve ท่ีมีการซบัซ้อน เม่ือท าการเลือกเส้นเร่ิมและเคล่ือนเมาส์ 
Cursor ไปไวท่ี้จุดปลาย  ซอฟแวร์จะแสดงแนวเส้นท่ีเช่ือมระหว่างจุดเร่ิมต้นและจุดปลายโดยอตัโนมติั  และ 
นอกจากนั้นยงัมีออบชั่นเพ่ือแกไ้ขการเลือกเพ่ือไดแ้นวเสน้ท่ีต้องการ 
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 Radius Reduction in Global Shaping 

สามารถใชค้ าสัง่ Radius Reduction ในหนา้ต่างของของค าสัง่ Global Shaping by Function เพ่ือลด
ขนาดรัศมีของของผิว free form blend บนช้ินงาน Sheet metal 
 

 
 

 Concave Faces 
 ออบชัน่ Concave Faces ใชแ้สดงผิวเวา้บนช้ินงานท่ีอยู่ในช่วงค่าท่ีก  าหนด โดยผิวเวา้ท่ีแสดงอา้งอิง
กบัทิศทางของ Draw Direction (Analysis ->Shape -> Concave Faces ) 
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 Patch Openings enhancements 

 ในส่วน Type ของค าสัง่ Patch Opening ไดมี้การเพ่ิมออบชัน่  Notch และ  Joggle ซ่ึง
สามารถสร้างผิวของ Notch และ Joggle   

 

 
 

Body Type option for Freeform commands 
 ไดมี้การเพ่ิมออบชัน่ Body Type เพ่ือก  าหนดว่าจะสร้าง Solid Body หรือ Sheet body ในส่วนของ
ค าสัง่ต่อไปน้ี   
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-  Ruled 
-  Swept 
-  Through Curves 
-  Through Curve Mesh 

 -  Studio Surface 
 

 
 
 
 
 
 
Assemblies 
 
Assembly constraint enhancements 
NX7.5 ไดมี้การเพ่ิมความสามารถให้ Assembly constraint ดงัต่อไปน้ี 

1. Show Degrees of Freedom ผูใ้ชง้านสามารถแสดง Show Degrees of Freedom ของช้ิน
ส่วนยอ่ย (Component)ท่ีถูกเลือก โดยจะแสดงรูป ลูกศรของ Degrees of Freedom ในหนา้ต่าง Graphics 
Area และ แสดงจ านวน Rotational และ Translation ท่ีเป็นอิสระ(Freedom)  ในส่วนของ Status line 
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 ( Assemblies→Component Position→Show Degrees of Freedom  ) 

 
 

2. สามารถใชค้ าสัง่ From Instance Feature โดยอา้งอิงกบัขอบของช้ินงาน ซ่ึงในเวอร์ชัน่กอ่น
หนา้น้ีจะอา้งกบัผิวของช้ินงานเท่านั้น 

 
 
 
 
Delay update of Assembly Constraint 
 ผูใ้ชง้านสามารถใช ้Delay Assembly Constraint ในการหยดุการ Update ค่า constrain จนกว่า
ผูใ้ชง้านจะตอ้งการ   เหมาะส าหรับการเปล่ียนค่า Constraint หลายค่าใน Assembly ขนาดใหญ่ 
( Tools→Update→Interpart Update→Delay Assembly Constraints ) 



50 
www.dtm-thailand.com 

 
 

Lightweight loading 
 ผูใ้ชง้านสามารถใชง้านสามารถก  าหนด Load option เป็นแบบ Lightweight loading 
 แทนการโหลดขอ้มูลทั้งหมด ซ่ึงจะช่วยลด Memory ท่ีตอ้งใช้ ,เพ่ิมประสิทธิภาพในการแสดงช้ินงาน 
เหมาะส าหรับ Assembly ขนาดใหญ่  (File→Options→Assembly Load Options,Scope group→Use 
Lightweight Representations) 

 
 
 
 
 
 
Design in context: Wave linking with modeling commands 
 เม่ือเปิดใช้ออบชั่น Create Interpart Link  ใน selection bar และ เปิดออบชัน่ใน 

File→Utilities→Customer Defaults →Assemblies →General→Interpart Modeling tab→Allow 
Associative Interpart Modeling ผูใ้ชง้านสามารถสามารถเลือก Geometry ของ ช้ินส่วนย่อย (Component) 
ส าหรับค าสัง่ใน  modeling โดยซอฟแวร์จะสร้าง Wave Likes ให้อตัโนมติั  
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Mirror Assembly enhancements 
 ในเวอร์ชัน่กอ่น NX 7.5 จะตอ้งใช ้Datum CSYS ในการอา้งอิงของค าสัง่ Mirror Assembly ในเวอร์
ชัน่ NX 7.5 ผูใ้ชง้านสามารถก  าหนด Datum Plan ในการอา้งอิงของค าสัง่ Mirror Assembly 

 
Display setting in context 
 ในเวอร์ชัน่กอ่น NX 7.5 เม่ือผูใ้ชง้านเปล่ียนค่าของ Layer และ ค่าของ Display properties  ของช้ิน
ส่วนยอ่ย (Component)ในระดบั Assembly,  ซ่ึงค่าของ Layer และ ค่าของ Display properties  ไม่ปรากฏใน 
ช้ินส่วนย่อย (Component) ซ่ึงท าให้ผูใ้ชง้านเกดิความสบัสน  ในเวอร์ชัน่ NX 7.5 มีค าสั่งท่ีช่วยให้ค่า ของ 
Layer และ ค่าของ Display properties ของช้ินส่วนยอ่ย (Component) เปล่ียนตามค่าในระดบั Assembly 

1. Apply 'Move to Layer' to Owning Parts (Format→Layer Settings) 
2. Apply Changes to Owning Parts (Edit→Object Display) 

 
 
 
 
 
 
 
Shape Studio 
 

 Surface Intersection Analysis 
 ค าสัง่ Surface Intersection Analysis ใช้ในการสร้าง Surface Intersection Analysis object (SIAO) 
ใชใ้นการวิเคราห์การตดักนัระหว่างผิวของ Surface และความต่อเน่ืองระหว่างผิว Surface โดยสามารถ
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แสดงในรูปของ Curve comb (Analyze Shape → Surface Intersection) 
 

 
 

 นอกจากนั้นยงัสามารถเปล่ียนลกัษณะการแสดง Surface Intersection Analysis object (SIAO)  ได้
จาก Edit→Object Display→Analysis tab 
 

 
 
 
 
 

 Text –expression support 
 สามารถท าการอา้งอิงค่า Curve Text กบัค่า Expression  เม่ือค่าของ Expression เปล่ียน ตัวอกัษรท่ี
เป็น Curve Text จะเปล่ียนตาม (Insert→Curve→Text) 
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 Edit Object Display – JT Point Display 
 สามารถใชค้ าสัง่ Edit Object Display ในการเปล่ียนลกัษณะการแสดงของช้ินงานท่ีเป็น JT Facet 

 
Transform and align geometric objects 
 สามารถใชค้ าสัง่ Align ในการยา้ยและวางแนว  กบั Geometry ต่างๆ ซ่ึงในเวอร์ชัน่กอ่นหนา้
สามารถใชง้านได้กบัช้ินงานท่ีเป็น Facet เท่านั้น (Edit→ Align→ Point Set to Point Set ,Multi-Patch 
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,Best Fit ) 

 
 

 Aesthetic Face Blend 
 เป็นค าสัง่ท่ีสร้างผิวฺBlendแบบสวยงามและยงัสามารถคงค่าก  าหนดทางดา้นวิศวกรรมไว ้ โดย
สามารถก  าหนดค่า รัศมี(Radius), Chord Length และค่าความต่อเน่ืองแบบ G1,G2  
(Insert→ Detail Feature→Aesthetic Face Blend) 
 

 
 

 Transition control setting for Studio Surface  
 เม่ือท าการเลือกการ Alignment เป็นแบบ By Point ในค าสัง่ Studio Surface ผูใ้ชง้านสามารถ
ก  าหนดค่า Constraint เป็น No Constraint 
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I-Form 
 เป็นค าสัง่ในการแกไ้ขแบบ Dynamic โดยท าการเพ่ิมหรือแกไ้ข iso-parametric curve โดยสามารถ
ใชก้บัผิวท่ีเป็นฺB-Surface และไม่เป็น B-Surface 

 

 
 
 
 

 
 X-Form enhancements 

 NX7.5 ไดมี้การเพ่ิมความสามารถให้กบัค าสัง่ X-Form โดยผูใ้ชง้านสามารถแกไ้ขผิวท่ีเป็นฺ B-
Surface และไม่เป็น B-Surface และ เพ่ิมออบชัน่ Use Face Finder ช่วยในการเลือกผิว  
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   Match Edge enhancements 
 NX7.5 ไดมี้การเพ่ิมความสามารถให้กบัค าสัง่ Match Edge โดยผูใ้ชง้านสามารถแกไ้ขผิวท่ีเป็นฺB-
Surface และไม่เป็น B-Surface และ เพ่ิมออบชัน่ Use Face Finder ช่วยในการเลือกผิว  

 
 Improved control of shape in N-side Surface 

NX7.5 ไดมี้การเพ่ิมความสามารถให้กบัค าสัง่ N-side Surface โดยผูใ้ชง้านสามารถใชง้าน Center 
Flat Slider ในหนา้ต่าง N-side Surface ซ่ึงในเวอร์ชัน่กอ่นหนา้น้ีไม่สามารใชก้บัผิว surface ท่ีถูก Trim หรือ 
เม่ือก  าหนดค่า UV Orientation เป็นแบบ Area 

 
 
 

Manufacturing 

1. Operation navigator  

เพ่ิม Columns ในการแสดงขอ้มูลการท างาน ไดแ้ก  ่

- Depth of cut  
- Feed 
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- Speed 
- Stock 
- Step over  
- Holder Description  
- MCS  

 

2. Freeze and Unfreeze  
ค าสัง่ช่วยให้แถบของ Name อยู่กบัท่ีในขณะเล่ือนแถบ เพ่ือดู Column ถดัไป 

 

3. Unapproved  

ค าสัง่ช่วยลบการ Approve ออกจาก Tool Path  
 

4. Copy program, methods, and geometry  

สามารถ Copy Program, Methods และ Geometry ไปยงัช้ินงานอ่ืนได ้โดยมีขอ้ก  าหนดดังน้ี 

- ถา้ Copy ในกลุ่มของ Geometry หรือ Program ชุด Operation จะถูก Copy ไปดว้ย 
- ถา้ Copy ในกลุ่มของ Method หรือ Tool ชุด Operation จะไม่ถูก Copy ไปดว้ย 

สามารถเรียกใชค้ าสัง่ Freeze column / Unfreeze column ไดโ้ดยการคลิกขวาบนแถบ column และท าการ

เลือก Freeze column / Unfreeze column  

นอกจากนั้นยงัสามารถเรียกใชค้ าสัง่ Unapprove ไดโ้ดยการคลิกขวาบน operation ท่ีมีการ approve และ

ท าการเลือก object → Unapprove 

 

5. Operation navigator time and length display  
สามารถปรับตั้งค่า ระยะเวลาในการเปล่ียน Tool และความเร็วในการเดินในขณะไม่มีการตดัเฉือน

ช้ินงาน เพ่ือให้ตรงกบัเคร่ืองแต่ละเคร่ืองท่ีใชง้าน และเพ่ือให้ไดร้ะยะเวลาการท างานท่ีแน่นอน 
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สามารถเรียกใชค้ าสัง่ Time Estimates ได้ 3 วิธีดงัน้ี 

1. ใน operation navigator ในหนา้ต่างของ machine tool view ท าการ double-click ท่ี generic 

machine  

2. เปล่ียนขอ้มูลของ Tool change และ rapid feed ในส่วนของ time estimates ตามเคร่ืองจกัร 

3. คลิก update operation navigator เพ่ือปรับระยะเวลาการท างานใหม่ 
 

6. Geometry selection – face and curve rules  
เพ่ิมลกัษณะการเลือกผิวและเสน้ โดยเพ่ิมการใช ้rules ซ่ึงจะแสดงอยูบ่น selection bar 

 

 

7. Specify planes  
ปัจจุบนั NX ใชก้ารก  าหนด Plane ในการก  าหนด clearance plane หรือ lower limit plane, floor 

planeและ boundary plane ซ่ึงในส่วนของงาน assembly สามารถก  าหนดไดโ้ดย 
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1. ในการเลือก component สามารถตั้งค่า selection scope บน selection bar เป็น entire assembly 
หรือ within work part and components 

2. หลงัจากเลือกวตัถุแลว้ท าการ drag หรือใส่ค่า offset 

 

3. Plane จะแสดงข้ึนบน graphics window จนกระทัง่มีการแกไ้ข 

 

 

8. Cut Angle and Level Angle 

ปรับปรุงการให้ขนาดองศาการตดังานระบุเป็น cut angle ในงาน milling และ level angle ในงาน 

turning โดยมีขอ้ก  าหนดดงัน้ี 

1. มุมจะ associative กบั geometry เม่ือท าการก  าหนด 
2. สามารถหมุนมุมไดอ้ยา่งอิสระโดยไม่ต้องค านึงถึง WCS ในกรณีท่ีท าการหมุนในแนว 3D 

โปรแกรมจะท าการวางให้ตามแนว Tool 
3. ส าหรับการใช้ specify ใน graphics window จะแสดง angle direction และ value 
4. สามารถก  าหนดมุมไดจ้ากการ dragging หรือใส่ค่าตามตอ้งการ 
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สามารถเรียกใชค้ าสัง่ Cut Angle and Level Angle ได้ ดงัน้ี 

- (Milling operation) dialog box → Path setting group → cutting parameters        → 
Strategy tap→ cutting group 

- (Turning operation) dialog box → Path setting group  

 

9. Tool Axis – Interpolate Vector  
สามารถท าการยา้ยทิศทางไดแ้บบ dynamic เพ่ิม list ใน dialog box มี labels ระหว่างการก  าหนด 

vector และสามารถท าการเพ่ิม แกไ้ข หรือลบ vector ไดจ้ากใน list 

 

สามารถเรียกใชค้ าสัง่ Tool Axis – Interpolate Vector ไดโ้ดย  

 (Multi – axis Milling operation) dialog box → Tool Axis group  
 

10.  Customize dialog boxes  

มีการวางรูปแบบ dialog box ใหม่ จดัเกบ็เป็นหมวดหมู่ ง่ายต่อการเพ่ิม หรือลบ 
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สามารถเรียกใชค้ าสัง่ Customize dialog boxes ไดโ้ดย 

1. คลิกขวาบน operation เลือก object → customize 

2. เปิด operation เลือก option → customize dialog 

ขั้นตอนการ Add an item to a dialog box 

1. ใน operation navigator คลิกขวาท่ี operation เลือก object – customize 

2. ใน customize dialog ในส่วนของ item used เลือกหนา้ต่างท่ีตอ้งการวาง item 
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3. ใน item to add เลือก customizable item  

4. จาก item list เลือก item ท่ีตอ้งการเพ่ิม 

5. เลือก add to dialog 

6. คลิกลูกศรเล่ือนข้ึนลง 

7. จดัวางต าแหน่งท่ีตอ้งการ 

8. เลือก OK 

 

 

 

 

 

 

 

 

 

11. Update customization  

ปรับปรุง dialog box เพ่ิม select all และ workflow 
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สามารถเรียกใชค้ าสัง่ Update customization ไดโ้ดย 

คลิกขวาบน Operation เลือก Object → Customize From      
 

12. NC Assistant overview  

ปรับปรุงเปล่ียนแปลงรูปร่าง dialog box ใหม่ เพ่ือง่ายต่อการใชง้าน       

      

 

 

 

 

 

สามารถเรียกใชค้ าสัง่ NC Assistant overview ไดโ้ดย 

Analysis →NC Assistant 

Geometry →NC Assistant 
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13. Tool Path Editor  
เพ่ิมความสามารถต่างๆดงัน้ี 

1. เพ่ิมความสามารถในการแกไ้ข Feed rates   

2. เพ่ิม dynamically ในส่วนของการ Move tool path  

 

3. สามารถ Undo ได ้โดยการใชคี้ร์บรอด กด ctrl + z 
4. Run gouge check ในส่วนของ Tool path editor 
5. เพ่ิมความสามารถในส่วนของ Fast forward 

สามารถเรียกใชค้ าสัง่ Tool Path Editor ไดโ้ดย 

คลิกขวาบน Operation เลือก Tool Path → Edit 

 

14. Tool update  

แกไ้ข update tool library เพ่ือให้เหมาะสมกบั version สามารถเรียกใชค้ าสัง่ Tool update ไดโ้ดย 

คลิกขวาบน Tool เลือก Object → Update Tool from Library  

 

15. Operation actions  
จดัวางค าสัง่ Generate, verify, replay และ list ของ operations tool bar ไวบ้น radial toolbar 

ดว้ย 
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สามารถเรียกใชค้ าสัง่ Generate, verify, replay และ list ไดโ้ดย 

เลือก Operation กด Ctrl + shift พร้อมกบักดเมาส์ปุ่มซา้ย แลว้เล่ือนไปยงัค าสัง่ท่ีต้องการ 

 

 

 

 

 

 

 

 

 

Milling 

1. Turbo machinery Multi Blade milling  
ชุดโปรแกรมในการท างาน Blade milling ซ่ึงออกแบบส าหรับงาน blade โดยเฉพาะ โดย

สามารถสร้างโปรแกรม roughing, rest milling hub finishing and blade and splitter finishing  
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Operation ท่ี support ใน multi blade milling 

- Tool axis smoothing 

- Tool path smoothing 

- In Process Workpiece 

- Holder Collision checking and avoidance 

- A preview of expected results 

ขั้นตอนการท างานของ Multi blade  

1. เลือก setup เขา้สู่ mill_multi_blade 

2. สร้าง tool ชนิด ball mill 

3. ใน Geometry view แกไ้ข workpiece ใส่ค่าตามท่ี workpiece ตอ้งการ 

3.1 Part 

3.2 (Optional) Blank 

3.3 (Optional) Check 

4. ระบุ  MULTI_BLADE_GEOM ตามขั้นตอนระบุแนวแกนการหมุน 
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4.1 ระบุช้ินงานตามโปรแกรมต้องการ 

- Hub 

- Shroud 

- Blade 

- Blade Blend  

- (Optional) Specify Splitters 

4.2 ระบุจ านวนของ Blades 

 

 

 

 

 

 

 

2. Multi Blade Rough operation  
ใชส้ าหรับสร้างโปรแกรมกดัหยาบ ซ่ึงสามารถก  าหนดค่าต่างๆไดแ้ก ่

- Multi-level cutting 

- Cut patterns 

- Depths 

- Start point and cut direction 

- Tool axis lead/lag and tilt 

- Tool path and tool axis smoothing 

- Blank geometry or IPW for stock definition 
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3. Multi Blade Rest milling operation  
ใชส้ าหรับสร้างโปรแกรมกดัก ึง่ละเอียด โดยใช้ 3D IPW อา้งอิงเน้ืองานท่ีเหลือจากโปรแกรมท่ี

ผ่านมา ซ่ึงสามารถก  าหนดค่าต่างๆไดแ้ก ่

- Blank geometry  

- 3D IPW geometry from previous operation 

- Multi level cutting 

- Multi axis cutting 

- Start point option 

- Tool axis lead/lag and tilt option 

4. Multi Blade Hub Finish operation 

สร้าง Tool path ส าหรับงานละเอียดของ multi blade hub ซ่ึงสามารถก  าหนดค่าต่างๆไดแ้ก ่

- Multi-axis cutting 

- Multiple cut patterns 

- Tool Path smoothing 

- Start point option 

- Tool axis lead/lag and tilt option 
 

5. Multi Blade Finish operation  

สร้าง Tool path ส าหรับงานละเอียดของ multi blade ซ่ึงสามารถก  าหนดค่าต่างๆไดแ้ก ่
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- Multi-axis cutting 

- Multiple cut patterns 

- Tool Path smoothing 

- Start point option 

- Tool axis lead/lag and tilt option 

 

 

 

 

 

 

 

 

6. Optimize Feed Rate  

ช่วยเพ่ิมประสิทธิภาพในการกดังาน และยดือายกุารใชง้านของเคร่ืองมือตดั โดยการรักษา load 
ในการกดังาน ดว้ยการปรับ feed ของการกดังาน โดยใช้เน้ืองานท่ีเหลือ หรือ 3D IPW มาใชใ้นการ
ค านวณ  
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สามารถเรียกใชค้ าสัง่ Optimize Feed Rate ไดโ้ดย 

1. (Milling Operation) dialog box  → Feeds and Speeds          → Feed Rates group → 
Optimize Feed Rate When Generating 

2. คลิกขวาท่ี operation เลือก object → Feed Rate → Optimize Feed Rate When 
Generating         

 

7. Cut steep and non-steep areas with Flowcut  

สามารถระบุให้รูปแบบในการกดัแตกต่างกนั ระหว่างพ้ืนท่ีท่ีมีระดบัความชนัของผิวแตกต่างกนั 

  
 สามารถเรียกใชค้ าสัง่ Cut steep and non-steep areas with Flowcut ไดโ้ดย 

Flow Cut operation dialog box→Drive Method group→Edit          →Non-steep cutting 
group/Steep Cutting group  
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8. Crosscut patterns in Flowcut operation  
รูปแบบการกดัแบบใหม่ใน flowcut โดยกดัตามแนวขวางของแนว tool path รูปแบบเกา่ ซ่ึง

สามารถท าการเลือกแบบแบ่งตามความชนัของผิว หรือเลือกแบบทั้งหมดบนช้ินงาน ซ่ึงประกอบดว้ย
ลกัษณะ Tool Path  

- Crosscut Zig 

- Crosscut Zig Zag 

- Crosscut Zig Zag with Lifts 

 
สามารถเรียกใชค้ าสัง่ Crosscut patterns in Flowcut operation ไดโ้ดย 

Flowcut operation dialog box→Drive Method group→Edit  →Non-steep Cutting group 
/Steep Cutting group  

 

9. Clearance options in Milling operation  

เพ่ิมรูปแบบ Clearance ใน Surface Contouring, Planar Milling, Cavity Milling, Face Milling, 
and Zlevel Milling operations. ไดแ้ก ่
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สามารถเรียกใชค้ าสัง่ Clearance options in Milling operation ไดโ้ดย 

[Milling operation] dialog box →Geometry list→MCS→Create New    →New 

Geometry dialog box→Geometry Subtype group→MCS   →MCS dialog box→Clearance 
group→Clearance Option list  

คลิกขวาท่ี operation→Edit→Mill Orient dialog box→Clearance group→Clearance 
Option list  
 

10. Profile 3D and Solid Profile 3D Tool Path Smoothing  
สามารถก  าหนด tool path ให้ Z Axis Smoothing ได ้ดว้ยการท า Radial โดยอา้งอิงการท า 

smoothing ดว้ยองศาในส่วนของ smooth parameters 

 



73 
www.dtm-thailand.com 

สามารถเรียกใชค้ าสัง่ Profile 3D and Solid Profile 3D Tool Path Smoothing ไดโ้ดย 

Cutting Parameters→Corners, Smoothing group 

 

11. Tool Holder Gouge and Collision Check  

ในส่วนของ Gouge Check เพ่ิมออปชัน่ ช่วยการท างานของ Gouge and Collision Check ดงัน้ี 

- หยดุเม่ือ Tool ไม่สามารถลงไปได ้หรือท าการลบ tool path ท่ีลงไม่ไดอ้อก 

- ก  าหนดจ านวนท่ี gouges ถดัไป กอ่นท าการหยดุ tool pate  

สามารถเรียกใชค้ าสัง่ Tool Holder Gouge and Collision Check ไดโ้ดย 

- คลิกขวาท่ี operation→Tool Path→Gouge Check 

- Operation toolbar→Gouge Check  
 

12. Cut Levels for Cavity Milling/Z-Level Milling  

ท าการออกแบบ dialog box ของ Cut Levels ใหม่ เพ่ือให้ท างานง่ายข้ึน โดยใช ้datum planes เป็น
เคร่ืองมือช่วยในการก  าหนดความลึก 

12.1 Cut range ท่ีท างานอยูจ่ะแสดงเป็น Plane สามารถท่ีจะท าการ drag เพ่ือท าการแกไ้ข

ระดบัชั้นไดท้นัที 

 

 
 

12.2 ระหว่างชั้นจะแสดงอยูใ่น list 

 
 

12.3 สามารถเลือกผิวเพ่ือก  าหนดชั้น และเม่ือท าการเลือกชั้นท่ีเราเลือกผิวไว ้โปรแกรมจะแสดง

ผิวท่ีเลือกไวด้ว้ย สามารถเลือกจุดเพ่ือก  าหนดชั้นได้ 
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12.4 สามารถเคล่ือนยา้ย cut level and range ไปยงัจะท่ีสามารถเห็นไดดี้ท่ีสุด 

 

 

 

 

12.5 สามารถก  าหนดค่าความลึกท่ีเกนิลงไป โดยใชค่้าความลึก หรือคิดเป็นเปอร์เซ็นต์ Tool 
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12.6 สามารถเร่ิม ZC จาก top level ได ้ในส่วนของ range depth เป็น top level   

 

สามารถเรียกใชค้ าสัง่ Cut Levels for Cavity Milling/Z-Level Milling ไดโ้ดย 

Cavity Milling or Z-Level Milling dialog box→Path Settings group  
 

13. Cut Levels – Planar Milling  

ปรับปรุง dialog box ใน cut levels ของ Planar Milling 

 

สามารถเรียกใชค้ าสัง่ Cut Levels for Cut Levels – Planar Milling ไดโ้ดย 

Path Settings group→Cut Levels  
 

 


