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Manufacturing General 
 
Tool library enhancements 

คา่พารามเิตอร์ใน NX ASCII Tool library ได้มีการเปลีย่นแปลง ให้สอดคล้องกบั dialog box ใน
การสร้อง Tool 

คา่พารามเิตอร์ที่เพิม่ใหม ่ใน ASCII tool library ได้แก่ 

 Milling tool shank 
 Coolant through on mills/drills 
 Tip angle on mills 
 Flute length on user defined mills 
 Corner radius on holemaking tools 
 Bell angle and diameter on center drills 
 Neck diameter and taper angle on taps and reamers 
 Boring bar parameters 
 Probe tracking points 
 Turning parametric holder 
 Boring Diameter, Maximum Reach, and Maximum Depth on Turning tools 
 X Mount, Y Mount, and Z Mount 
 Milling chamfer 

รูปแบบที่เพิ่มใหม ่ใน ASCII tool library ได้แก ่

 Chamfer Mills 
 Spherical Mills 
 Spot facing tools 

สามารถก าหนดคา่พารามิเตอร์การเข้างาน (Engage) ในสว่นของ Non Cutting Moves ที่สามารถ
สร้างเก็บไว้ใน Tool งานกดัได้ดงันี ้

 Ramp Angle 
 Diameter (helical) 
 Minimum Ramp Length 
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สามารถก าหนดคา่พารามิเตอร์การกดั (ในการใช้งาน plunge milling) ที่สามารถสร้างเก็บไว้ใน Tool 
งานกดัได้ดงันี ้

 Max Cut Width 
ประเภทและพารามเิตอร์ของ Tool สามารถจดัเก็บไปยงั Tool library สามารถเรียกออกมาใช้งานได้โดย 

 ค้นหา Tool ที่ต้องการ โดยใช้ description 
 Export tool ไปจดัเก็บโดยไมก่ าหนด holding 
 ก าหนดโดยการก าหนดเลขตอ่ท้ายด้วย libref เมื่อ exporting หรือ importing tool หรือ holder ผู้ใช้

สามารถใช้ customer default เพื่อเร่ิมตวัเลขตอ่ท้ายตามทีต้่องการ 

 *หมายเหต ุถ้าต้องการเปลีย่นแปลง ASCII libraries สามารถเปลีย่นแปลงได้ที่ tool_database.dat ซึง่เรา
สามารถก าหนดรูปแบบขึน้มาใหมเ่องได้ 

เมื่อท าการดงึ Tool ออกมาใช้ ผู้ใช้สามารถก าหนดรูปแบบบน Tool master ใน library_dialog.prt 
และท าการแก้ไขข้อมลูไปยงั Tool ได้ 

ท ำไมถงึควรใช้ 

การปรับปรุงชว่ยให้สามารถจดัเก็บได้ดีและสมบรูณ์ขึน้ 

Customer default จะชว่ยป้องกนัไมใ่ห้ตวัเลขใน libref ท าการเขยีนขึน้ทบัของเดิม เมื่อสามารถสร้าง
ตวัเลขใน libref ขึน้ใหมไ่ด้  

สำมำรถเรียกค ำสั่งได้ที่   

ASCII Tool library 

Application Manufacturing 

Menu Insert→Tool  

Location in 
dialog box 

Library group→Retrieve Tool from Library →Library Class 
Selection→Search Criteria dialog box→Search Parameters 
group→Description 
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การใสค่า่ Starting Number ส าหรับ Librefs ใน customer default 

Application Manufacturing 

Menu File→Utilities→Customer Defaults 

Location in dialog box Manufacturing→Tools→Tool Library group 

 
Shop Documentation enhancements 
 

 
สามารถใช้ Templates ได้สองรูปแบบคือ 

 HTML templates. โดย Templates สามารถปรับแตง่ได้ใน Excel. 
 TEXT templates. โดย Templates สามารถปรับแตง่ได้ใน TCL. 

ในการสร้าง Shop Documentation ล าดบัแรกต้องเลอืก object ใน Operation Navigator ซึง่ทัง้สองรู
แบบจะต้องท าการเลอืก object ใน Operation Navigator เช่นกนั 

 *หมายเหต ุPre-NX 8 templates จะไมแ่สดงใน NX เพราะสามารถใช้ default templates ในการสร้าง report 
machining operations จากหน้าตา่งทัง้สีข่อง Operation Navigator   

Pre-NX 8 templates จะท าการสร้าง reports เพียงแค ่view เดียว ถ้าต้องการใช้ pre NX 8 templates 
รูปแบบอื่นให้ท าการลบเคร่ืองหมาย (#) ใน shop_doc.dat file . ซึง่อยูใ่น MACH\resource\shop_doc. 

เมื่อเลอืกใช้ Excel-html template ในไดอลอกบอกซ์ของ Shop Documentation จะสร้างเอกสาร
ออกมาในรูปของ Microsoft Excel™ หรือ web browsers 

ไฟล์ Excel ที่ใช้ในการสร้าง Excel-html templates อยูท่ี่ folder 
MACH/resource/shop_doc/excel_templates สามารถก าหนดรูปแบบ templates ใหมไ่ด้ตามรูปแบบท่ี
ต้องการตามการผลติ แตล่ะไฟล์ Excel จะมีเอกสารสองแผน่ โดยแผน่ท่ีสองจะเป็นข้อมลูและตวัแปรเก่ียวกบั 
MOM ที่สามารถคดัลอกมาวางใน cells ที่เหมาะสมของแผน่แรกได้ ซึง่จะช่วยให้สามารถแก้ไข templates ได้
เอง แม้วา่ไมคุ่้นเคยกบัการใช้งาน MOM  
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ท ำไมถงึควรใช้ 
สามารถปรับปรุง Template และข้อมลู เพื่อใช้ในการควบคมุ Shop Documentation ตามความ

ต้องการของแตล่ะผู้ใช้งานได้ 
 
สำมำรถเรียกค ำสั่งได้ที่ 
 

Application Manufacturing 

Toolbar Operations toolbar 

Location in dialog box Shop Documentation dialog box→Report Format list 

 
 
CAM Express Startup  

สามารถเปิด CAM Express จากเมน ูStart บนเคร่ืองคอมพิวเตอร์ ซึง่เป็น Product ที่แยกออกมาจาก 
NX 

ท ำไมถงึควรใช้ 
เปิดใช้ CAM Express โดยเป็น Product ที่แยกออกมาจาก NX อยา่งชดัเจน 

 
สำมำรถเรียกค ำสั่งได้ที่ 
 

Application Manufacturing 

Menu Start→All Programs→Siemens NX 8.0→Manufacturing→CAM Express 8 
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Transferring an IPW across multiple setups  

สามารถถ่ายโอน IPW จากต าแหนง่หนึง่ไปยงัอกีต าแหนง่หนึง่ โดยที่จดัวางต าแหนง่ IPW ให้อตัโนมตั ิ

 

สามารถสร้างความสมัพนัธ์ระหวา่งสองต าแหนง่ ส าหรับการถ่ายโอน IPW โดย IPW จะถกูถา่ยโอน
จากต าแหนง่ชิน้งานหนึง่ ไปยงัต าแหนง่ของชิน้งานท่ีสอง และมคีวามสมัพนัธ์เช่ือมโยงกนั เราสามารถดู
ความสมัพนัธ์ได้ในไดอลอกบอกซ์ของ Blank Geometry  

ท ำไมถงึควรใช้ 
เพื่อถ่ายโอน IPW จาก setup หนึง่ ไปยงั setup ถดัไป เมื่อชิน้งานไมส่ามารถท าการ machine จนเสร็จ

ใน step การท างานเดยีว และต้องการย้ายไปยงัต าแหนง่ถดัไป หรือการ refixture IPW 

สำมำรถเรียกค ำสั่งได้ที่ 

Application Manufacturing 

Prerequisite 
การเลอืกชิน้งานเข้าไปยงั geometry ถ้าเป็นงาน assembly จะต้องอยูใ่น component 
เดียวกนั 

Location in dialog 
box WORKPIECE group→Blank Geometry→IPW→Select Source for IPW 
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Geometry selection in Manufacturing 

สามารถเลอืกผิวและชิน้งานใน Manufacturing ได้เช่นเดยีวกบัใน Modeling โดยเป็นการเลอืก
ความสมัพนัธ์ของ geometry นอกเหนือจากการเลอืกแบบขอบเขต ซึง่สามารถท าได้ดงันี ้

 ใช้ Selection filters บนแถบ Selection bar ในการเลอืก face และ body และใช้ Selection 

Intent rules  ในการเลอืกวตัถหุลายๆชิน้ 

 

 ในกรณีต้องการเลอืกชิน้งานกลุม่ใหมท่ี่แตกตอ่งออกไป ก็คลกิเลอืก Add New Set  ใน 
selection dialog box ส าหรับงาน CAM faces และ bodies. 

 ก าหนดข้อมลูการเลอืกผิวโดยใช้ rule. 
 ตรวจสอบการเลอืก โดยคลกิเลอืกใน List ได้เช่นเดียวกบัการใช้งานใน modeling. 

 

*หมายเหต ุเมื่อทดลองเลอืก โดยใช้ selection intent ในต าแหนง่ที่คาดวา่งานออกแบบจะมีการเปลีย่นแปลง 
เมื่อมกีารเปลีย่นแปลงการออกแบบ selection intent จะท าการแก้ไขการท างาน โดยเพิ่มหรือลบผิว
ออก 
ตวัอยา่งเช่น ถ้าระบกุารเลอืกเป็น Tangent Faces จะท าการเลอืกผิวทัง้หมดที่ตอ่เนื่องกนัด้วยการ 
blended และหลงัจากนัน้เมื่อเราท าการเพิม่การ blended ในต าแหนง่ที่ตอ่เนื่องกนั ผิวของการ 
blended และผิวที่ตอ่เนื่องออกมา จะถกูเพิ่มเข้าไปในการเลอืก โดยปกตใินสถานการณ์เช่นนี ้ใน
การเลอืกใช้ rule ควรเลอืกใช้ให้เหมาะสมกบัการท างานท่ีต้องการ เช่น Feature Faces, Region 
Faces, และอื่นๆ โดยสามารถเลอืกแตล่ะผิว เช่นเดยีวกบัเวอร์ชัน่ก่อน    
 

ตวัอยา่งตอ่ไป แสดงให้เห็นถึงความแตกตา่ง ของการใสค่า่ stock ของ work piece ในแตล่ะผิว 

Set Number of Items Custom Data 

1 8 Yes 

2 9 No 

3 1 Yes 
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Set 1 มีการใสค่า่ใน custom data. ในหน้าตา่งของ
Part Offset มีคา่ที่ใสไ่ว้เทา่กบั 1.0 mm. 
Face Rule ตัง้คา่เป็น Tangent Faces สามารถเลอืก
ผิวงานได้โดยการคลกิเพยีงครัง้เดียว  

 

Set 2 มีคา่ stock ตามคา่ของ default  
Face Rule ตัง้คา่เป็น Tangent Faces สามารถเลอืก
ผิวงานด้านบนได้โดยการคลกิเพยีงครัง้เดยีว.  

 

Set 3 มีการใสค่า่ใน custom data. ในหน้าตา่งของ
Part Offset มีคา่ที่ใสไ่ว้เทา่กบั 2.0 mm. 
ส าหรับผิวด้านลา่งใช้ Face Rule ตัง้คา่เป็น Single 

Face โดย rule ชนิดนี ้สามารถเลอืกผิวได้หลายผิวได้
ด้วยการคลกิเลอืกหนึง่ผิวตอ่หนึง่ครัง้  

การปรับปรุงคา่เร่ิมต้นของชิน้งาน 

 เมื่อเร่ิมต้นเปิดชิน้งาน ชิน้งานทัง้หมดจะมีข้อมลู stock เหมือนกนั โดยถกูจดักลุม่เป็นชดุเดียวกนั 
 ข้อมลูที่ก าหนดเองจากการ gouging จะไมไ่ด้รับการรองรับ  

ท ำไมถงึควรใช้ 
ใช้การเลอืกแบบ rules ในการช่วยลดจ านวนการคลกิ เมื่อต้องการเลอืกผิวและวตัถ ุ 

เมื่อท าการแก้ไข geometry จะสง่ผลให้ rule ท าการเปลีย่นแปลงการเลอืกผิวและชิน้งาน ให้ตรงกบั rule โดย
อตัโนมตั ิ
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ตวัอยา่งตอ่ไป เป็นการแสดงการแก้ไขผิวด้านบนของชิน้งาน เนื่องจากการเลอืก rule ของ set 2 เป็น
แบบ Tangent faces ผิวที่เลอืกจึงเพิม่เข้ามาอตัโนมตัิ ผิวใหมท่ีเ่พิ่มขึน้มีคา่ของ part offset เช่นเดียวกบัใน set  

 

Set Number of Items Custom Data 

1 8 Yes 

2 9 No 

3 1 Yes 
 

Set Number of Items Custom Data 

1 8 Yes 

2 17 No 

3 1 Yes 
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Dynamic machine tool positioning  

สามารถก าหนดต าแหนง่ tool ของเคร่ืองจกัร เป็นแบบ dynamically ในการท างานในสว่น 
Manufacturing เมื่อใช้รูปแบบเป็น CSYS tool โดย 

 ก าหนดแนวแกน tool ในการกดัแบบ  fixed-axis หรือ variable-axis operation. 
 การแก้ไขเคร่ืองมือตดั(Tool) ของ milling, drilling, หรือ probing  

 *หมายเหต ุมีคา่ customer default อยู ่2 คา่ที่ใช้ในการควบคมุการแสดงของเคร่ืองจกัรในรูปแบบ dynamic 
 เมื่อเปิดใช้ dynamic Machine tool ใช้ส าหรับการก าหนด tool axis และ ปิดเพื่อแก้ไข tool   

ถ้าท าการเคลือ่นแนวแกน จนเลยต าแหนง่ที่สามารถท าได้ รูปภาพก็จะแสดงการเตือน 

 ชิน้สว่นของเคร่ืองจกัรมกีาร over-travel ก็จะมีการ highlight 
 เมื่อลากต าแหนง่จาก handle จนกระทัง่ over-travel ก็จะมกีาร highlight  

                      
Machine tool components are moved to match the tool axis      Graphic alerts for over-travel 

 
 
ท ำไมถงึควรใช้ 

ควรใช้การจ าลองการท างานของเคร่ืองจกัรแบบ dynamic เมื่อต้องการตรวจสอบข้อจ ากดัของ
เคร่ืองจกัร 
 
สำมำรถเรียกค ำสั่งได้ที่ 

Application Manufacturing 

Prerequisite ใน library ของเคร่ืองจกัร จะต้องมีการตดิตัง้ และก าหนดอยา่งถกูต้อง 
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Shank definition for milling and drilling tools 

เมื่อท าการสร้าง tool ในงาน milling และ drilling สามารถก าหนด shank ระหวา่งเคร่ืองมือตดักบัด้าม
จบัได้ ซึง่สามารถก าหนดคา่ได้ตามด้านลา่ง 

 

1. Shank Diameter 
2. Shank Length 
3. Shank Taper Length 

คา่ของมมุเอียงจะเปลีย่นแปลงตามคา่ของ Tool และขนาดเส้นผา่นศนูย์กลางของ shank ในการสร้าง 
shank จะถกูเก็บเข้าไปยงั tool library ด้วย 

 

ก่อนหน้านีจ้ะเห็น shank บน tool เช่น T Cutters ซึง่ตอนนีจ้ะเรียกวา่ Neck Diameter  

ท ำไมถงึควรใช้ 

สามารถก าหนดได้ดีมากขึน้ และสร้างเคร่ืองมือตดัที่ถกูต้องตามลกัษณะของเคร่ืองมือตดัจริง 

สำมำรถเรียกค ำสั่งได้ที่ 
 

Application Manufacturing 

Menu Insert→Tool 

Toolbar Insert→Create Tool  

Location in dialog box Tool Subtype group→Mill Tool Parameters dialog box→Shank tab 
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Taper definition for tool holder steps 

ได้มีการเพิ่มคา่เส้นผา่นศนูย์กลางด้านบนในการสร้าง holder ซึง่สามารถปรับแตง่ได้จากการตัง้คา่ของ 
Taper Angle และ Length หรือสามารถระบไุด้โดยตรงจากคา่ของ Upper Diameter  

ซึง่คา่ Diameter ก่อนหน้านีม้เีพยีงแตค่า่ Lower Diameter  

เมื่อต้องการก าหนดคา่ holder สามารถก าหนดคา่ได้ดงันี ้ 

 

 (L) Length 
 (OS) Tool Insertion Offset 
 (UD) Upper Diameter 
 (LD) Lower Diameter 
 (B) Taper Angle 
 (R1) Corner Radius 
 (1) Step 1 
 (2) Step 2 

 
ท ำไมถงึควรใช้ 
 

ได้มีการปรับปรุงหน้าตาของ holder ให้ใช้งานงา่ยขึน้ โดยการก าหนดมมุเอยีงให้สอดคล้องกบัการซ้อน
กนัของชิน้ท่ีตอ่ด้วย 
 
สำมำรถเรียกค ำสั่งได้ที่ 
 

Application Manufacturing 

Menu Insert→Tool 

Location in dialog 
box 

Create Tool dialog box→Tool Subtype→Milling Tool dialog box Holder 
tab 
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Operation parameters inherited from the tool 
สามารถระบคุา่พารามเิตอร์ดงัตอ่ไปนีไ้ด้ เมื่อท าการสร้างเคร่ืองมอืตดัสว่นใหญ่ 

 Ramp Angle 
 Helical Diameter 
 Min Ramp Length 
 Max Cut Width 

ในเวอร์ชัน่ก่อนหน้านี ้สามารถระบไุด้เพียงภายในการสร้าง operation 

 *หมายเหต ุคา่พารามิเตอร์ดงักลา่วในเวอร์ชัน่ก่อน ยงัคงปิดอยูใ่นการใช้งานในแตล่ะ operation 

ท ำไมถงึควรใช้ 
เพราะคา่พารามเิตอร์จะถกูเก็บในตวั tool โดยสามารถถา่ยทอดความสมัพนัธ์ดงักลา่วไปยงั Cutting 

Parameters และ Non-Cutting Moves ใน operations ที่ใช้ tool ดงักลา่ว ซึง่เป็นประโยชน์มากส าหรับ tool 
แบบตา่งๆ ท่ีใช้ในการกดั ทีส่ามารถตัง้คา่ engage ramp angle และ diameter ตามลกัษณะของ tool ได้ 
 
สำมำรถเรียกค ำสั่งได้ที่ 
 

Application Manufacturing 

Menu Insert→Tool 

Toolbar Insert→Create Tool  

Location in dialog 
box 

Tool Subtype group→Mill Tool Parameters dialog box→More 
tab→Operation Parameters group 

 
 
 
 
 
 
 
 
 
 
 



www.dtm-thailand.com 
 

What’s new in NX8? |  | By Design Through Manufacturing Co., Ltd. 
 

69 

Tool clearance enhancements 
การใช้งาน tool และคา่พารามิเตอร์ของ holder clearance มีการควบคมุคา่ clearance ในแตล่ะสว่น

เพิ่มขึน้ ในการใช้งานการตรวจสอบ tool และ holder เพื่อความปลอดภยัในการท างาน  

 

1. Tool Holder 
2. Tool Shank  
3. Tool Neck  

คา่พารามเิตอร์ของ Clearance สามารถน าไปใช้ได้หลายที่ รวมถงึการตรวจสอบใน operation 
collision, Operation Navigator gouge checking และ tool axis tilting. 

สำมำรถเรียกค ำสั่งได้ที่ 

Application Manufacturing 

Menu Insert→Create Operation 

Location in dialog box Path Settings group→Cutting Parameters→More tab→Clearance group 
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Flute length checking 
Check Flute Length and Depth per Cut ใน customer default ช่วยให้สามารถตรวจสอบคา่ความ

ลกึในการกดัตอ่ความยาวคมตดั ส าหรับเคร่ืองมือตดัทีจ่ะสามารถท าการกดัลกึมากที่สดุ 

 

ถ้า customer default ถกูเลอืกใช้ และคา่ของความยาวคมตดัน้อยกวา่คา่ความลกึในการกดังาน จะมี
ข้อความขึน้เตือนวา่จะท างานตอ่หรือไม ่ 

ท ำไมถงึควรใช้ 
สามารถตรวจสอบได้วา่มีความยาวคมตดัเพียงพอกบัการกดัที่ระบไุว้ใน depth per cut หรือไม ่

 
สำมำรถเรียกค ำสั่งได้ที่ 
 

Application Manufacturing 

Menu File→Utilities→Customer Defaults 

Location in 
dialog box 

Manufacturing→Tools→Validation tab→Milling Operations group→Check 
Flute Length and Depth per Cut 

 

 

 

 

 



www.dtm-thailand.com 
 

What’s new in NX8? |  | By Design Through Manufacturing Co., Ltd. 
 

71 

Manufacturing Milling 

Blank Geometry enhancements 

ปรับปรุงไดอลอกบอกซ์ของ Blank Geometry และเพิ่มออปชัน่ใหมใ่นการชว่ยสร้าง blank geometry 

 Bounding Block 

คล้ายกบัการเลอืกสร้างแบบเดิมคือ Auto Block โดยมีการเพิ่มออบชัน่การก าหนดต าแหนง่และแนว
ทิศทางที่สามารถระบไุด้ จากการเลอืก MCS หรือ Specify CSYS 

 Bounding Cylinder 

สร้างเส้นวงกลมล้อมรอบชิน้งานและท าการยืดออก โดยอ้างองิ MCS จนกระทัง้ครอบชิน้งานเอาไว้
ทัง้หมด 

 *หมายเหต ุBounding Cylinder เหมาะส าหรับชิน้งานท่ีเป็นรูปทรงกลม ในกรณีที่เป็นสีเ่หลีย่มอาจจะต้องมีการ
เพิ่มขนาดด้วยการ offset อยูบ้่าง 

 Part Outline 

Extrudes ตามขอบเขตของชิน้งานด้านนอก จนกระทัง่ครอบชิน้งานไว้ทัง้หมด  

 Part Convex Hull 

เช่ือมตอ่จดุขอบของเส้นด้านนอก ในการสร้างเส้น convex hull และยืดขึน้ไปครอบชิน้งานไว้ทัง้หมด 

 IPW – In Process Workpiece 

ช่วยในการระบแุหลง่ที่มาของ In-process workpiece  

ส าหรับ Bounding Cylinder, Part Outline และ Part Convex Hull สามารถที่จะ 

 ยอมรับคา่ทศิทางในการยดืออก ซึง่ขนานกบัแนวแกน ZM  ของ MCS หรือระบแุนวแกนท่ีแตกตา่ง
ออกไป โดยอ้างองิตามทิศทางของ vector 

 เพิ่มขนาดด้านบน หรือด้านลา่งได้ 
 Offset รัศมีของวงกลม, เส้นรอบนอกของชิน้งาน หรือ convex hull outline 
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ชิน้งานและ convex hull offset outlines ซึง่มีรัศมีที่มมุ 

 

 

สามารถเรียกค าสัง่ได้ที่ 
 

Application Manufacturing 

Toolbar Insert→Create Geometry  

Menu Insert→Create Geometry 

Location in 
dialog box 

Geometry Subtype group→Workpiece or MILL_GEOM  
subtype→Workpiece dialog box→Geometry group→Specify Blank 

→Blank Geometry dialog box→Type group 
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Feed rate setting improvements 

การตัง้คา่ Feed rate ในไดอลอกบอกซ์ของ Feeds and Speeds ส าหรับงานกดัมีการปรับปรุงดงันี ้

Rapid motion output mode 

ในกลุม่ของ Feed Rates ภายใต้ Rapid สามารถตัง้คา่ Output เป็น G0 – Rapid Mode หรือ G1 – 
Feed Mode 

Motion types 

ภายใน More สามารถระบกุารเคลือ่นท่ีโดยใช้ rapid output mode หรือ percent of the cut feed 
rate ตวัอยา่งเช่น จาก Approach list สามารถเลอืกเปลีย่นได้ดงันี ้

 none 
 ipm 
 ipr 
 Rapid 
 %Cut 

Zero feed rates 

อตัราป้อนเป็นศนูย์จะไม่สามารถใสค่า่ได้จากการตัง้คา่เป็นแบบ rapid และ percent of cut feed rate  

ในกรณีก่อนหน้านีจ้ะต้องใสอ่ตัราป้อนเป็นศนูย์ ในการเคลือ่นท่ีอยา่งรวดเร็ว G0 ซึง่ตอนนีเ้ราสามารถ
ระบเุป็นหมวดของ rapid โดยไมต้่องใสค่า่ศนูย์  

ก่อนหน้านีจ้ะมีคา่ทีใ่สไ่ว้เป็นศนูย์ในแตล่ะช่อง ซึง่ปัจจบุนัหากต้องการใสค่า่ สามารถระบเุป็นหมวด
ของ percent of the cut feed rate แล้วจึงใสค่า่ตามต้องการ  

Operation Navigator 

ในกรณีท าการแก้ไข feed rates ใน Operation Navigator ถ้าหลาย operations มีการเลอืกการตัง้คา่
ในรูปแบบเดยีวกนั สามารถแก้ไขทัง้หมด ได้พร้อมกนัในการก าหนดเพียงครัง้เดียว เมื่อแก้ไขทัง้หมดจะ
ท าการแก้ไข feed rates เช่นเดยีวกนั 
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Calculation of related values 

ในไดอลอกบอกซ์ของ Feeds and Speeds แตล่ะช่องค าสัง่ได้แก่ Surface Speed, Feed per Tooth, 
Spindle Speed และ Cut Feed มีปุ่ มกดเพื่อค านวณ feed และรอบให้สอดคล้องกนั แตล่ะปุ่ มกดจะ
สามารถค านวณคา่ให้อกีสามคา่ได้ ถ้ามีปุ่ มใดปุ่ มหนึง่ท างาน สามารถปรับคา่ได้ด้วยการคลกิ OK ถ้า
ไมม่ีปุ่ มกดไหนท างาน แสดงวา่ต้องการคา่ทีใ่ห้ใสเ่ข้าไปก่อน 

Set Machining Data 

เมื่อท าการคลกิ Set Machining Data: 

 Feed rates จะตัง้เป็น percent of the cut feed ซึง่จะไปดงึคา่ Feed ใน feeds and 
speeds database ที่เก็บไว้มาใช้ 

 ส าหรับผู้ที่ก าหนด tracking points ในการสร้าง tool ในสว่นของ diameter ของ tracking 
point จะถกูน ามาใช้ในการชว่ยค านวณ spindle speed หรือ feed rate ด้วย  

Part update 

ชิน้งานจากเวอร์ชัน่ก่อนหน้านี ้ของ NX จะท าการแก้ไขให้อตัโนมตัิเมื่อเปิดใน NX 8 ในสว่นท่ี feed 
เป็นศนูย์จะเปลีย่นเป็น rapid motion หรือ 100% of cut feed ขึน้อยูก่บักฎส าหรับคา่ศนูย์ในเวอร์ชัน่
ก่อนหน้านี ้ 

*หมายเหต ุการเปลีย่นแปลงไมไ่ด้ถกูน าไปใช้กบั Wire EDM feed rates 

 
ท ำไมถงึควรใช้ 

ในสว่นของ rapid mode บางเคร่ืองอาจจะไมไ่ด้เคลือ่นท่ีเป็นเส้นตรง ซึง่อาจท าให้การเคลือ่นท่ี ทีไ่มเ่ป็นไปตาม
ความต้องการ โดยสามารถเปลีย่นแปลงการควบคมุได้ ตวัอยา่งเชน่ การหลกีเลีย่งการชนที่อาจเกิดขึน้ โดย
สามารถระบกุารเคลือ่นท่ีเป็นแบบ feed mode 

สำมำรถเรียกค ำสั่งได้ที่ 

Application Manufacturing 

Prerequisite 
เปิดไดอลอกบอกซ์ของ Feeds and Speeds  หรือใน Operation Navigator เลอืกหนึง่ 
operation หรือหลาย operations ทีต่ัง้คา่เหมือนกนั 
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Variable-axis profiling enhancements 

ปัจจบุนัมีตวัเลอืกตอ่ไปนีใ้นการควบคมุการเคลือ่นท่ีของ cutter และแนวแกน อยูใ่น 
variable-axis profiling 

Automatic             ใช้การวางต าแหนง่เช่นเดียวกบัใน pre-NX 8 เส้นทางเดินเคร่ืองมือตดัแบบเดมิ โดยมีการ
ปรับปรุงการเลอืกให้ดีขึน้ 

Align to Edges      จดัแนว tool ให้สมัผสัขอบของเส้นระหวา่งด้านบน และด้านลา่งของผนงัชิน้งาน 

Swarf Base UV     จดัแนว tool ตามแนว UV ของผนงัชิน้งาน 

 
ท ำไมถงึควรใช้ 

ใช้ variable-axis profile operation ส าหรับ swarf-cut walls เพื่อให้ได้ผลในการสร้าง tool path ที่ดี
ที่สดุ ซึง่สามารถปรับแตง่ต าแหนง่ของเคร่ืองมือตดัในสว่นของทิศทาง lead และ lag ตามพืน้ฐานของ geometry 
ผนงั 

 ใช้ Swarf Base UV option เมื่อมีผิวที่วางแนว UV ได้เหมาะสม  
 ใช้ Align to Edges option เมื่อมีเส้นขอบเป็นแนวที่ด ี
 ใช้ Automatic option ในกรณีอืน่ๆทัง้หมด 

สำมำรถเรียกค ำสั่งได้ที่ 

Application Manufacturing 

Menu 
Create Operation→mill_multi-axis→VARIABLE_CONTOUR→Drive 
Method→Contour Profile 

Location in dialog 
box Axis group→Axis list 
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IPW in Surface Contouring 

สามารถใช้ออปชัน่ของ Cutting Parameters ในสว่นของ Surface Contouring operations ในการลบ
ทางเดินเคร่ืองมือตดัในกรณีทีไ่มม่ีการกนัเนือ้งานท่ีก าหนด และเช่ือมตอ่กบัเส้นทางเดินเคร่ืองมือตดัที่เหลอื ซึง่
การท างานจะรับรู้ถึง blank และ IPW ก่อนหน้า โดยสามารถตัง้คา่ In Process Workpiece เป็น Use 3D  

สามารถใช้ออปชัน่อื่น เพื่อชว่ยลดการกดังานในต าแหนง่ที่ไมม่ีการกดัเนือ้งาน ซึง่ตวัเลอืกตอ่ไปนี ้
สามารถใช้ได้ใน Surface Contouring 

 Hookup Distance ระยะหา่งกวา่ที่ก าหนดจะยก 
 Minimum Cut Length ความยาว tool path น้อยสดุที่จะท าการตดัออก 
 Minimum Material Removed เนือ้วสัดนุ้อยสดุที่จะท าการกดั 

ตวัเลอืกใหมด่งันี ้

Apply to Last Pass   ควบคมุการตดัทางเดิน tool path ชัน้สดุท้าย หรือชัน้ท่ีมเีนือ้ blank คมุได้ไมห่มด 

ถ้าต้องการเก็บบนชิน้งานครัง้สดุท้าย ต้องแนใ่จวา่ได้ท าการคลกิเลอืกออกแล้ว มิฉะนัน้ใน
การกดัละเอียด จะท าการกดัเฉพาะบริเวณที่เป็นเนือ้วสัดทุี่อ้างอิงมาจาก IPW เทา่นัน้ อาจ
ท าให้บางบริเวณไมม่กีารถกูกดั 

Minimize Non Cutting Moves   เพิ่มประสทิธิภาพการกดัด้วยการลดการยกที่ไมต้่องการ 

 

ส าหรับข้อมลูเพิ่มเติมของ Containment tab สามารถดไูด้จาก Manufacturing Milling help. 
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ท ำไมถงึควรใช้ 

ลดเวลาในการกดังานลง เนื่องจาก NX ได้ก าจดัสว่นของเส้นทางเดินเคร่ืองมือตดั ที่คา่ของการ stock 
ไมไ่ด้ท าการลบออกให้ 

 
สำมำรถเรียกค ำสั่งได้ที่ 
 

Application Manufacturing 

Prerequisite 

ต้องเป็น operation ของ surface contouring  

ต้องใช้รูปแบบการกดัแบบ Zig, Zig-Zag, หรือ Zig Zag with Lifts 

Location in dialog 
box 

Cutting Parameters dialog box→Containment tab→Blank group→In 

Process Workpiece list→Use 3D 
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Customize Generic Motion and Probing operations 

สามารถปรับแตง่ Generic Motion และ Probing operations ได้ดงันี ้

 จดัเรียงล าดบัรายการของ sub-operation types ที่ใช้ส าหรับการสร้าง 
 ลบ sub-operation types ที่ไมต้่องการใช้ในรายการของ sub-operation types 

 ก าหนด sub-operations ขึน้เองด้วย User Defined Move dialog item type 
 เพิ่มพารามิเตอร์ให้กบัคา่ default ของ Probing cycles และ Generic Motion moves 

 *หมายเหต ุจะใช้เมื่อต้องการปรับแตง่คา่ของ Probing หรือ Generic Motion dialog box 

 ไมส่ามารถลบหรือแก้ไขพารามเิตอร์ที่มีอยูเ่ดิมใน standard sub-operation ได้ 
 ไมส่ามารถปรับแตง่ sub-operation ปัจจบุนัท่ีก าลงัใช้งานอยู ่เมื่อท าการปรับแตง่ อาจต้องลบ

บางอยา่งของ sub-operation ก่อนที่จะสามารถแก้ไข sub-operation template ได้ 
 สามารถลบ sub-operation type ปัจจบุนัท่ีก าลงัใช้งานอยู ่เมื่อท าการก าหนด instance ที่มีอยูใ่น 

sub-operation จะยงัคงอยูใ่น operation 

สามารถเรียกค าสัง่ได้ที่ 

Application Manufacturing 

Operation 
Navigator Right-click a Probing or Generic Motion operation→Object→Customize 

Dialog box 

Probing or Generic Motion operation dialog box→Options group→Customize 

Dialog  
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Generic Motion enhancements 

Generic Motion operation มีการปรับปรุงดงันี ้

 Rotary Move To Point Suboperation ใน NX8 ถกูเรียกวา่ Rotary Point Vector Move ซึง่ 
suboperation มีคา่ defaults ส าหรับการวางต าแหนง่ tool ที่ดีขึน้ นอกจากนีย้งัมเีคร่ืองมือในการวาง
ต าแหนง่ใหมด้่วย 

 มีสอง suboperations ใหม ่ได้แก่ Follow Curve/Edge และ Follow Part Offset. 

Rotary Point Vector Move 

Rotary Point Vector Move Suboperation สามารถย้ายแบบ dynamic จากต าแหนง่หนึง่ไปยงัอกี
ต าแหนง่หนึง่ หรือเปลีย่นแนวแกนได้  

จาก default สามารถสร้างต าแหนง่ได้จากการก าหนดสองที่ 

 ถ้าท าการยอมรับคา่ในการก าหนดต าแหนง่ tool ก็จะอยูใ่นต าแหนง่ที่ท าการก าหนด 
 ถ้ายงัไมไ่ด้ท าการยอมรับคา่ในการก าหนดต าแหนง่ tool ก็จะยงัคงอยูใ่นต าแหนง่เร่ิมต้นท่ี MCS โดย

อยูใ่นแนวแกน ZM 
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เมื่อ operation มีการระบ ุgeometry สามารถก าหนดต าแหนง่สมัผสัโดยการเลอืกจดุบนผิวของชิน้งาน และได้

เพิ่มออปชัน่   Alternate Solution ในการเลอืกระหวา่ง วางบนต าแหนง่ของ tool หรือท าสมัผสักบัต าแหนง่
ของ tool  

 

Follow Curve/Edge 

ใช้ Follow Curve/Edge Suboperation ตามรูปแบบการเลอืกทศิทางของเส้นได้ดงันี ้ 

 

สามารถทีจ่ะ 

 เลอืกเส้นหรือเส้นขอบส าหรับให้ tool เดิน 
 ระบจุดุเร่ิมต้น, จดุสดุท้าย และแนวแกน 
 ระบคุา่ยดืเส้นสมัผสัออกจากจดุเร่ิมต้น หรือจดุสดุท้าย 

Follow Part Offset 

ใช้ Follow Part Offset Suboperation ตาม cross section ของชิน้งานได้ดงันี ้ 
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สามารถทีจ่ะ 

 ระบจุดุเร่ิมต้นและจดุสดุท้าย 
 ระบแุนวแกน tool 
 ระบคุา่ยดืเส้นสมัผสัออกจากจดุเร่ิมต้น และจดุสดุท้าย 

ท ำไมถงึควรใช้ 

การปรับปรุงชว่ยให้สร้างเส้นทางเดินเคร่ืองมือตดัได้งา่ยขึน้ เมื่อท าการระบตุ าแหนง่ tool โดยวิธีเลอืก
การก าหนดต าแหนง่, แนวแกน, เส้น หรือเส้นขอบของชิน้งาน 

สำมำรถเรียกค ำสั่งได้ที่ 
 

Application Manufacturing 

Toolbar Insert→ Create Operation  

Location in dialog 
box 

Type group→Mill_Multi_Axis or Probing→Operation 

Subtype→GENERIC_MOTION  
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Tilt Tool Axis 

ใช้ Tilt Tool Axis command เพื่อหลกีเลีย่งการชนของ tool holder ใน Surface Contouring 
และ ZLevel tool paths โดย tool path จะมีการตรวจสอบการชนของ tool holder ถ้าพบวา่มีการชน tool axis 
จะถกูปรับ เพื่อหลกีเลีย่งการชน 

ถ้าท าการ generate หลงัจากการเลอืก tilt tool axis ในสว่นของ tilt tool path จะถกู generate ใหม ่
เป็นรูปแบบแค ่3-axis tool path หากต้องการแก้ไข ให้ท าการเลอืก tool axis tilt ใหมอ่ีกครัง้ 

นอกจากนีค้วามสามารถในการหลกีเลีย่งการชนของ Tilt Tool Axis ยงัช่วยให้ tool เข้าถึงต าแหนง่ที่ลกึ 
โดยใช้ tool ที่สัน้ท่ีสดุ เพื่อความแข็งแรงของการใช้งาน  

ในตวัอยา่งนี ้มีการปรับแนวแกน tool เมื่อมีการตรวจพบการชนของ tool holder เพื่อให้สามารถกดั
งานลงไปตามผนงัด้านลา่งของชิน้งานได้ 

 

 
สำมำรถเรียกค ำสั่งได้ที่ 
 

Application Manufacturing 

Prerequisites 

 ใช้งานได้เฉพาะใน Surface Contouring หรือ Zlevel operation 
 ต้องเป็น cutter ชนิด ball mill และมีการก าหนด tool holder 

Operation Navigator Right-click an operation→Tool Path→Tilt Tool Axis  
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Chamfer mill tool type 

ใช้ Chamfer Mill สร้าง tool ส าหรับท ามมุ chamfer 

 

สามารถระบคุา่พารามเิตอร์ของ tool ได้ดงันี ้

 

 (L) Length 
 (FL) Flute Length 
 (C) Chamfer Length 
 (D) Diameter 
 (R1) Lower Radius 
 (B) Chamfer Angle 

ท ำไมถงึควรใช้ 

การใช้ Tool รูปแบบนีม้ีประโยชน์มาก เมื่อใช้กบังาน face mill หรือ chamfered  

สำมำรถเรียกค ำสั่งได้ที่ 

Application Manufacturing 

Menu Insert→Tool 

Toolbar Insert→Create Tool  

Location in dialog 
box 

Type→mill_planar, mill_contour, mill_multi-axis, or mill_multi_blade→Tool 

Subtype→CHAMFER_MILL  
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Spherical mill tool type 

ใช้ Spherical Mill tool type สร้าง ball-shaped tool ส าหรับลดคา่เส้นผา่นศนูย์กลางชว่งคอลง tool ชนิด
นีช้่วยให้สามารถท างานในบริเวณที่เป็น ports และ undercuts ได้ 

 

สามารถก าหนดรูปร่างของ tool ที่ใช้ได้ตามคา่พารามเิตอร์ดงันี ้

 

 (L) Length 
 (ND) Neck Diameter 
 (FL) Flute Length 
 (D) Diameter 
 Number of Flutes 

 
สำมำรถเรียกค ำสั่งได้ที่ 
 

Application Manufacturing 

Menu Insert→Tool 

Toolbar Insert→Create Tool  

Location in dialog 
box 

Type→mill_planar, mill_contour, mill_multi-axis, or mill_multi_blade→Tool 

Subtype→SPHERICAL_MILL  
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Multi Blade Milling 
 
Multi Blade — Interpolate Vector 

สามารถใช้ออบชัน่ Interpolate Vector tool axis option ในการควบคมุลกัษณะการเคลือ่นท่ีของ tool 
โดยผู้ใช้งานสามารถแก้ไขการแนวหมนุของ Tool ที่ต าแหนง่จดุตา่งๆ และสามารถเพิม่จดุต าแหนง่ หรือ
ปรับเปลีย่นจดุตามแนวต า่สดุและสงูสงุของชัน้การตดั โดยการก าหนดคา่ออบชัน่ดงักลา่วจะชว่ยให้การตดั 
smooth และ หลกีเลีย่งการตดัเกินเข้าไปในชิน้งาน  

 
Preview of tool orientations showing gouges 

 
Preview of interpolated vectors 

สำมำรถเรียกค ำสั่งได้ที่ 
 

Application Manufacturing 

Prerequisite Requires the NX Turbo Machinery Add-on license. 

Toolbar Insert→Create Operation  

Menu Insert→Operation 

Location in 
dialog box 

Type group→mill_multi_blade→Operation Subtype 

group→MULTI_BLADE_ROUGH , HUB_FINISH , BLADE_FINISH 

, or BLEND_FINISH  

[Operation] dialog box→Tool Axis group 
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Multi Blade Blend Finish operations 

ใช้ Multi Blade Blend Finishing operations ส าหรับเก็บละเอียดผิว blend จาก blade impellers 
และ blisks ซึง่สามารถเก็บละเอยีด blade ที่มีขนาดใหญ่กวา่ tool และเก็บละเอยีดพืน้ท่ีระหวา่ง blade และ 
hub ที่เลก็กวา่ tool  

 

สำมำรถเรียกค ำสั่งได้ที่ 
 

Application Manufacturing 

Prerequisite Requires the NX Turbomachinery Milling Add-on license 

Toolbar Insert→Create Operation  

Menu Insert→Operation 

Location in dialog 
box 

Type group→mill_multi_blade→Operation Subtype 

group→BLEND_FINISH  
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Additional Multi Blade enhancements 

สามารถยืด tool path ให้ tangential ออกมาในงาน Blade Finish และ Blend Finish  
ในงาน Blade Finish ยงัรวมถงึคา่ยืด tool path ของ Helical cut pattern ด้วย 

 

Blade Finish — all sides, helical cut pattern 

                                                     

Blade Finish — Left, Right, Leading Edge, 
without extensions 

Blade Finish — Left, Right, Leading Edge, 
with tangential extensions 

สำมำรถเรียกค ำสั่งได้ที่ 

Application Manufacturing 

Prerequisite Requires the NX Turbomachinery Milling Add-on license 

Toolbar Insert→Create Operation  

Menu Insert→Operation 

Location in dialog 
box 

Type group→mill_multi_blade→Operation Subtype group→BLADE_FINISH 

or BLEND_FINISH  
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Hole Milling 
Hole milling operations 

ใช้ HOLE_MILLING operation type ในการ machine holes และ cylindrical bosses โดยไม่
จ าเป็นต้องม ีFeature-based Machining สามารถที่จะ 

 ใช้การอ้างอิง tool ที่ใช้อยู ่      
 กลบัทิศทางการท างาน โดยไมม่ผีลตอ่แนวทางการท างาน  
 ตรวจสอบการเคลือ่นท่ีด้วย Gouge check 
 ท างานรวมกนัได้ทัง้รูทะล ุและไมท่ะล ุ
 ยืดการกดัได้ทัง้จดุเข้างาน และจดุจบการท างาน 
 ระบรูุปแบบการกดัได้ทัง้ helical และ spiral  
 ตัง้คา่ได้หลาย radial เพื่อให้สามารถท างานได้หลายชัน้ของ stepover  
 ตัง้คา่ multiple axial stepovers ส าหรับ Spiral and Helical/Spiral cut patterns. 

 

 

การสร้างการกดัแบบ Helical ส าหรับตามแนวแกน 

1. เคลือ่นท่ีกดังานตามรูปแบบ helical  
2. มี option ในการล้างชัน้สดุท้ายของความลกึของ hole หรือ boss 

 

 

การสร้างการกดัแบบ Spiral ส าหรับการกดัระหวา่งชัน้เดียวกนั 

1. เคลือ่นท่ีกดังานตามรูปแบบ spiral  
2. มี option ในการล้างชัน้สดุท้ายของ diameter เพื่อให้ได้ขนาด finish 

 

 

การสร้างการกดัแบบ Helical/Spiral ท าได้ดงันี ้

1. เคลือ่นท่ีกดังานตามรูปแบบ helical บริเวณจดุศนูย์กลางรูลงไปตามแนวแกน 
2. เคลือ่นท่ีกดังานตามรูปแบบ spiral ช่วยเพิ่มคา่ diameter ระหวา่งชัน้การกดั 
3. มี option ในการล้างชัน้สดุท้ายของ diameter เพื่อให้ได้ขนาด finish 
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สำมำรถเรียกค ำสั่งได้ที่ 
 

Application Manufacturing 

Toolbar Insert→Create Operation  

Menu Insert→Operation 

Location in dialog 
box 

Type→hole_making/drill/planar_mill→Operation 

Subtype→HOLE_MILLING  
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Hole/Boss geometry object 
 

ใช้ Hole/Boss geometry ช่วยในการก าหนดต าแหนง่ hole และ boss โดยไมต้่องใช้ข้อมลูของ thread 
สามารถใช้ geometry ของชิน้งานเพื่อใช้ส าหรับสร้าง HOLE_MILLING และ THREAD_MILLING  

 HOLE_MILLING operations ใช้ได้กบั Hole, Boss, Threaded Hole และ Threaded Boss 
geometry 

 THREAD_MILLING operations จะต้องมีข้อมลูของ thread และใช้ได้แค ่Threaded Hole 
และ Threaded Boss geometry 

สามารถระบ ุhole milling geometry โดยเลอืกสิง่ตา่งๆดงันี ้

 Points 
 Curves 
 Arcs 
 Cylindrical edges 
 Cylindrical faces 

ท ำไมถงึควรใช้ 
Hole/Boss geometry object ชว่ยให้ก าหนดการท างานของ holes and bosses ที่มีความแตกตา่งกนัของ
แนวแกน, ขนาดเส้นผา่นศนูย์กลาง หรือความลกึได้  
 
สำมำรถเรียกค ำสั่งได้ที่ 
 
Application Manufacturing 
Toolbar 

Insert→Create Geometry  
Menu Insert→Geometry 
Location in 
dialog box 

Type group→mill_planar/Drill/hole_making→Geometry Subtype 

group→HOLE_BOSS_GEOM  
 
 
 
 


